Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718730 - dev-dotnet/mono-addins-1.0-r1 compilation fails: Strong name cannot be verified for delay-signed assembly
Summary: dev-dotnet/mono-addins-1.0-r1 compilation fails: Strong name cannot be verifi...
Status: RESOLVED DUPLICATE of bug 644232
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-21 11:51 UTC by Andrew
Modified: 2020-07-23 14:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,25.29 KB, text/x-log)
2020-04-21 11:53 UTC, Andrew
Details
emerge --info (emerge_info.txt,5.89 KB, text/plain)
2020-04-21 11:57 UTC, Andrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2020-04-21 11:51:36 UTC
dev-dotnet/mono-addins-1.0-r1 compilation fails: Strong name cannot be verified for delay-signed assembly. 

Build.log file fragment:

...
aking install in Mono.Addins
make[1]: Entering directory '/var/tmp/portage/dev-dotnet/mono-addins-1.0-r1/work/mono-addins-mono-addins-1.0/Mono.Addins'
make[2]: Entering directory '/var/tmp/portage/dev-dotnet/mono-addins-1.0-r1/work/mono-addins-mono-addins-1.0/Mono.Addins'
/usr/bin/gacutil /i ../bin/Mono.Addins.dll /f /package mono-addins /root /var/tmp/portage/dev-dotnet/mono-addins-1.0-r1/imag>
Failure adding assembly ../bin/Mono.Addins.dll to the cache: Strong name cannot be verified for delay-signed assembly
make[2]: *** [Makefile:552: gac-install] Error 1
...

Reproducible: Always
Comment 1 Andrew 2020-04-21 11:53:33 UTC
Created attachment 634008 [details]
build.log
Comment 2 Andrew 2020-04-21 11:57:06 UTC
Created attachment 634010 [details]
emerge --info
Comment 3 PhobosK 2020-07-23 10:04:05 UTC
Duplicate of the older bug #644232 ?
Comment 4 Sam James archtester gentoo-dev Security 2020-07-23 14:26:03 UTC

*** This bug has been marked as a duplicate of bug 644232 ***