Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 7187 - php compile errors
Summary: php compile errors
Status: RESOLVED DUPLICATE of bug 3876
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Ryan Phillips (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-28 16:21 UTC by Seemant Kulleen (RETIRED)
Modified: 2005-07-17 13:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Seemant Kulleen (RETIRED) gentoo-dev 2002-08-28 16:21:10 UTC
<Lisa[NY]> libtool: link: warning: library `/usr/lib/libxmlparse.la' was moved.
<Lisa[NY]> libtool: link: warning: library `/usr/lib/libxmltok.la' was moved.
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `operator new[](unsigned)'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `vtable for
__cxxabiv1::__si_class_type_info'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `operator delete(void*)'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `__gxx_personality_v0'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `__cxa_pure_virtual'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `vtable for
__cxxabiv1::__class_type_info'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `operator delete[](void*)'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `vtable for
__cxxabiv1::__vmi_class_type_info'
<Lisa[NY]> /usr/lib/libsablot.so: undefined reference to `operator new(unsigned)'
Comment 1 Lisa Seelye (RETIRED) gentoo-dev 2002-08-28 16:25:00 UTC
This was with GCC 3.2, by the way.

Changing the make.conf to -`xml -xml2` (instead of simply `xml 
xml2`) was a fix.

It appears this is a problem with XMP and dev-php/php-4.2.2-r1.
Comment 2 Seemant Kulleen (RETIRED) gentoo-dev 2002-08-28 16:33:09 UTC
http://forums.gentoo.org/viewtopic.php?t=7575&highlight=php+xml
Comment 3 Ryan Phillips (RETIRED) gentoo-dev 2002-08-30 12:09:31 UTC
Azarah (Martin): PHP needs libiconv as a dependency to include sablotron 
support with the XML flag and noticed it was masked.... Is there any way around 
this?
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2002-08-30 15:14:44 UTC
libiconv is part of glibc ...

Anyhow, that seems more like libstdc++ linkage problems (like in not linking
to it when it should).
Comment 5 Ryan Phillips (RETIRED) gentoo-dev 2002-09-01 21:12:25 UTC
Lisa: did you upgrade gcc or is this on a brand new installation?
Comment 6 Lisa Seelye (RETIRED) gentoo-dev 2002-09-01 21:23:09 UTC
No, what I did was,

Boot from a 1.2 CD
Wget the 1.4 .bz2 and continue from the 1.2 guide.

So 
this is NOT an upgraded GCC 3.2.

(thanks for the cc, btw)
Comment 7 Ryan Phillips (RETIRED) gentoo-dev 2002-09-02 00:27:34 UTC
export LDFLAGS='-lstdc++' 
emerge sablotron 
emerge php 



*** This bug has been marked as a duplicate of 3876 ***