Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718242 - app-portage/g-sorcery: need py3.7, 3.8 port
Summary: app-portage/g-sorcery: need py3.7, 3.8 port
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Layman Overlay Manager project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: python3.7-compat
  Show dependency tree
 
Reported: 2020-04-19 13:24 UTC by Michał Górny
Modified: 2020-04-24 21:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-04-19 13:24:22 UTC
The packages are stuck on py3.6 which means they will be pain once we switch to 3.7.  Please test them on 3.7 *and* 3.8 (so we don't to revisit this in a few months), and update PYTHON_COMPAT appropriately.  If it doesn't work, please either fix it, remove Python or issue last rites.  Please consider this urgent.
Comment 1 Brian Dolbec gentoo-dev 2020-04-23 20:18:19 UTC
So far it is not going well.  I am getting 2 test fails in both 3.7 and 3.8 while they all pass in 3.6.

Also python 3.7 and 3.8 are both failing to exit from the tests correctly and I have to control "c" to get it to exit.  It also locks up the same for a 'FEATURES="TEST" emerge ...' run.
Comment 2 Brian Dolbec gentoo-dev 2020-04-24 21:55:22 UTC
I've fixed the issue and patched the ebuild with the needed fixes.

It is now 3.7, 3.8 enabled