Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718154 - www-apache/mod_security-2.9.1-r1 fails to build with USE=fuzzyhash
Summary: www-apache/mod_security-2.9.1-r1 fails to build with USE=fuzzyhash
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-19 10:50 UTC by Giuseppe Foti
Modified: 2020-04-21 00:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,6.99 KB, application/x-info)
2020-04-19 10:50 UTC, Giuseppe Foti
Details
$ emerge --info www-apache/mod_security (emerge.info,7.39 KB, application/x-info)
2020-04-20 12:31 UTC, Giuseppe Foti
Details
build.log.xz (build.log.xz,5.25 KB, application/x-xz)
2020-04-20 12:42 UTC, Giuseppe Foti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe Foti 2020-04-19 10:50:45 UTC
Created attachment 633696 [details]
emerge --info

the build fails with:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/libuuid.so when searching for -luuid
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/librt.so when searching for -lrt
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/librt.a when searching for -lrt
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/libcrypt.so when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/libcrypt.a when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/libpthread.so when searching for -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr//lib/libpthread.a when searching for -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/libdb-5.3.so: error adding symbols: file in wrong format
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:681: mod_security2.la] Error 1
make[2]: Leaving directory '/var/tmp/portage/www-apache/mod_security-2.9.1-r1/work/modsecurity-2.9.1/apache2'
make[1]: *** [Makefile:580: all] Error 2
make[1]: Leaving directory '/var/tmp/portage/www-apache/mod_security-2.9.1-r1/work/modsecurity-2.9.1/apache2'
make: *** [Makefile:489: all-recursive] Error 1
Comment 1 Jonas Stein gentoo-dev 2020-04-19 15:40:30 UTC
Thank you for the report. We need to have all information at hand before ticket assignment. That is why I ask you to 
* attach the logs  
as described on 
https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
Please reopen this ticket (Status:UNCONFIRMED) afterwards.

please test also version 2.9.3
Comment 2 Giuseppe Foti 2020-04-20 12:31:17 UTC
Created attachment 633838 [details]
$ emerge --info www-apache/mod_security
Comment 3 Giuseppe Foti 2020-04-20 12:42:33 UTC
Created attachment 633840 [details]
build.log.xz