Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718138 - net-libs/rpcsvc-proto calls cpp directly
Summary: net-libs/rpcsvc-proto calls cpp directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-04-19 08:57 UTC by Agostino Sarubbo
Modified: 2020-04-19 10:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.65 KB, text/plain)
2020-04-19 08:57 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-19 08:57:28 UTC
This is an auto-filled bug because net-libs/rpcsvc-proto calls cpp directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to temporarily move the /usr/bin/cpp binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-19 08:57:34 UTC
Created attachment 633676 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-04-19 10:15:50 UTC
rpcgen calls /lib/cpp explicitly right from code:
  https://github.com/thkukuk/rpcsvc-proto/blob/master/rpcgen/rpc_main.c

The only thing it allows to override is the directory where 'cpp' resides.

    static const char *CPP = "/lib/cpp";
    static const char CPPFLAGS[] = "-C";

		case 'Y':
		  if (++i == argc)
		    return 0;
		  {
                    // ...
		    stpcpy (stpcpy (pathbuf,
				    argv[i]),
			    "/cpp");
		    CPP = pathbuf;
		    cppDefined = 1;
		    goto nextarg;
		  }

Using @CPP@ should work.
Comment 3 Larry the Git Cow gentoo-dev 2020-04-19 10:48:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b33a731e18e03cb49560abf4ac4b49011e27140e

commit b33a731e18e03cb49560abf4ac4b49011e27140e
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-04-19 10:47:18 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-04-19 10:47:59 +0000

    net-libs/rpcsvc-proto: for fallback use ${CHOST}-cpp, not 'cpp'
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/718138
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 net-libs/rpcsvc-proto/rpcsvc-proto-1.4.1-r1.ebuild | 38 ++++++++++++++++++++++
 1 file changed, 38 insertions(+)