Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718028 - app-crypt/pinentry calls ar directly
Summary: app-crypt/pinentry calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Kristian Fiskerstrand (RETIRED)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-04-18 10:20 UTC by Agostino Sarubbo
Modified: 2020-06-12 23:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,14.32 KB, text/plain)
2020-04-18 10:21 UTC, Agostino Sarubbo
Details
pinentry-1.0.0-AR.patch (pinentry-1.0.0-AR.patch,326 bytes, patch)
2020-05-28 06:43 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-18 10:20:56 UTC
This is an auto-filled bug because app-crypt/pinentry calls ar directly.
The issue was originally discovered on x86, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to temporarily move the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-18 10:21:01 UTC
Created attachment 633562 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-05-28 06:43:04 UTC
Created attachment 642144 [details, diff]
pinentry-1.0.0-AR.patch
Comment 3 Larry the Git Cow gentoo-dev 2020-06-12 23:14:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2c53a9350cfb5b89c7b7fb6d4747ffc6541085c9

commit 2c53a9350cfb5b89c7b7fb6d4747ffc6541085c9
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-06-12 23:13:55 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-06-12 23:13:55 +0000

    app-crypt/pinentry: respect user's AR setting
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/718028
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 app-crypt/pinentry/files/pinentry-1.0.0-AR.patch | 11 +++++++++++
 app-crypt/pinentry/pinentry-1.1.0-r3.ebuild      |  1 +
 2 files changed, 12 insertions(+)