Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718004 - sys-devel/gcc-9.3.0 (and older) fails to compile: /bin/bash: ar: command not found when /usr/bin/ar is missing
Summary: sys-devel/gcc-9.3.0 (and older) fails to compile: /bin/bash: ar: command not ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL: https://gcc.gnu.org/PR94657
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-18 07:42 UTC by Agostino Sarubbo
Modified: 2020-05-29 21:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,292.99 KB, text/plain)
2020-04-18 07:42 UTC, Agostino Sarubbo
Details
libcpp-ar.patch (libcpp-ar.patch,3.26 KB, patch)
2020-04-18 13:27 UTC, Sergei Trofimovich
Details | Diff
libcpp-ar.patch (libcpp-ar.patch,3.47 KB, patch)
2020-04-19 08:27 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-18 07:42:43 UTC
This is an auto-filled bug because sys-devel/gcc fails to compile on amd64. Feel free to adjust the summary to clarify the exact issue. Attached build log and emerge --info
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-18 07:42:51 UTC
Created attachment 633518 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-04-18 08:08:08 UTC
Your system lacks 'ar' command. Is it on purpose? Can you post the following:

$ ar --version
(mine is: GNU ar (Gentoo 2.34 p1) 2.34.0)
$ which ar
(mine is /usr/bin/ar)
$ ls -l /usr/bin/ar
(mine is: lrwxrwxrwx 1 root root 22 мар 17 22:42 /usr/bin/ar -> x86_64-pc-linux-gnu-ar)

Looks like a missing 'binutils-config' run to set up symlinks.

"""
checking whether x86_64-pc-linux-gnu-gcc supports -Wold-style-definition... rm -f libcpp.a
ar cru libcpp.a charset.o directives.o directives-only.o errors.o expr.o files.o identifiers.o init.o lex.o line-map.o macro.o mkdeps.o pch.o symtab.o traditional.o
/bin/bash: ar: command not found
make[3]: *** [Makefile:101: libcpp.a] Error 127
make[3]: Leaving directory '/var/tmp/portage/sys-devel/gcc-8.4.0/work/build/build-x86_64-pc-linux-gnu/libcpp'
make[2]: *** [Makefile:2801: all-build-libcpp] Error 2
make[2]: *** Waiting for unfinished jobs....
yes
...
config.status: executing default commands
make[2]: Leaving directory '/var/tmp/portage/sys-devel/gcc-8.4.0/work/build'
make[1]: *** [Makefile:23100: stage1-bubble] Error 2
make[1]: Leaving directory '/var/tmp/portage/sys-devel/gcc-8.4.0/work/build'
make: *** [Makefile:23432: bootstrap-lean] Error 2
 * ERROR: sys-devel/gcc-8.4.0::gentoo failed (compile phase):
 *   emake failed
"""
Comment 3 Agostino Sarubbo gentoo-dev 2020-04-18 08:21:20 UTC
(In reply to Sergei Trofimovich from comment #2)
> Your system lacks 'ar' command. Is it on purpose? Can you post the following:

Yes, this is on purpose to catch packages that call tools directly.ù

x86_64-pc-linux-gnu-ar should be used via tc-export AR (I guess)
Comment 4 Sergei Trofimovich gentoo-dev 2020-04-18 08:34:35 UTC
(In reply to Agostino Sarubbo from comment #3)
> (In reply to Sergei Trofimovich from comment #2)
> > Your system lacks 'ar' command. Is it on purpose? Can you post the following:
> 
> Yes, this is on purpose to catch packages that call tools directly.ù

Please document your setup somewhere so I could replicate it in chroot.

> x86_64-pc-linux-gnu-ar should be used via tc-export AR (I guess)

Yeah. Packages that support cross-compilation like gcc usually should set AC_PROG_AR in configure phase to resolve it to Makefile's $(AR) based on --build/--host/--target.

Most of gcc's libraries do it correctly, but not libcpp. Let's see if we can fix it with a configure's one-liner.
Comment 5 Agostino Sarubbo gentoo-dev 2020-04-18 08:39:04 UTC
(In reply to Sergei Trofimovich from comment #4)
> Please document your setup somewhere so I could replicate it in chroot.

Sure..

I'm doing "rm -fr /usr/bin/{gcc,cc,cpp,c++,g++,ld,nm,ar,ranlib,gcov,as}" before doing the merge.
To reproduce you can do "mv /usr/bin/ar /whatever" and then move it back when you are done.
Comment 6 Sergei Trofimovich gentoo-dev 2020-04-18 13:27:16 UTC
Created attachment 633580 [details, diff]
libcpp-ar.patch

Let's see if libcpp-ar.patch will be enough.
Comment 7 Agostino Sarubbo gentoo-dev 2020-04-18 13:38:51 UTC
(In reply to Sergei Trofimovich from comment #6)
> Created attachment 633580 [details, diff] [details, diff]
> libcpp-ar.patch
> 
> Let's see if libcpp-ar.patch will be enough.

if you can reproduce my moving ar somewhere and the patch works for you then I trust you =)
Comment 8 Sergei Trofimovich gentoo-dev 2020-04-18 16:53:58 UTC
(In reply to Agostino Sarubbo from comment #7)
> (In reply to Sergei Trofimovich from comment #6)
> > Created attachment 633580 [details, diff] [details, diff] [details, diff]
> > libcpp-ar.patch
> > 
> > Let's see if libcpp-ar.patch will be enough.
> 
> if you can reproduce my moving ar somewhere and the patch works for you then
> I trust you =)

Yeah, I reproduced failure locally and patch does not help. Looking further.
Comment 9 Sergei Trofimovich gentoo-dev 2020-04-19 08:27:07 UTC
Created attachment 633664 [details, diff]
libcpp-ar.patch

Updated patch should get up past libcpp (previously Makefile.in did not do substitution).
Comment 10 Sergei Trofimovich gentoo-dev 2020-04-19 09:42:26 UTC
Filed upstream bug: https://gcc.gnu.org/PR94657

I don't think it's a regression.
Comment 11 Larry the Git Cow gentoo-dev 2020-04-19 09:46:48 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=93ba4381579701e69ad2a0f9b065d5af4879c674

commit 93ba4381579701e69ad2a0f9b065d5af4879c674
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-04-19 09:46:22 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-04-19 09:46:22 +0000

    8.4.0: fix libcpp ar detection
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 8.4.0/gentoo/29_all_libcpp-ar.patch | 143 ++++++++++++++++++++++++++++++++++++
 8.4.0/gentoo/README.history         |   3 +
 2 files changed, 146 insertions(+)

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=baf79867c63ff919483051395b518822fa501a41

commit baf79867c63ff919483051395b518822fa501a41
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-04-19 09:45:02 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-04-19 09:45:02 +0000

    9.3.0: fix libcpp ar detection
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 9.3.0/gentoo/29_all_libcpp-ar.patch | 143 ++++++++++++++++++++++++++++++++++++
 9.3.0/gentoo/README.history         |   3 +
 2 files changed, 146 insertions(+)
Comment 12 Sergei Trofimovich gentoo-dev 2020-04-19 09:57:50 UTC
(In reply to Agostino Sarubbo from comment #5)
> (In reply to Sergei Trofimovich from comment #4)
> > Please document your setup somewhere so I could replicate it in chroot.
> 
> Sure..
> 
> I'm doing "rm -fr /usr/bin/{gcc,cc,cpp,c++,g++,ld,nm,ar,ranlib,gcov,as}"
> before doing the merge.
> To reproduce you can do "mv /usr/bin/ar /whatever" and then move it back
> when you are done.

I think detecting these kinds of issues only during stabilization is quite late. 

Fixes will certainly change the behaviour of the build system and would probably require more soaking time in ~arch. But given that users don't actually experience problems most of the time it would be unfortunate to block stabilization for extra time.

Detecting most of such issues on earlier phase (say, in ~arch) should decrease probability of also popping up during stabilization process.

Toralf, WDYT of also adding Agostino's file removal into tinderbox runs as well?

I suspect huge initial breakage. But maybe it will not be that bad.
Comment 13 Toralf Förster gentoo-dev 2020-04-19 10:20:47 UTC
(In reply to Sergei Trofimovich from comment #12)
> Toralf, WDYT of also adding Agostino's file removal into tinderbox runs as
> well?
> 
> I suspect huge initial breakage. But maybe it will not be that bad.

You mean "rm -fr /usr/bin/{gcc,cc,cpp,c++,g++,ld,nm,ar,ranlib,gcov,as}" before gcc will be emerged?

/me wonders whether this can be handled via "emerge -u gcc" or whether than each ebuild phase needs to be called explicitly?

Furthermore I do "emerge -u =\$(portageq best_visible / sys-devel/gcc) dev-libs/mpc dev-libs/mpfr" very early after setup of a newe image - works now since years. I do wonder how to achieve that otehrwise?
Comment 14 Sergei Trofimovich gentoo-dev 2020-04-19 11:31:03 UTC
(In reply to Toralf Förster from comment #13)
> (In reply to Sergei Trofimovich from comment #12)
> > Toralf, WDYT of also adding Agostino's file removal into tinderbox runs as
> > well?
> > 
> > I suspect huge initial breakage. But maybe it will not be that bad.
> 
> You mean "rm -fr /usr/bin/{gcc,cc,cpp,c++,g++,ld,nm,ar,ranlib,gcov,as}"
> before gcc will be emerged?
> 
> /me wonders whether this can be handled via "emerge -u gcc" or whether than
> each ebuild phase needs to be called explicitly?
> 
> Furthermore I do "emerge -u =\$(portageq best_visible / sys-devel/gcc)
> dev-libs/mpc dev-libs/mpfr" very early after setup of a newe image - works
> now since years. I do wonder how to achieve that otehrwise?

Good question. I don't know. Maybe we should add gcc-config / binutils-config modes first to omit non ${CTARGET}-* tools. I'll have a look at that first.
Comment 15 Sergei Trofimovich gentoo-dev 2020-05-21 17:54:54 UTC
(In reply to Sergei Trofimovich from comment #14)
> (In reply to Toralf Förster from comment #13)
> > (In reply to Sergei Trofimovich from comment #12)
> > > Toralf, WDYT of also adding Agostino's file removal into tinderbox runs as
> > > well?
> > > 
> > > I suspect huge initial breakage. But maybe it will not be that bad.
> > 
> > You mean "rm -fr /usr/bin/{gcc,cc,cpp,c++,g++,ld,nm,ar,ranlib,gcov,as}"
> > before gcc will be emerged?
> > 
> > /me wonders whether this can be handled via "emerge -u gcc" or whether than
> > each ebuild phase needs to be called explicitly?
> > 
> > Furthermore I do "emerge -u =\$(portageq best_visible / sys-devel/gcc)
> > dev-libs/mpc dev-libs/mpfr" very early after setup of a newe image - works
> > now since years. I do wonder how to achieve that otehrwise?
> 
> Good question. I don't know. Maybe we should add gcc-config /
> binutils-config modes first to omit non ${CTARGET}-* tools. I'll have a look
> at that first.

Will be sorted in https://bugs.gentoo.org/724454
Comment 16 Sergei Trofimovich gentoo-dev 2020-05-22 21:00:56 UTC
(In reply to Toralf Förster from comment #13)
> (In reply to Sergei Trofimovich from comment #12)
> > Toralf, WDYT of also adding Agostino's file removal into tinderbox runs as
> > well?
> > 
> > I suspect huge initial breakage. But maybe it will not be that bad.
> 
> You mean "rm -fr /usr/bin/{gcc,cc,cpp,c++,g++,ld,nm,ar,ranlib,gcov,as}"
> before gcc will be emerged?
> 
> /me wonders whether this can be handled via "emerge -u gcc" or whether than
> each ebuild phase needs to be called explicitly?
> 
> Furthermore I do "emerge -u =\$(portageq best_visible / sys-devel/gcc)
> dev-libs/mpc dev-libs/mpfr" very early after setup of a newe image - works
> now since years. I do wonder how to achieve that otehrwise?

Finally implemented in https://bugs.gentoo.org/724454

The following should be enough to enable mode without native symlinks on tinderbox:
- USE=-native-symlinks for sys-devel/binutils-config (starting from 5.3)
- USE=-native-symlinks for sys-devel/gcc-config (starting from 2.3)

The effect is removed links like:
- /lib/cpp
- /usr/bin/{gcc,cc,g++,c++,...}
- /usr/bin/{as,ld,ranlib,dwp,...}
Comment 17 Larry the Git Cow gentoo-dev 2020-05-29 07:07:34 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=af4164c093d4682a080c240a9840eb4dbb13e3e4

commit af4164c093d4682a080c240a9840eb4dbb13e3e4
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 07:07:17 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 07:07:17 +0000

    9.2.0: fix libcpp ar detection
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 9.2.0/gentoo/38_all_libcpp-ar.patch | 143 ++++++++++++++++++++++++++++++++++++
 9.2.0/gentoo/README.history         |   1 +
 2 files changed, 144 insertions(+)
Comment 18 Larry the Git Cow gentoo-dev 2020-05-29 07:54:51 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=36520630857a9e125c0f4c25c7f03a02ee06d8ab

commit 36520630857a9e125c0f4c25c7f03a02ee06d8ab
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 07:53:56 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 07:53:56 +0000

    8.3.0: fix libcpp ar detection, backport whitespace change
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Reported-by: Jeroen Roovers
    Bug: https://bugs.gentoo.org/725676
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 8.3.0/gentoo/35_all_libcpp-ar.patch     | 143 ++++++++++++++++++++++++++++++++
 8.3.0/gentoo/36_all_whitespace-pa.patch |  27 ++++++
 8.3.0/gentoo/README.history             |   4 +
 3 files changed, 174 insertions(+)
Comment 19 Larry the Git Cow gentoo-dev 2020-05-29 08:31:31 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=c3220a3d428e7c5100347c953d16838c495978ae

commit c3220a3d428e7c5100347c953d16838c495978ae
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 08:31:11 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 08:31:11 +0000

    7.5.0: fix libcpp ar detection
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 7.5.0/gentoo/24_all_libcpp-ar.patch | 143 ++++++++++++++++++++++++++++++++++++
 7.5.0/gentoo/README.history         |   3 +
 2 files changed, 146 insertions(+)
Comment 20 Larry the Git Cow gentoo-dev 2020-05-29 18:17:37 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=9076212373bfaed5b0603a6670dd92b6b7deb861

commit 9076212373bfaed5b0603a6670dd92b6b7deb861
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 18:17:18 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 18:17:18 +0000

    6.5.0: fix libcpp ar detection, backport whitespace change
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Reported-by: Jeroen Roovers
    Bug: https://bugs.gentoo.org/725676
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 6.5.0/gentoo/26_all_libcpp-ar.patch     | 143 ++++++++++++++++++++++++++++++++
 6.5.0/gentoo/27_all_whitespace-pa.patch |  28 +++++++
 6.5.0/gentoo/README.history             |   4 +
 3 files changed, 175 insertions(+)
Comment 21 Larry the Git Cow gentoo-dev 2020-05-29 21:27:21 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=2e352a647976fb24448244759d8c63a212e3d778

commit 2e352a647976fb24448244759d8c63a212e3d778
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:19:42 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:19:42 +0000

    5.5.0: cut 3 patchset
    
    Two new patches:
    + 26_all_libcpp-ar.patch: respect user's AR
    + 27_all_alignof-failure-PR90736.patch: avoid gcc ICE in templates
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 5.5.0/gentoo/README.history | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=ee123ef6de6bdce12afbd801604342349765371e

commit ee123ef6de6bdce12afbd801604342349765371e
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:16:19 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:16:19 +0000

    6.5.0: cut 4 patchset
    
    Two new patches:
    + 26_all_libcpp-ar.patch: respect user's AR
    + 27_all_alignof-failure-PR90736.patch: avoid gcc ICE in templates
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 6.5.0/gentoo/README.history | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=b4ca71db73bf84f09c7b25652d775b48c6134a0f

commit b4ca71db73bf84f09c7b25652d775b48c6134a0f
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:13:49 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:13:49 +0000

    7.5.0: cut 3 patchset
    
    One new patch:
    - 29_all_libcpp-ar.patch: respect user's AR
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 7.5.0/gentoo/README.history | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=cf528552812b5776e3cb40c9d1e9cbcf5560faac

commit cf528552812b5776e3cb40c9d1e9cbcf5560faac
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:08:45 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:08:45 +0000

    8.4.0: cut 2 patchset
    
    Two new patches:
    + 29_all_libcpp-ar.patch: respect user's AR
    + 30_all_alignof-failure-PR90736.patch: avoid gcc ICE in templates
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 8.4.0/gentoo/README.history | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=ab6ae685eb5c56d622cb74c2a8b81a0e565e12aa

commit ab6ae685eb5c56d622cb74c2a8b81a0e565e12aa
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:03:53 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:03:53 +0000

    9.3.0: cut 3 patchset
    
    One new patch:
    - 29_all_libcpp-ar.patch: respect user's AR
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 9.3.0/gentoo/README.history | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=ea14fd9ff6024eb1611f4b43cbf2a7f844cac0ab

commit ea14fd9ff6024eb1611f4b43cbf2a7f844cac0ab
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 18:34:31 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 18:34:31 +0000

    5.5.0: fix libcpp ar detection, backport whitespace change
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Reported-by: Jeroen Roovers
    Bug: https://bugs.gentoo.org/725676
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 5.5.0/gentoo/38_all_libcpp-ar.patch     | 143 ++++++++++++++++++++++++++++++++
 5.5.0/gentoo/39_all_whitespace-pa.patch |  28 +++++++
 5.5.0/gentoo/README.history             |   4 +
 3 files changed, 175 insertions(+)
Comment 22 Larry the Git Cow gentoo-dev 2020-05-29 21:27:39 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=698fe68de7471bbae1a006811ab74236d742bfc6

commit 698fe68de7471bbae1a006811ab74236d742bfc6
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:21:45 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:27:34 +0000

    sys-devel/gcc: 5.5.0: cut 3 patchset
    
    Two new patches:
    + 26_all_libcpp-ar.patch: respect user's AR
    + 27_all_alignof-failure-PR90736.patch: avoid gcc ICE in templates
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 sys-devel/gcc/Manifest         | 2 +-
 sys-devel/gcc/gcc-5.5.0.ebuild | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=40027047a387b2587280a8726cc0339e7199fe3f

commit 40027047a387b2587280a8726cc0339e7199fe3f
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:19:10 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:27:33 +0000

    sys-devel/gcc: 6.5.0: cut 4 patchset
    
    Two new patches:
    + 26_all_libcpp-ar.patch: respect user's AR
    + 27_all_alignof-failure-PR90736.patch: avoid gcc ICE in templates
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-6.5.0-r1.ebuild |  2 +-
 sys-devel/gcc/gcc-6.5.0-r2.ebuild | 19 +++++++++++++++++++
 3 files changed, 21 insertions(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9cb6f36587c721251c496ebaabd0693fb94cca26

commit 9cb6f36587c721251c496ebaabd0693fb94cca26
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:15:43 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:27:33 +0000

    sys-devel/gcc: 7.5.0: cut 3 patchset
    
    One new patch:
    - 29_all_libcpp-ar.patch: respect user's AR
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-7.5.0-r1.ebuild | 19 +++++++++++++++++++
 2 files changed, 20 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=85e2120c5a9f3aa867d38af646ae39900b5dc05f

commit 85e2120c5a9f3aa867d38af646ae39900b5dc05f
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:12:58 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:27:33 +0000

    sys-devel/gcc: 8.4.0: cut 2 patchset
    
    Two new patches:
    + 29_all_libcpp-ar.patch: respect user's AR
    + 30_all_alignof-failure-PR90736.patch: avoid gcc ICE in templates
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-8.4.0-r1.ebuild | 19 +++++++++++++++++++
 2 files changed, 20 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6595e8e7a90d36f07782e3058d0200f104bcc779

commit 6595e8e7a90d36f07782e3058d0200f104bcc779
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-29 21:07:51 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-29 21:27:33 +0000

    sys-devel/gcc: 9.3.0: cut 3 patchset
    
    One new patch:
    - 29_all_libcpp-ar.patch: respect user's AR
    
    Reported-by: Agostino Sarubbo
    Bug: https://bugs.gentoo.org/718004
    Bug: https://gcc.gnu.org/PR94657
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-9.3.0-r1.ebuild | 19 +++++++++++++++++++
 2 files changed, 20 insertions(+)
Comment 23 Sergei Trofimovich gentoo-dev 2020-05-29 21:30:11 UTC
Should be fixed in ~arch in all gcc branches.