Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 715928 - sys-process/psmisc-23.3-r1: use BDEPEND with EAPI=7
Summary: sys-process/psmisc-23.3-r1: use BDEPEND with EAPI=7
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-02 16:42 UTC by David Michael
Modified: 2020-04-02 21:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Michael 2020-04-02 16:42:56 UTC
The latest ebuild version switched to EAPI 7, but it left build system dependencies in DEPEND instead of moving to BDEPEND.

Reproducible: Always

Steps to Reproduce:
1. emerge =sys-process/psmisc-23.3-r1  # with a sysroot configuration

Actual Results:  
It installs gettext and libtool and all of their dependencies in the sysroot.

Expected Results:  
It should just use all of this stuff in /.

I tested this:

--- sys-process/psmisc/psmisc-23.3-r1.ebuild
+++ sys-process/psmisc/psmisc-23.3-r1.ebuild
@@ -15,8 +15,8 @@
 RDEPEND=">=sys-libs/ncurses-5.7-r7:0=
 	nls? ( virtual/libintl )
 	selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
-	>=sys-devel/libtool-2.2.6b
+DEPEND="${RDEPEND}"
+BDEPEND=">=sys-devel/libtool-2.2.6b
 	nls? ( sys-devel/gettext )"
 
 DOCS=( AUTHORS ChangeLog NEWS README )