Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 715512 - net-misc/cadaver-0.23.3 : src/cadaver.c: fatal error: ne_request.h: No such file or directory
Summary: net-misc/cadaver-0.23.3 : src/cadaver.c: fatal error: ne_request.h: No such f...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo musl team
URL:
Whiteboard:
Keywords: NeedPatch
: 725068 (view as bug list)
Depends on:
Blocks: missing-musl-includes
  Show dependency tree
 
Reported: 2020-03-30 20:55 UTC by Toralf Förster
Modified: 2020-11-16 19:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.29 KB, text/plain)
2020-03-30 20:55 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,113.50 KB, text/plain)
2020-03-30 20:55 UTC, Toralf Förster
Details
environment (environment,58.28 KB, text/plain)
2020-03-30 20:55 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.48 KB, application/x-bzip)
2020-03-30 20:55 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,13.31 KB, application/x-bzip)
2020-03-30 20:55 UTC, Toralf Förster
Details
net-misc:cadaver-0.23.3:20200330-193613.log (net-misc:cadaver-0.23.3:20200330-193613.log,12.28 KB, text/plain)
2020-03-30 20:55 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,18.68 KB, application/x-bzip)
2020-03-30 20:55 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-03-30 20:55:14 UTC
make -j1 
x86_64-gentoo-linux-musl-gcc -DHAVE_CONFIG_H -I. -I./lib  -I/usr/include    -DLOCALEDIR=\/usr/share/locale\ -I./src -O2 -pipe -march=native -I./lib/neon -o src/cadaver.o -c src/cadaver.c
src/cadaver.c:62:10: fatal error: ne_request.h: No such file or directory
   62 | #include <ne_request.h>
      |          ^~~~~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_musl_hardened-20200328-201618

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-gentoo-linux-musl-9.3.0 *
clang version 10.0.0 
Target: x86_64-gentoo-linux-musl
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.42.0 *

timestamp of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon Mar 30 18:39:03 UTC 2020
/var/db/repos/musl	Fri Mar 27 00:25:27 UTC 2020

emerge -qpvO net-misc/cadaver
[ebuild  N    ] net-misc/cadaver-0.23.3  USE="nls"
Comment 1 Toralf Förster gentoo-dev 2020-03-30 20:55:16 UTC
Created attachment 627578 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-03-30 20:55:20 UTC
Created attachment 627580 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-03-30 20:55:22 UTC
Created attachment 627582 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-03-30 20:55:25 UTC
Created attachment 627584 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-03-30 20:55:28 UTC
Created attachment 627586 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-03-30 20:55:31 UTC
Created attachment 627588 [details]
net-misc:cadaver-0.23.3:20200330-193613.log
Comment 7 Toralf Förster gentoo-dev 2020-03-30 20:55:33 UTC
Created attachment 627590 [details]
temp.tbz2
Comment 8 Sam James archtester gentoo-dev Security 2020-03-31 19:45:36 UTC
possible patch given ne_request is from neon: https://git.alpinelinux.org/aports/tree/community/cadaver/neon.patch
Comment 9 Sam James archtester gentoo-dev Security 2020-03-31 19:45:59 UTC
(In reply to Sam James (sam_c) (security padawan) from comment #8)
> possible patch given ne_request is from neon:
> https://git.alpinelinux.org/aports/tree/community/cadaver/neon.patch

they also disable nls but the standard fix for this is to include libintl, which is available by default w/ glibc
Comment 10 Hank Leininger 2020-05-04 20:33:27 UTC
(In reply to Sam James (sec padawan) from comment #8)
> possible patch given ne_request is from neon:
> https://git.alpinelinux.org/aports/tree/community/cadaver/neon.patch

Aha, it seems we already do some hackery in the .ebuild to extend NE_REQUIRE_VERSIONS in configure.ac:

          sed \
                -e "/NE_REQUIRE_VERSIONS/s:29:& 30:" \
                -e "/AM_GNU_GETTEXT/s:no-libtool:external:" \
                -e "/AC_CONFIG_FILES/s: lib/neon/Makefile lib/intl/Makefile::" \
                -i configure.ac || die "sed configure.ac failed"

By simply extending that to:

                -e "/NE_REQUIRE_VERSIONS/s:29:& 30 31:" \

I was able to build cadaver-0.23.3 with system neon-0.31.1.
Comment 11 Kobboi 2020-11-06 20:12:28 UTC
(In reply to Hank Leininger from comment #10)
> (In reply to Sam James (sec padawan) from comment #8)
> > possible patch given ne_request is from neon:
> > https://git.alpinelinux.org/aports/tree/community/cadaver/neon.patch
> 
> Aha, it seems we already do some hackery in the .ebuild to extend
> NE_REQUIRE_VERSIONS in configure.ac:
> 
>           sed \
>                 -e "/NE_REQUIRE_VERSIONS/s:29:& 30:" \
>                 -e "/AM_GNU_GETTEXT/s:no-libtool:external:" \
>                 -e "/AC_CONFIG_FILES/s: lib/neon/Makefile
> lib/intl/Makefile::" \
>                 -i configure.ac || die "sed configure.ac failed"
> 
> By simply extending that to:
> 
>                 -e "/NE_REQUIRE_VERSIONS/s:29:& 30 31:" \
> 
> I was able to build cadaver-0.23.3 with system neon-0.31.1.

Hitting this too. Care to make PR?
Comment 12 Arfrever Frehtes Taifersar Arahesis 2020-11-13 19:01:23 UTC
*** Bug 725068 has been marked as a duplicate of this bug. ***
Comment 13 Larry the Git Cow gentoo-dev 2020-11-16 19:51:41 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4c4b194a7b45f44aee3f4dbae055168d36b30dc5

commit 4c4b194a7b45f44aee3f4dbae055168d36b30dc5
Author:     Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
AuthorDate: 2020-11-13 05:00:00 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-11-16 19:51:16 +0000

    net-misc/cadaver: Fix building with Neon >=0.31.
    
    Closes: https://bugs.gentoo.org/715512
    Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 net-misc/cadaver/cadaver-0.23.3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)