Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 714744 - media-libs/musicbrainz-5.1.0::gentoo failed (compile phase): emake failed
Summary: media-libs/musicbrainz-5.1.0::gentoo failed (compile phase): emake failed
Status: RESOLVED DUPLICATE of bug 698090
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-03-25 17:24 UTC by guyu2876
Modified: 2020-06-04 19:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
error log (file_714744.txt,8.75 KB, text/plain)
2020-03-25 17:24 UTC, guyu2876
Details
build environment (file_714744.txt,113.39 KB, text/plain)
2020-03-25 17:30 UTC, guyu2876
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guyu2876 2020-03-25 17:24:08 UTC
Created attachment 625812 [details]
error log

Can't emerge under the command 
emerge --verbose --update --deep --newuse --keep-going @world gnome-light
Comment 1 guyu2876 2020-03-25 17:30:13 UTC
Created attachment 625814 [details]
build environment
Comment 2 guyu2876 2020-03-25 17:37:43 UTC
make[2]: Leaving directory '/var/tmp/portage/media-libs/musicbrainz-5.1.0/work/musicbrainz-5.1.0_build'
[  5%] Built target make-c-interface
make -f src/CMakeFiles/musicbrainz5.dir/build.make src/CMakeFiles/musicbrainz5.dir/depend
make[2]: Entering directory '/var/tmp/portage/media-libs/musicbrainz-5.1.0/work/musicbrainz-5.1.0_build'
make[2]: *** No rule to make target 'src/*.inc', needed by 'src/mb5_c.cc'.  Stop.
make[2]: Leaving directory '/var/tmp/portage/media-libs/musicbrainz-5.1.0/work/musicbrainz-5.1.0_build'
make[1]: *** [CMakeFiles/Makefile2:252: src/CMakeFiles/musicbrainz5.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-libs/musicbrainz-5.1.0/work/musicbrainz-5.1.0_build'
make: *** [Makefile:147: all] Error 2
Comment 3 guyu2876 2020-03-25 17:38:26 UTC
Portage 2.3.95 (python 3.6.10-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-9.3.0, glibc-2.30-r6, 5.5.11-arch1-1 x86_64)
=================================================================
System uname: Linux-5.5.11-arch1-1-x86_64-Intel-R-_Core-TM-_i5-9400F_CPU_@_2.90GHz-with-gentoo-2.7
KiB Mem:    16336408 total,   6953576 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Tue, 24 Mar 2020 21:30:01 +0000
Head commit of repository gentoo: 0959da60c9b3626181471fe4e04c587c4771a932
sh bash 5.0_p16
ld GNU ld (Gentoo 2.34 p1) 2.34.0
app-shells/bash:          5.0_p16::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r1::gentoo, 3.6.10::gentoo, 3.7.7::gentoo, 3.8.2::gentoo
dev-util/cmake:           3.17.0::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.34::gentoo
sys-devel/gcc:            9.3.0::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.5::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r6::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord crypt cups dbus dri dts dvd dvdr eds emboss encode evo exif flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv icu introspection ipv6 jpeg lcms ldap libnotify libsecret libtirpc mad mng mp3 mp4 mpeg multilib nautilus ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt5 readline sdl seccomp spell split-usr ssl startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 mechtech737 2020-03-26 01:07:29 UTC
This is also failing to compile on my system. Happened after upgrading to gcc 9.3.0. Was working with 9.2.0.
Comment 5 cyrillic 2020-03-26 18:14:34 UTC
This is a duplicate of bug 698090
Comment 6 mechtech737 2020-03-27 02:03:00 UTC
The patch on bug report 698090 from cyrillic fixes this issue for me.
Comment 7 Andreas Sturmlechner gentoo-dev 2020-06-04 19:56:57 UTC

*** This bug has been marked as a duplicate of bug 698090 ***