Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 713602 - sci-physics/looptools-2.13 : clang-10: error: invalid integral value 32:25:16 in -falign-functions=32:25:16
Summary: sci-physics/looptools-2.13 : clang-10: error: invalid integral value 32:25:16...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Physics related packages
URL:
Whiteboard:
Keywords:
: 710430 (view as bug list)
Depends on:
Blocks: colon-in-CFLAGS
  Show dependency tree
 
Reported: 2020-03-20 14:46 UTC by Toralf Förster
Modified: 2021-02-13 22:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.41 KB, text/plain)
2020-03-20 14:46 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,173.73 KB, text/plain)
2020-03-20 14:46 UTC, Toralf Förster
Details
environment (environment,81.88 KB, text/plain)
2020-03-20 14:46 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.21 KB, application/x-bzip)
2020-03-20 14:46 UTC, Toralf Förster
Details
sci-physics:looptools-2.13:20200320-021445.log (sci-physics:looptools-2.13:20200320-021445.log,21.14 KB, text/plain)
2020-03-20 14:46 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,21.52 KB, application/x-bzip)
2020-03-20 14:46 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-03-20 14:46:29 UTC
x86_64-pc-linux-gnu-gfortran -O2 -pipe -march=native -fno-common -falign-functions=32:25:16 -march=native -g -ffixed-line-length-none -fno-range-check -DQUAD=1 -DU77EXT=0  -I. -fPIC -c -o ffinit.o ffinit.F
x86_64-pc-linux-gnu-gfortran -O2 -pipe -march=native -fno-common -falign-functions=32:25:16 -march=native -g -ffixed-line-length-none -fno-range-check -DQUAD=1 -DU77EXT=0  -I. -fPIC -c -o ffxli2.o ffxli2.F
clang-10: error: invalid integral value 32:25:16 in -falign-functions=32:25:16
make[1]: *** [makefile:208: cache.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory /var/tmp/portage/sci-physics/looptools-2.13/work/LoopTools-2.13/build

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome-20200315-161810

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.41.1 *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.14.0 [icedtea-bin-8]
2)	JamVM JDK 2.0.0 [jamvm]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
  [2]   jamvm 

The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Wed, 18 Mar 2020 15:38:31 +0000
emerge -qpvO sci-physics/looptools
[ebuild  N    ] sci-physics/looptools-2.13  USE="-doc -static-libs"
Comment 1 Toralf Förster gentoo-dev 2020-03-20 14:46:32 UTC
Created attachment 622982 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-03-20 14:46:35 UTC
Created attachment 622984 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-03-20 14:46:38 UTC
Created attachment 622986 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-03-20 14:46:41 UTC
Created attachment 622988 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-03-20 14:46:44 UTC
Created attachment 622990 [details]
sci-physics:looptools-2.13:20200320-021445.log
Comment 6 Toralf Förster gentoo-dev 2020-03-20 14:46:47 UTC
Created attachment 622992 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-15 19:22:49 UTC
*** Bug 710430 has been marked as a duplicate of this bug. ***
Comment 8 Jakov Smolić gentoo-dev 2021-01-31 09:14:42 UTC
*** Bug 711638 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2021-02-13 22:52:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a0ff6cc1bd7727615627243ccf1fe9bc816d1ce7

commit a0ff6cc1bd7727615627243ccf1fe9bc816d1ce7
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-02-13 22:51:45 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-02-13 22:51:45 +0000

    sci-physics/looptools: Bump to 2.0.15
    
    Closes: https://bugs.gentoo.org/723280
    Closes: https://bugs.gentoo.org/713602
    Closes: https://bugs.gentoo.org/711638
    Closes: https://bugs.gentoo.org/705220
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 sci-physics/looptools/Manifest                     |  1 +
 .../looptools/files/looptools-2.15-makefile.patch  | 99 ++++++++++++++++++++++
 sci-physics/looptools/looptools-2.15.ebuild        | 38 +++++++++
 3 files changed, 138 insertions(+)