Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71246 - qtparted won t start
Summary: qtparted won t start
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Kevin F. Quinn (RETIRED)
Depends on:
Reported: 2004-11-14 22:58 UTC by OxO pHz.60
Modified: 2006-08-10 03:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description OxO pHz.60 2004-11-14 22:58:12 UTC
after emerging qtparted I tried to run it. After 1-2 seconds of a blackbox with white letters saying getting devices and then qtparted crashes and says Floating point exception.

Reproducible: Always
Steps to Reproduce:
1.#emerge -av qtparted

Actual Results:  
Floating point exception

Expected Results:  
launch the gui

the contents of my make.conf:
# These settings were set by the catalyst build script that automatically built
this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
USE="3dnow alsa oss avi cdr -cups -gnome -kde gtk2 qt imlib imagemagick java
jpeg msn mmx mpeg oggvorbis pdflib perl python ruby png -scanner truetype tcltk
spell X offensive"

The contents of emerege -evp qtparted:
These are the packages that I would merge, in order:

Calculating dependencies   ?? ...done!
[ebuild  N    ] sys-devel/patch-2.5.9  -build -debug -static 197 kB 
[ebuild  N    ] sys-devel/gnuconfig-20040214  (-uclibc) 30 kB 
[ebuild  N    ] sys-libs/ncurses-5.4-r5  -bootstrap -build -debug -doc (-uclibc)
-unicode 2,103 kB 
[ebuild  N    ] sys-devel/gettext-0.12.1-r2  -bootstrap -emacs +nls 5,592 kB 
[ebuild  N    ] sys-apps/sed-4.0.9  -bootstrap -build -debug +nls -static 0 kB 
[ebuild  N    ] sys-apps/texinfo-4.7-r1  -build -debug +nls -static 1,385 kB 
[ebuild  N    ] sys-devel/binutils-  -bootstrap -build -debug
-multitarget +nls (-uclibc) 0 kB 
[ebuild  N    ] sys-libs/zlib-1.2.1-r3  -build -debug 277 kB 
[ebuild  N    ] dev-python/python-fchksum-1.7.1  26 kB 
[ebuild  N    ] app-shells/bash-2.05b-r9  -build -debug +nls (-uclibc) 1,923 kB 
[ebuild  N    ] sys-libs/readline-4.3-r5  947 kB 
[ebuild  N    ] sys-devel/flex-2.5.4a-r5  -build -debug -static 372 kB 
[ebuild  N    ] app-arch/bzip2-1.0.2-r3  -build -cross -debug -static 649 kB 
[ebuild  N    ] sys-apps/help2man-1.29  36 kB 
[ebuild  N    ] sys-devel/automake-1.8.5-r1  (-uclibc) 2,557 kB 
[ebuild  N    ] sys-apps/coreutils-5.2.1  -acl -build -debug +nls (-selinux)
-static (-uclibc) 4,255 kB 
[ebuild  N    ] sys-apps/debianutils-1.16.7-r4  -build -static 25 kB 
[ebuild  N    ] sys-apps/portage-2.0.51-r3  -build -debug (-selinux) 274 kB 
*** Please update portage to the above version before proceeding.
    Failure to do so may result in failed or improper merges.
    A simple 'emerge -u portage' is sufficient.

[ebuild  N    ] sys-devel/bc-1.06-r5  -debug +readline -static 272 kB 
[ebuild  N    ] sys-apps/diffutils-2.8.4-r4  -build -debug +nls -static 809 kB 
[ebuild  N    ] dev-libs/openssl-0.9.7d-r2  -debug -emacs (-uclibc) 4,866 kB 
[ebuild  N    ] dev-lang/tcl-8.4.6  -threads 3,367 kB 
[ebuild  N    ] dev-libs/glib-1.2.10-r5  -debug 411 kB 
[ebuild  N    ] sys-apps/miscfiles-1.3-r1  (-uclibc) 2,153 kB 
[ebuild  N    ] sys-devel/gcc-config-1.3.6-r3  0 kB 
[ebuild  N    ] sys-libs/cracklib-2.7-r10  -debug +pam (-uclibc) 0 kB 
[ebuild  N    ] sys-libs/pam-0.77-r1  +berkdb -debug -pwdb (-selinux) 0 kB 
[ebuild  N    ] sys-apps/shadow-4.0.5-r2  -debug +nls +pam (-selinux) -skey 988 kB 
[ebuild  N    ] sys-apps/pam-login-3.14  -livecd +nls (-selinux) 137 kB 
[ebuild  N    ] sys-apps/grep-2.5.1-r6  -build -debug +nls -pcre -static
(-uclibc) 667 kB 
[ebuild  N    ] sys-apps/gawk-3.1.3-r1  -build +nls (-uclibc) 2,029 kB 
[ebuild  N    ] app-crypt/hashalot-0.3  78 kB 
[ebuild  N    ] sys-apps/util-linux-2.12-r4  +crypt -debug +nls +pam (-selinux)
-static (-uclibc) 1,819 kB 
[ebuild  N    ] media-libs/libpng-1.2.7  -debug 370 kB 
[ebuild  N    ] dev-libs/expat-1.95.7  289 kB 
[ebuild  N    ] media-libs/freetype-2.1.5-r1  -bindist -cjk -debug -doc +zlib
830 kB 
[ebuild  N    ] x11-misc/ttmkfdir-3.0.9-r2  -debug 19 kB 
[ebuild  N    ] media-libs/fontconfig-2.2.3  732 kB 
[ebuild  N    ] x11-base/opengl-update-1.8.1-r1  30 kB 
[ebuild  N    ] x11-base/xorg-x11-6.8.0-r1  -3dfx +3dnow* +bitmap-fonts -cjk
-debug -dlloader -dmx -doc -hardened -insecure-drivers -ipv6 +mmx* +nls +pam
-sdk -sse -static -xprint* 64,126 kB 
[ebuild  N    ] dev-lang/tk-8.4.6-r1  -threads 3,155 kB 
[ebuild  N    ] sys-apps/file-4.10-r1  -build -debug +python 0 kB 
[ebuild  N    ] sys-apps/which-2.16  122 kB 
[ebuild  N    ] app-arch/cpio-2.5  181 kB 
[ebuild  N    ] app-arch/rpm2targz-9.0-r2  2 kB 
[ebuild  N    ] sys-apps/utempter-  20 kB 
[ebuild  N    ] x11-terms/xterm-196  -Xaw3d -debug +truetype -unicode 662 kB 
[ebuild  N    ] sys-libs/db-1.85-r1  264 kB 
[ebuild  N    ] sys-libs/gdbm-1.8.3-r1  +berkdb -debug 0 kB 
[ebuild  N    ] dev-lang/python-2.3.4  +X +berkdb -bootstrap -build -debug -doc
+gdbm -ipv6 +ncurses +readline +ssl +tcltk -ucs2 7,020 kB 
[ebuild  N    ] dev-java/java-config-1.2.10  15 kB 
[ebuild  N    ] dev-java/blackdown-jdk-1.4.1  -doc -mozilla 39,857 kB 
[ebuild  N    ] sys-libs/db-4.1.25_p1-r3  -doc +java +tcltk 0 kB 
[ebuild  N    ] sys-apps/groff-1.19.1-r2  +X -debug 2,567 kB 
[ebuild  N    ] sys-devel/libperl-5.8.4-r1  +berkdb -debug +gdbm -ithreads
(-uclibc) 11,810 kB 
[ebuild  N    ] dev-lang/perl-5.8.4-r1  +berkdb -debug -doc +gdbm -ithreads
-perlsuid (-uclibc) 0 kB 
[ebuild  N    ] sys-devel/autoconf-2.59-r5  1,336 kB 
[ebuild  N    ] sys-devel/libtool-1.5.2-r5  (-uclibc) 3,117 kB 
[ebuild  N    ] sys-devel/m4-1.4.1  -bootstrap +nls 0 kB 
[ebuild  N    ] sys-devel/bison-1.875  -debug +nls -static 795 kB 
[ebuild  N    ] sys-devel/gcc-3.3.4-r1  +X -bootstrap -build -debug +fortran
-gcj -hardened -multilib +nls -objc -pic -static (-uclibc) 0 kB 
[ebuild  N    ] sys-apps/cronbase-0.3.1  0 kB 
[ebuild  N    ] sys-apps/man-1.5m-r2  -debug +nls 222 kB 
[ebuild  N    ] sys-kernel/linux26-headers-  -build 34,793 kB 
[ebuild  N    ] sys-apps/baselayout-1.9.4-r6  -bootstrap -build -debug -livecd
(-selinux) -static (-uclibc) 197 kB 
[ebuild  N    ] sys-libs/glibc-  -build -debug -erandom
-hardened -makecheck -multilib +nls -nptl -pic -userlocales 15,372 kB 
[ebuild  N    ] sys-fs/jfsutils-1.1.4  0 kB 
[ebuild  N    ] sys-fs/e2fsprogs-1.35-r1  -debug -diet +nls -static 0 kB 
[ebuild  N    ] sys-fs/xfsprogs-2.6.13  -debug +nls (-uclibc) 0 kB 
[ebuild  N    ] media-libs/jpeg-6b-r4  -debug 0 kB 
[ebuild  N    ] media-libs/lcms-1.12  +jpeg +python -tiff +zlib 554 kB 
[ebuild  N    ] media-libs/libmng-1.0.4  555 kB 
[ebuild  N    ] media-libs/giflib-4.1.0-r3  +X +gif 294 kB 
[ebuild  N    ] media-libs/libungif-  +X +gif 305 kB 
[ebuild  N    ] x11-libs/qt-3.3.3  -cups -debug -doc -firebird +gif -icc -immqt
-immqt-bc -ipv6 -mysql -nas -odbc +opengl -postgres -sqlite -xinerama +zlib
14,086 kB 
[ebuild  N    ] dev-util/pkgconfig-0.15.0  596 kB 
[ebuild  N    ] sys-devel/make-3.80-r1  -build -debug +nls -static (-uclibc) 899 kB 
[ebuild  N    ] sys-apps/parted-1.6.6  -debug +nls +readline -static 0 kB 
[ebuild  N    ] kde-base/kde-env-3-r3  0 kB 
[ebuild  N    ] sys-fs/ntfsprogs-1.9.2  -gnome 0 kB 
[ebuild  N    ] sys-apps/qtparted-0.4.4  +arts -debug -xinerama 0 kB 

Total size of downloads: 243,464 kB
Comment 1 Michael Kelly 2004-11-25 18:37:18 UTC
(Keep in mind that I am on a Gentoo amd64 install. Originally I thought that was why I got the error since qtparted is not marked amd64 or even ~amd64.)

I originally got error as well. It was actually a parted-1.6.6 error, not qtparted. Try calling parted on a console as root and see if you get the same floating point error. 

Once I accepted the ~ARCH keyword for parted I installed parted-1.6.15 which works fine. I then re-emerged qtparted (accepting x86 keyword) and it works fine as well, except for one other problem which I will be posting a bug report after I test Knoppix's qtparted to make sure what I'm asking for isn't impossible (ReiserFS partitions don't move or resize). Perhaps parted-1.6.6.ebuild should be masked or at least downgraded to unstable.

Oh and by the way if the ebuild maintainer sees this, yes qtparted-0.4.4.ebuild does build and work nicely on amd64 (other than that Reiser problem, which people on x86 are talking about on the chat boards so it's not just my platform), so you may want to consider adding an ~amd64 keyword to it once we get parted-1.6.15 to keyword amd64 status (or at least once you mask parted-1.6.6).
Comment 2 Liam Helmer 2005-04-07 11:15:50 UTC
I had a problem very similar to this on i386. After some fiddling, I managed to determine that it was crashing when it scanned and found the CD-Rom device. When I Removed the cdrom device node, it worked. This is not a fix, but, I'm curious if your issue is the same.

I left it after that, as I realized the program is really only mostly working anyways (it's pretty much unmaintained upstream).
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2005-09-06 13:59:55 UTC
Assigning to maintainer-needed@ as livecd doesn't use this package.
Comment 4 Caleb Tennis (RETIRED) gentoo-dev 2006-07-31 05:04:33 UTC
package masked and is going away soon

*** This bug has been marked as a duplicate of 140792 ***
Comment 5 Kevin F. Quinn (RETIRED) gentoo-dev 2006-08-10 02:16:48 UTC
I'm taking this package on.
Comment 6 Kevin F. Quinn (RETIRED) gentoo-dev 2006-08-10 02:19:37 UTC
Mine, all mine!
Comment 7 Kevin F. Quinn (RETIRED) gentoo-dev 2006-08-10 03:18:12 UTC
Please try the new qtparted-0.4.5, see if the problem persists, and report back here (and re-open the bug).