Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 71208 - Start RP-PPPoE before NTP
Summary: Start RP-PPPoE before NTP
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-14 14:27 UTC by Lionel Sausin
Modified: 2004-11-18 21:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Sausin 2004-11-14 14:27:46 UTC
On a system having both ntp-client and rp-pppoe started in the same runlevel, it is probable that the administrator wants NTP to reach a host over the PPPoE connection.
This fails with the current stable ebuilds because init wants to start ntp before rp-pppoe.
A simple change in the dependencies in /etc/init.d/ntp does the trick.

Reproducible: Always
Steps to Reproduce:
1. add ntp-client and rp-pppoe to myrunlevel
2. configure rp-pppoe ; leave ntp-client's config as-is
3. rc myrunlevel

Actual Results:  
NTP complains it can't reach pool.ntp.org, because the PPPoE connection has not
yet been established

Expected Results:  
Establish PPPoE connection and then sync clocks

Using up-to date portage tree, stable ebuilds, x86, gentoo-sources kernel.

A quick fix is to change the dependencies in /etc/init.d/ntp-client :
  depend() {
          before cron
          need net
          use dns logger
>>        after rp-pppoe
  }

A "before" dependency in /etc/init.d/rp-pppoe should do the trick just as well.
Comment 1 SpanKY gentoo-dev 2004-11-18 21:57:30 UTC
rp-pppoe is not a supported net script