Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71028 - alsa-driver 1.0.7 failes to emerge, problem with sndversions.h
Summary: alsa-driver 1.0.7 failes to emerge, problem with sndversions.h
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Jeremy Huddleston (RETIRED)
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-12 18:35 UTC by Daniel Kulp
Modified: 2004-11-19 00:16 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Kulp 2004-11-12 18:35:45 UTC
Alsa 1.0.7 failes to emerge.   2.4.

root@dilbert / # uname -a
Linux dilbert 2.4.27-gentoo-r1 #1 Sun Aug 29 16:39:04 EDT 2004 i686 Intel(R) Pentium(R) 4 Mobile CPU 2.00GHz GenuineIntel GNU/Linux

root@dilbert / # emerge -u world
Calculating world dependencies ...done!
>>> emerge (1 of 4) media-sound/alsa-driver-1.0.7 to /
>>> md5 src_uri ;-) alsa-driver-1.0.7.tar.bz2
>>> Unpacking source...
>>> Unpacking alsa-driver-1.0.7.tar.bz2 to /var/tmp/portage/alsa-driver-1.0.7/work
 * Applying alsa-driver-1.0.5-devfix.patch ...                                        [ ok ]
 * Applying alsa-driver-1.0.5a-cs46xx-passthrough.patch ...                           [ ok ]
 * /usr/src/linux is a symbolic link
 * Determining the real directory of the Linux kernel source code
 * Building for Linux 2.4.27-gentoo-r1 found in /usr/src/linux
 * /usr/src/linux is a symbolic link
 * Determining the real directory of the Linux kernel source code
 * Building for Linux 2.4.27-gentoo-r1 found in /usr/src/linux
 * Applying alsa-driver-1.0.6a-kbuild.patch ...                                       [ ok ]
>>> Source unpacked.
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-oss --with-kernel=/usr/src/linux --with-isapnp=yes --with-sequencer=yes --with-cards=all
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for i686-pc-linux-gnu-gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for i686-pc-linux-gnu-ranlib... no
checking for ranlib... ranlib
checking for a BSD-compatible install... /bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel version... 2.4.27-gentoo-r1
checking for GCC version... Kernel compiler: gcc 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6) Used compiler: gcc (GCC) 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)
checking for built-in ALSA... "no"
checking for existing ALSA module... "no"
checking for Red Hat kernel... "auto"
checking for Red Hat kernel... "no"
checking for SUSE kernel... "auto"
checking for SUSE kernel... "no"
checking to modify of kernel linux/kmod.h... "no"
checking for kernel linux/compiler.h... "yes"
checking for kernel linux/pm.h... "yes"
checking for kernel linux/spinlock.h... "yes"
checking for kernel linux/irq.h... "yes"
checking for kernel linux/threads.h... "yes"
checking for kernel linux/rwsem.h... "yes"
checking for kernel linux/gameport.h... "yes"
checking for kernel linux/devfs_fs_kernel.h... "yes"
checking for kernel linux/highmem.h... "yes"
checking for kernel linux/workqueue.h... "no"
checking for kernel linux/dma-mapping.h... "no"
checking for kernel asm/hw_irq.h... "yes"
checking for kernel linux/device.h... "no"
checking for kernel linux/jiffies.h... "no"
checking for kernel linux/compat.h... "no"
checking for kernel linux/adb.h... "yes"
checking for kernel linux/cuda.h... "yes"
checking for kernel linux/pmu.h... "yes"
checking for kernel linux/moduleparam.h... "yes"
Removing a dummy linux/moduleparam.h.
checking for kernel linux/syscalls.h... "no"
checking for exported symbol dump_stack... "yes"
checking for kernel module symbol versions... "yes"
checking for PCI support in kernel... "yes"
checking for I2C driver in kernel... module
checking for input subsystem in kernel... module
checking for SGI/MIPS (HAL2) architecture... "no"
checking for directory to store kernel modules... /lib/modules/2.4.27-gentoo-r1/kernel/sound
checking for verbose printk... on
checking for debug level... none
checking for ISA support in kernel... "yes"
checking for processor type... "unknown"
checking for SMP... "no"
checking for Video device support in kernel... "yes"
checking for ISA PnP driver in kernel... yes
checking for PnP driver in kernel... no
checking for Kernel ISA-PnP support... "yes"
checking for ISA PnP support... yes
checking for strlcpy... "no"
checking for snprintf... "yes"
checking for scnprintf... "no"
checking for sscanf... "yes"
checking for vmalloc_to_page... "yes"
checking for old kmod... "yes"
checking for PDE... "yes"
checking for pci_set_consistent_dma_mask... "no"
checking for tty->count is the atomic type... "no"
checking for video_get_drvdata... "yes"
checking for remap_pfn_range... "no"
checking for new remap_page_range... "no"
checking for kcalloc... "no"
checking for saved_config_space in pci_dev... "no"
checking for acpi_register_gsi... "no"
checking for driver version... 1.0.7
checking for sequencer support... yes
checking for OSS/Free emulation... yes
checking for RTC callback support in kernel... "no"
checking for Procfs support... "yes"
checking for USB support... "yes"
checking for kernel PCMCIA
checking for PCMCIA support... "yes"
checking for PC9800 support in kernel... "no"
checking for parallel port support... "yes"
checking for which soundcards to compile driver for... all
configure: creating ./config.status
config.status: creating version
config.status: creating Makefile.conf
config.status: creating snddevices
config.status: creating utils/alsa-driver.spec
config.status: creating utils/buildrpm
config.status: creating toplevel.config
config.status: creating utils/alsasound
config.status: creating utils/alsasound.posix
config.status: creating include/config.h
config.status: creating include/config1.h
config.status: creating include/version.h
config.status: include/version.h is unchanged
config.status: creating include/autoconf-extra.h
if [ ! -d include/sound -a ! -L include/sound ]; then \
  ln -sf ../alsa-kernel/include include/sound ; \
fi
make  dep
cp -auvf include/version.h include/sound/version.h
`include/version.h' -> `include/sound/version.h'
make[1]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7'
make[2]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/acore'
make  -C ioctl32 fastdep
make  -C oss fastdep
make[3]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/acore/ioctl32'
make[3]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/acore/oss'
/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/include/sndversions.h was updated
/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/include/sndversions.h was updated
mv: cannot stat `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/include/sndversions.h.tmp': No such file or directory
make[3]: *** [update-sndversions] Error 1
make[3]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/acore/oss'
make[2]: *** [_sfdep_oss] Error 2
make[2]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/acore/ioctl32'
make[2]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/acore'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7'
make: *** [include/sndversions.h] Error 2

!!! ERROR: media-sound/alsa-driver-1.0.7 failed.
!!! Function src_compile, Line 89, Exitcode 2
!!! Parallel Make Failed
!!! If you need support, post the topmost build error, NOT this status message.



Reproducible: Always
Steps to Reproduce:
1.emerge -u world
2.
3.

Actual Results:  
Emerge fails 

Expected Results:  
Would have expected the package to properly install 

root@dilbert / # emerge info 
Portage 2.0.51-r3 (default-linux/x86/2004.2, gcc-3.3.4, 
glibc-2.3.4.20040808-r1, 2.4.27-gentoo-r1 i686) 
================================================================= 
System uname: 2.4.27-gentoo-r1 i686 Intel(R) Pentium(R) 4 Mobile CPU 2.00GHz 
Gentoo Base System version 1.4.16 
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) 
[disabled] 
Autoconf: sys-devel/autoconf-2.59-r5 
Automake: sys-devel/automake-1.8.5-r1 
Binutils: sys-devel/binutils-2.14.90.0.8-r1 
Headers:  
sys-kernel/linux-headers-2.4.19-r1,sys-kernel/linux-headers-2.4.21-r1 
Libtools: sys-devel/libtool-1.5.2-r5 
ACCEPT_KEYWORDS="x86" 
AUTOCLEAN="yes" 
CFLAGS="-O3 -march=pentium4 -mcpu=pentium4 -fomit-frame-pointer -fthread-jumps 
-fforce-addr-falign-functions=4 -falign-jumps=4 -ftracer 
-fprefetch-loop-arrays -pipe" 
CHOST="i686-pc-linux-gnu" 
COMPILER="" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-O3 -march=pentium4 -mcpu=pentium4 -fomit-frame-pointer 
-fthread-jumps -fforce-addr -falign-functions=4 -falign-jumps=4 -ftracer 
-fprefetch-loop-arrays -pipe" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoaddcvs ccache distlocks sandbox sfperms" 
GENTOO_MIRRORS="http://gentoo.osuosl.org 
http://distro.ibiblio.org/pub/Linux/distributions/gentoo" 
MAKEOPTS="-j2" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://rsync.gentoo.org/gentoo-portage" 
USE="DirectFB X aalib acpi alsa apm arts artswrappersuid audiofile avi berkdb 
bitmap-fonts bonobo cdparanoia cdr crypt cups dga directfb dnd dv dvb dvd dvdr 
encode esd f77 fam fbcon flac foomaticdb fortran gdbm gif gnome gphoto2 gpm 
gstreamer gtk gtk2 imagemagick imlib insecure-drivers java jpeg junit kde ldap 
libg++ libwww mad mikmod mmx monkey motif mozilla mpeg nas ncurses nls 
offensive oggvorbis opengl oss pam pda pdflib perl pic png python qt quicktime 
readline ruby samba scanner sdl slang spell sse ssl svga tcltk tcpd theora 
tiff truetype usb wifi wmf x86 xine xinerama xml xml2 xmms xv zlib"
Comment 1 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-12 19:20:56 UTC
hmm... works for me on 2.6... can you pleasse try to debug a bit more... try setting MAKEOPTS="-j1" (although I don't think that will matter...)
Comment 2 Daniel Kulp 2004-11-12 21:19:20 UTC
If I use -j1, things get a LOT furthur, but still fail.


.................
make[2]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/usb'
make[2]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/pcmcia'
make  -C pdaudiocf fastdep
make[3]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/pcmcia/pdaudiocf'
/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/include/sndversions.h was updated
copying file alsa-kernel/pcmcia/pdaudiocf/pdaudiocf.c
patching file pdaudiocf.c
Hunk #2 succeeded at 29 with fuzz 1.
Hunk #3 FAILED at 62.
Hunk #4 succeeded at 80 (offset -4 lines).
Hunk #5 succeeded at 192 (offset -4 lines).
Hunk #6 succeeded at 279 (offset -7 lines).
Hunk #7 succeeded at 377 (offset -7 lines).
Hunk #8 succeeded at 448 (offset -7 lines).
1 out of 8 hunks FAILED -- saving rejects to file pdaudiocf.c.rej
make[3]: *** [pdaudiocf.c] Error 1
make[3]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/pcmcia/pdaudiocf'
make[2]: *** [_sfdep_pdaudiocf] Error 2
make[2]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7/pcmcia'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7/work/alsa-driver-1.0.7'
make: *** [include/sndversions.h] Error 2

!!! ERROR: media-sound/alsa-driver-1.0.7 failed.
!!! Function src_compile, Line 89, Exitcode 2
!!! Parallel Make Failed
!!! If you need support, post the topmost build error, NOT this status message.



Comment 3 Harm Geerts 2004-11-16 20:42:22 UTC
I don't have a fix for the compile problem but there may be a way to skip that file.
Specify the driver you need for your soundcard in /etc/make.conf like this:
ALSA_CARDS="emu10k1" # this is for my SB Live
Comment 4 Rick Knowles 2004-11-17 23:06:39 UTC
I've also observed this - it's under kernel 2.4.28-rc3-mosix, with gcc-3.4.3. Also see http://forums.gentoo.org/viewtopic.php?p=1777052 for further info.

It seems to be an ebuild problem, since the make dep (which is the part that fails) finishes smoothly if you complete the compile from the command line manually.

Rick Knowles
Comment 5 Rick Knowles 2004-11-17 23:08:33 UTC
Additionally my ALSA_CARDS variable is set to "via82xx ali5451"
Comment 6 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-17 23:13:43 UTC
There is nothing special done by the ebuild compared to doing it "manually"  The only patches added are trivial:

        epatch ${FILESDIR}/${PN}-1.0.5-devfix.patch
        epatch ${FILESDIR}/${PN}-1.0.5a-cs46xx-passthrough.patch

the other code is for old 2.5 and 2.6 kernels (pre 2.6.6) and doesn't even run on 2.4 kernel systems.

Additionally, the logs youu provide show 2 different problems... neither of which I can reproduce =(

so hopefully somebody with the problem can find a solution to this... otherwise, it'll have to be reported upstream...
Comment 7 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-17 23:15:19 UTC
Actually... just as a hunch... can you guys try MAKEOPTS="-j1"
Comment 8 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-17 23:16:17 UTC
guys I just added, please check previous comment...
Comment 9 Daniel Kulp 2004-11-18 05:00:56 UTC
Just FYI...

If I use -j1  and specifically set my card (intel8x0), it builds fine.   However, both are pretty ugly hacks that shouldn't need to be done.

Comment 10 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-18 11:42:16 UTC
Right, but I was testing if it was a parallel compilation issue (which it seems to be if -j1 fixes it)... also, setting your card is wise as you probably don't want to build drivers for every single sound card... but please test if '-j1' solves the problem regardless of whether or not you set your card.
Comment 11 Rick Knowles 2004-11-18 21:28:27 UTC
Very interesting indeed ... -j1 worked. But only after I had additionally made all the hosts distcc was distributing jobs to unavailable (ie off). 

It seems distcc pays no regard to the -j setting on make ... either that or there was something in the process of distributing that caused the same effect to occur as when it was parallel built.

Also interesting was that I had tried commenting out my MAKEOPTS variable in /etc/make.conf and the problem still occurred. Is there a default it reads from somewhere else ?

So anyway ... I guess the next thing for me to do is to try re-emerging it with -j5, and when it fails, I go in and try make -j5 dep. If that fails, I send it off to the alsa guys ? 

Rick

Comment 12 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-18 23:58:23 UTC
default is -j2

I set it to use -j2 in the ebuild...

Thanks.
Comment 13 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-19 00:16:32 UTC
correction... I meant to say I set it to -j1 in the ebuild...