Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 710266 - www-servers/tomcat-9* is masked
Summary: www-servers/tomcat-9* is masked
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords: PMASKED
Depends on: 751895 710288
Blocks:
  Show dependency tree
 
Reported: 2020-02-20 00:17 UTC by Vieri
Modified: 2021-02-14 20:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vieri 2020-02-20 00:17:04 UTC
Hi,

Please correct me if I'm wrong, but I think there's been some kind of a mess when cleaning up the tree.

On an "older" Gentoo server I have www-servers/tomcat-9.0.7 and virtual/{jdk,jre}- 1.8.0-r4. Now I'm in the process of installing a new Gentoo machine, and portage tries to install tomcat 8 because the latest tomcat 9 in the tree requires a JDK that's still masked.

Maybe the jdk/jre should have been stabilized before removing the older tomcat 9 versions?
Comment 1 Miroslav Šulc gentoo-dev 2020-02-20 10:07:53 UTC
that was the original intention, but many months passed and no stabilization of jre/jdk 11 is on the way. tomcat 9.0.7 is old and vulnerable so i removed it, though it was the only stable in 9 slot, but for the reasons i wrote. you can still use tomcat 9 if you want (i do on my servers), but you have to install jdk 11 and unmask gentoo-vm use flag on it.
Comment 2 Miroslav Šulc gentoo-dev 2020-02-27 22:39:05 UTC
tomcat:9 now uses jdk:1.8 for compilation but there is still the need for jdk:11 due to eclipse-ecj:4.13 (though i changed eclipse-ecj to use source/target 1.8, it still needs jdk:11 to compile)
Comment 3 Max Nokhrin 2020-03-03 00:14:47 UTC
Is there any chance we can get the latest 9 at least in the unstable tree that doesn't require jre/jdk:11 and accepts 1.8?
Comment 4 Miroslav Šulc gentoo-dev 2020-03-03 00:19:36 UTC
tomcat:9 itself does not require jdk:11 as of now. the problem is ecj (which tomcat depends on) does, ecj does not compile with jdk:1.8.
Comment 5 Miroslav Šulc gentoo-dev 2020-03-05 22:21:29 UTC
i think what might work is creating binary ecj ebuild on another system where jdk:11 is umasked and then installing the binary package on the target system and emerging tomcat:9.
Comment 6 Reva Denis 2020-10-27 10:41:38 UTC
May be we should just stabilize java 11 and completely remove java 8 because ones is closing to EOL