Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 710194 - net-misc/dhcp-4.4.2-r2 : fails to build with -fno-common or gcc-10
Summary: net-misc/dhcp-4.4.2-r2 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL: https://gitlab.isc.org/isc-projects/d...
Whiteboard:
Keywords: PATCH
: 706288 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-02-19 17:44 UTC by Toralf Förster
Modified: 2020-05-02 18:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.21 KB, text/plain)
2020-02-19 17:44 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,177.16 KB, text/plain)
2020-02-19 17:44 UTC, Toralf Förster
Details
environment (environment,63.66 KB, text/plain)
2020-02-19 17:44 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,18.98 KB, application/x-bzip)
2020-02-19 17:45 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,22.21 KB, application/x-bzip)
2020-02-19 17:45 UTC, Toralf Förster
Details
net-misc:dhcp-4.4.2-r2:20200219-005603.log (net-misc:dhcp-4.4.2-r2:20200219-005603.log,217.68 KB, text/plain)
2020-02-19 17:45 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,28.25 KB, application/x-bzip)
2020-02-19 17:45 UTC, Toralf Förster
Details
dhcp-4.4.2-fno-common.patch (dhcp-4.4.2-fno-common.patch,876 bytes, patch)
2020-03-17 08:19 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-02-19 17:44:50 UTC
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../includes  -DCLIENT_PATH='"PATH=/usr/sbin:/sbin:/bin:/usr/sbin:/usr/bin"' -DLOCALSTATEDIR='"/var/lib"'   -O2 -pipe -march=native -fno-common  -I../includes -I/var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/include -c -o clparse.o clparse.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../includes  -DCLIENT_PATH='"PATH=/usr/sbin:/sbin:/bin:/usr/sbin:/usr/bin"' -DLOCALSTATEDIR='"/var/lib"'   -O2 -pipe -march=native -fno-common  -I../includes -I/var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/include -c -o dhclient.o dhclient.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../includes  -DCLIENT_PATH='"PATH=/usr/sbin:/sbin:/bin:/usr/sbin:/usr/bin"' -DLOCALSTATEDIR='"/var/lib"'   -O2 -pipe -march=native -fno-common  -I../includes -I/var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/include -c -o dhc6.o dhc6.c
x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=native -fno-common  -I../includes -I/var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/include  -Wl,-O1 -Wl,--as-needed -o dhclient client_tables.o clparse.o dhclient.o dhc6.o ../common/libdhcp.a ../omapip/libomapi.a /var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/bind-9.11.14/lib/irs/libirs.a /var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/bind-9.11.14/lib/dns/libdns.a /var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/bind-9.11.14/lib/isccfg/libisccfg.a /var/tmp/portage/net-misc/dhcp-4.4.2-r2/work/dhcp-4.4.2/bind/bind-9.11.14/lib/isc/libisc.a 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: ../common/libdhcp.a(discover.o):(.bss+0x8e): multiple definition of `remote_port'; dhclient.o:(.bss+0x174): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: ../common/libdhcp.a(discover.o):(.bss+0x90): multiple definition of `local_port'; dhclient.o:(.bss+0x176): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20200215-095802

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.41.0 *
java-config:
The following VMs are available for generation-2:

ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Tue, 18 Feb 2020 23:37:28 +0000

emerge -qpvO net-misc/dhcp
[ebuild  N    ] net-misc/dhcp-4.4.2-r2  USE="client ipv6 server ssl -ldap -libressl (-selinux) -vim-syntax"
Comment 1 Toralf Förster gentoo-dev 2020-02-19 17:44:53 UTC
Created attachment 614512 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-02-19 17:44:56 UTC
Created attachment 614514 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-02-19 17:44:59 UTC
Created attachment 614516 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-02-19 17:45:02 UTC
Created attachment 614518 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-02-19 17:45:05 UTC
Created attachment 614520 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-02-19 17:45:08 UTC
Created attachment 614522 [details]
net-misc:dhcp-4.4.2-r2:20200219-005603.log
Comment 7 Toralf Förster gentoo-dev 2020-02-19 17:45:14 UTC
Created attachment 614524 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-03-17 08:19:08 UTC
Created attachment 620740 [details, diff]
dhcp-4.4.2-fno-common.patch
Comment 9 David Seifert gentoo-dev 2020-04-21 09:14:49 UTC
*** Bug 706288 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2020-04-21 09:28:54 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=12b4d8f06024aba59d700e6b3c40ae5b46ed9d26

commit 12b4d8f06024aba59d700e6b3c40ae5b46ed9d26
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-04-21 09:28:39 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-04-21 09:28:48 +0000

    net-misc/dhcp: Fix build with gcc-10
    
    Bug: https://bugs.gentoo.org/710194
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 net-misc/dhcp/dhcp-4.4.2-r2.ebuild              |  3 +++
 net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch | 34 +++++++++++++++++++++++++
 2 files changed, 37 insertions(+)