Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 709800 - sys-firmware/intel-microcode-20191115_p20200209 requires mounted /boot
Summary: sys-firmware/intel-microcode-20191115_p20200209 requires mounted /boot
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-16 11:02 UTC by Joerg Schaible
Modified: 2020-02-16 15:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Schaible 2020-02-16 11:02:48 UTC
An update to intel-microcode fails if /boot is not mounted. Packages like grub will auto-mount /boot.

=============== %< ===============
>>> Running pre-merge checks for sys-firmware/intel-microcode-20191115_p20200209
 * Your boot partition is not mounted at /boot.
 * Please mount it and retry.
 * ERROR: sys-firmware/intel-microcode-20191115_p20200209::gentoo failed (pretend phase):
 *   /boot not mounted
 * 
 * Call stack:
 *                                   ebuild.sh, line 125:  Called pkg_pretend
 *   intel-microcode-20191115_p20200209.ebuild, line  50:  Called mount-boot_pkg_pretend
 *                           mount-boot.eclass, line  87:  Called mount-boot_check_status
 *                           mount-boot.eclass, line  72:  Called die
 * The specific snippet of code:
 *              die "/boot not mounted"
 * 
 * If you need support, post the output of `emerge --info '=sys-firmware/intel-microcode-20191115_p20200209::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-firmware/intel-microcode-20191115_p20200209::gentoo'`.
 * The complete build log is located at '/var/log/portage/sys-firmware:intel-microcode-20191115_p20200209:20200216-020507.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/portage/sys-firmware/intel-microcode-20191115_p20200209/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/portage/sys-firmware/intel-microcode-20191115_p20200209/temp/die.env'.
 * Working directory: '/var/tmp/portage/portage/sys-firmware/intel-microcode-20191115_p20200209/homedir'
 * S: '/var/tmp/portage/portage/sys-firmware/intel-microcode-20191115_p20200209/work'
=============== %< ===============

Reproducible: Always

Steps to Reproduce:
1. ensure /boot is not mounted
2. emerge sys-firmware/intel-microcode
3.
Actual Results:  
Ebuild fails

Expected Results:  
Auto-mount of /boot and a successful build
Comment 1 Thomas Deutschmann gentoo-dev Security 2020-02-16 15:15:19 UTC
(In reply to Joerg Schaible from comment #0)
> An update to intel-microcode fails if /boot is not mounted. Packages like
> grub will auto-mount /boot.

Please elaborate what you mean with "packages like grub will auto-mount" because this should be wrong.

Since commit https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2d90570e81469bf75b2d4a4275151e282632c18e (bug 532264), mount-boot.eclass is no longer able to mount /boot.