Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 709544 - sys-power/nvclock-0.8_p20110102-r2 : fails to build with -fno-common or gcc-10
Summary: sys-power/nvclock-0.8_p20110102-r2 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrew Savchenko
URL:
Whiteboard:
Keywords: PATCH
: 738402 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-02-14 00:46 UTC by Jeroen Roovers (RETIRED)
Modified: 2020-08-29 17:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/nvclock-0.8_p20110102-fno-common.patch (nvclock-0.8_p20110102-fno-common.patch,304 bytes, patch)
2020-02-14 00:46 UTC, Jeroen Roovers (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2020-02-14 00:46:21 UTC
Created attachment 613742 [details, diff]
files/nvclock-0.8_p20110102-fno-common.patch

/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./backend/libbackend.a(backend.o):/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src/backend/../nvcontrol/nvcontrol.h:45: multiple definition of `option_list'; /home/portage/sys-power/nvclock-0.8_p20110102-r2/temp/ccTnvLMd.o:/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src/./nvcontrol/nvcontrol.h:45: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./nvcontrol/libnvcontrol.a(libnvcontrol.o):/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src/nvcontrol/nvcontrol.h:45: multiple definition of `option_list'; /home/portage/sys-power/nvclock-0.8_p20110102-r2/temp/ccTnvLMd.o:/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src/./nvcontrol/nvcontrol.h:45: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./nvcontrol/libnvcontrol.a(nvcontrol.o):/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src/nvcontrol/nvcontrol.h:45: multiple definition of `option_list'; /home/portage/sys-power/nvclock-0.8_p20110102-r2/temp/ccTnvLMd.o:/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src/./nvcontrol/nvcontrol.h:45: first defined here
collect2: error: ld returned 1 exit status
make: *** [Makefile:40: nvclock] Error 1
make: Leaving directory '/home/portage/sys-power/nvclock-0.8_p20110102-r2/work/nvclock-0.8_p20110102/src'
 * ERROR: sys-power/nvclock-0.8_p20110102-r2::gentoo failed (compile phase):
 *   emake failed
Comment 1 David Seifert gentoo-dev 2020-08-29 17:02:47 UTC
*** Bug 738402 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2020-08-29 17:34:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bb50b8477b5209d012332bcb532bd6cee7311145

commit bb50b8477b5209d012332bcb532bd6cee7311145
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-08-29 17:33:53 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-08-29 17:33:53 +0000

    sys-power/nvclock: Port to EAPI 7
    
    Closes: https://bugs.gentoo.org/709544
    Closes: https://bugs.gentoo.org/726030
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../files/nvclock-0.8_p20110102-fno-common.patch   |  11 ++
 .../files/nvclock-0.8_p20110102-r1-make.patch      | 135 +++++++++++++++------
 sys-power/nvclock/nvclock-0.8_p20110102-r2.ebuild  |  36 +++---
 3 files changed, 129 insertions(+), 53 deletions(-)