Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 708824 - sys-apps/systemd: login with usernames including a dot (".") automatically closes gdm session due to pam_systemd forbidding it
Summary: sys-apps/systemd: login with usernames including a dot (".") automatically cl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo systemd Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-09 12:11 UTC by Oliver Welter
Modified: 2020-03-05 16:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Log journal for logging in process (gdm_error.log,133.02 KB, text/plain)
2020-02-09 12:13 UTC, Oliver Welter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Welter 2020-02-09 12:11:25 UTC
Looks like the username including a dot causes an error for creating the session.

See in attached log:
Feb 09 12:03:01 cloud gdm-password][99754]: pam_systemd(gdm-password:session): Failed to get user record: Invalid argument
Feb 09 12:03:01 cloud gdm-password][99754]: gkr-pam: unable to locate daemon control file


Reproducible: Always

Steps to Reproduce:
1.Create a user with a dot in it, e.g. "tony.stark"
2.Set a password for the user "tony.stark"
3.Login via gdm
Actual Results:  
The screen blanks and then the login screen is shown again.

Expected Results:  
The desktop is of the user is shown.
Comment 1 Oliver Welter 2020-02-09 12:13:23 UTC
Created attachment 613050 [details]
Log journal for logging in process
Comment 2 Matt Turner gentoo-dev 2020-02-09 19:53:58 UTC
Is there an upstream bug report?
Comment 3 Oliver Welter 2020-02-15 09:48:08 UTC
Just created one: https://gitlab.gnome.org/GNOME/gdm/issues/559
Comment 4 Pacho Ramos gentoo-dev 2020-02-22 17:46:04 UTC
It looks to be a pam_systemd issue
https://github.com/systemd/systemd/pull/13244

What systemd version are you running?
Comment 5 Mike Gilbert gentoo-dev 2020-02-22 18:25:44 UTC
I can reproduce the pam_systemd issue with sys-apps/systemd-245_rc1-r1.

Feb 22 13:22:05 naomi sshd[2623165]: pam_unix(sshd:session): session opened for user tony.stark(uid=10001) by (uid=0)
Feb 22 13:22:05 naomi sshd[2623165]: pam_systemd(sshd:session): Failed to get user record: Invalid argument
Comment 6 Oliver Welter 2020-02-22 18:54:24 UTC
I'm using sys-apps/systemd-245_rc1-r1 as well.
Comment 7 Mike Gilbert gentoo-dev 2020-02-22 19:17:03 UTC
I'm working on a patch.
Comment 8 Mike Gilbert gentoo-dev 2020-03-05 16:32:07 UTC
Should be resolved in systemd-245_rc2.