Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708008 - net-misc/grive-0.5.1_pre20171005 with sys-libs/binutils-libs-2.34 - .../work/grive-0.5.1_pre20171005/libgrive/src/bfd/SymbolInfo.cc:121:16: error: ‘bfd_get_section_vma’ was not declared in this scope; did you mean ‘bfd_set_section_vma’?
Summary: net-misc/grive-0.5.1_pre20171005 with sys-libs/binutils-libs-2.34 - .../work/...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christoph Junghans
URL:
Whiteboard: ~arch only
Keywords: PATCH, PullRequest
: 708724 725184 (view as bug list)
Depends on:
Blocks: binutils-2.34
  Show dependency tree
 
Reported: 2020-02-03 14:57 UTC by Steven Green
Modified: 2020-09-20 14:14 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (net-misc:grive-0.5.1_pre20171005:20200203-144624.log,50.13 KB, text/plain)
2020-02-03 14:58 UTC, Steven Green
Details
grive-0.5.1_pre20171005-binutils-2.34.patch (grive-0.5.1_pre20171005-binutils-2.34.patch,567 bytes, patch)
2020-02-03 20:46 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Green 2020-02-03 14:57:37 UTC
Emerging net-misc/grive fails after updating binutils-libs to version 2.34.

This is possibly be a dependency of bug #707898 that is tracking bin-utils-2.34 issues.

Errors include:

/var/tmp/portage/net-misc/grive-0.5.1_pre20171005/work/grive-0.5.1_pre20171005/libgrive/src/bfd/SymbolInfo.cc:121:16: error: ‘bfd_get_section_vma’ was not declared in this scope; did you mean ‘bfd_set_section_vma’?
  121 |  bfd_vma vma = bfd_get_section_vma(abfd, section);
      |                ^~~~~~~~~~~~~~~~~~~
      |                bfd_set_section_vma
/var/tmp/portage/net-misc/grive-0.5.1_pre20171005/work/grive-0.5.1_pre20171005/libgrive/src/bfd/SymbolInfo.cc:127:40: error: cannot convert ‘bfd*’ to ‘const asection*’ {aka ‘const bfd_section*’}
  127 |  bfd_size_type size = bfd_section_size(abfd, section);
      |                                        ^~~~
      |                                        |
      |                                        bfd*
In file included from /usr/include/bfd.h:10,
                 from /var/tmp/portage/net-misc/grive-0.5.1_pre20171005/work/grive-0.5.1_pre20171005/libgrive/src/bfd/SymbolInfo.cc:26:
/usr/include/x86_64-pc-linux-gnu/bfd.h:1205:35: note:   initializing argument 1 of ‘bfd_size_type bfd_section_size(const asection*)’
 1205 | bfd_section_size (const asection *sec)
      |                   ~~~~~~~~~~~~~~~~^~~


Reproducible: Always
Comment 1 Steven Green 2020-02-03 14:58:55 UTC
Created attachment 611190 [details]
build.log
Comment 2 Sergei Trofimovich gentoo-dev 2020-02-03 20:46:45 UTC
Created attachment 611500 [details, diff]
grive-0.5.1_pre20171005-binutils-2.34.patch

grive-0.5.1_pre20171005-binutils-2.34.patch is a simple patch that can be conditionally applied against >=binutils-2.34. See blocker bug for other examples how to port to binutils-2.34.
Comment 3 Christoph Junghans gentoo-dev 2020-02-03 22:35:27 UTC
Thanks for the patch, has anyone reported that upstream yet?
Comment 4 Jeroen Roovers gentoo-dev 2020-02-08 13:19:53 UTC
*** Bug 708724 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Junghans gentoo-dev 2020-09-20 14:08:45 UTC
*** Bug 725184 has been marked as a duplicate of this bug. ***
Comment 6 Larry the Git Cow gentoo-dev 2020-09-20 14:14:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=66ad936a19e0032422bc274f201f7ef8ebb32a83

commit 66ad936a19e0032422bc274f201f7ef8ebb32a83
Author:     Christoph Junghans <junghans@gentoo.org>
AuthorDate: 2020-09-20 14:13:29 +0000
Commit:     Christoph Junghans <junghans@gentoo.org>
CommitDate: 2020-09-20 14:14:31 +0000

    net-misc/grive: fix build with new binutils
    
    Closes: https://bugs.gentoo.org/708008
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: Christoph Junghans <junghans@gentoo.org>

 net-misc/grive/files/299.patch       | 113 +++++++++++++++++++++++++++++++++++
 net-misc/grive/grive-0.5.1-r1.ebuild |  36 +++++++++++
 2 files changed, 149 insertions(+)