Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 70796 - app-office/dia-0.93 failing when run with an invalid DISPLAY environment
Summary: app-office/dia-0.93 failing when run with an invalid DISPLAY environment
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2004-11-11 07:31 UTC by kevin arnold
Modified: 2005-03-10 00:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description kevin arnold 2004-11-11 07:31:05 UTC
While doing an emerge world I ran into a problem with the dia emerge.  The ./configure indicated that it could not find the pygtk module because the X11 connection was rejected.  The end of the emerge output is listed below.  This failure occured because I ran the emerge from a screen session that I had established after connecting on ssh with X11 forwarding turned on.  Once I disconnected to let the emerge run, the DISPLAY environment variable was no longer valid but still in memory.  After clearing the DISPLAY variable, the emerge ran fine.  This problem should be avoidable by clearing DISPLAY in the ebuild before the configure script is run since no X connections are actually required for the pygtk detection.

checking for db2html... no
checking for python... /usr/bin/python
checking if Python version >= 1.5.2... okay
checking local Python configuration... checking for  script directory...
checking for  extension module directory... /usr/lib/python2.3/site-packages
looks good
checking for python module gtk... X11 connection rejected because of wrong
configure: error: could not find pygtk module

!!! ERROR: app-office/dia-0.93 failed.
!!! Function econf, Line 449, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status
Comment 1 Leonardo Boshell (RETIRED) gentoo-dev 2004-11-22 11:49:44 UTC
This is a minor bug in the autoconf macro that checks for the pygtk module. Could you try the procedure you describe with dia-0.94?
Comment 2 Leonardo Boshell (RETIRED) gentoo-dev 2005-03-10 00:22:52 UTC
No reply