Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 70787 - lincvs crashes on diff
Summary: lincvs crashes on diff
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-11-11 06:14 UTC by Martin Tsachev
Modified: 2004-11-13 14:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tsachev 2004-11-11 06:14:27 UTC
lincvs crashes if I do a diff to console

Reproducible: Always
Steps to Reproduce:
1. Go to a working copy of a CVS project
2. Select diff against repository version
3. lincvs crashes

Actual Results:  
lincvs crashed

Expected Results:  
diff output
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2004-11-12 11:20:35 UTC
It doesn't work for me either, but it does not crash. Which lincvs and diffutils versions are you using? provides snapshots, if you like to try it.
Comment 2 Martin Tsachev 2004-11-13 02:59:19 UTC
I found how to fix that, I selected an external diff command tried a diff, it crashed, then removed the checkbox and it worked.
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2004-11-13 12:25:08 UTC
Well, I don't think this is an issue we have to take care of. You may test the snapshot anyways and report upstream, if you can reproduce the crash and your time allows it. :)
Comment 4 Martin Tsachev 2004-11-13 14:18:57 UTC
It used to work up to 1.3.0 on Debian for me (didn't have a Debian box after that) and then it crashed on for me on FreeBSD but other apps crashed too so I didn't bother reporting that.

I suppose it maybe is a crash caused by the configuration because I copied it over from the FreeBSD box. Can't reproduce it anymore though.