Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 70763 - Samba emerge for 3.0.8 fails to install; wrong MD5 or filesize in distribution
Summary: Samba emerge for 3.0.8 fails to install; wrong MD5 or filesize in distribution
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's SAMBA Team
: 70778 (view as bug list)
Depends on:
Reported: 2004-11-11 02:59 UTC by Stefano
Modified: 2004-11-12 05:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Stefano 2004-11-11 02:59:32 UTC
Whenever emerging (emerge update) samba 3.0.8, I get to the following:

>>> md5 src_uri ;-) samba-3.0.8.tar.gz

!!! Digest verification Failed:
!!!    /usr/portage/distfiles/smbldap-tools-0.8.5.tgz
!!! Reason: Filesize does not match recorded size

Reproducible: Always
Steps to Reproduce:
1. emerge -Du samba
Comment 1 Michael Glauche (RETIRED) gentoo-dev 2004-11-11 04:35:34 UTC
if you have an old version of smbldap-tools-0.8.5.tgz, i.e. the 3.0.8 ebuild did not download it, please remove /usr/portage/distfiles/smbldap-tools-0.8.5.tgz and reemerge samba :
Comment 2 Stefano 2004-11-11 04:40:09 UTC
First thing I did, obviously... same result
Comment 3 Michael Glauche (RETIRED) gentoo-dev 2004-11-11 04:48:53 UTC
ok, then satya has still the old version on his harddrive :(

To get it working right now, do a 
ebuild /usr/portage/net-fs/samba/samba-3.0.8.ebuild digest

and re-emerge samba, i'll fix the digest in cvs ....
(the correct digest should look like this:
998ece1ac96680d75cebe6f0352f56b9  smbldap-tools-0.8.5.tgz 271436
It's correct on the mirrors + the original file)
Comment 4 Carsten Lohrke (RETIRED) gentoo-dev 2004-11-11 05:42:44 UTC
*** Bug 70778 has been marked as a duplicate of this bug. ***
Comment 5 Stefano 2004-11-11 07:50:22 UTC
just sync'ed, now it's perfect. Solved.
Comment 6 Christian Andreetta (RETIRED) gentoo-dev 2004-11-12 05:05:11 UTC
no, _this_ time that's officially not me ;-)
Comment 7 Michael Glauche (RETIRED) gentoo-dev 2004-11-12 05:15:59 UTC
oh, sorry, just saw in the logs  ... seems the mips guy brought back the mess from the dead ...