Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 707620 - net-mail/email-3.1.3 : fails to build with -fno-common or gcc-10
Summary: net-mail/email-3.1.3 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 721174 722136 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-31 17:39 UTC by Toralf Förster
Modified: 2020-05-17 10:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.68 KB, text/plain)
2020-01-31 17:39 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,218.68 KB, text/plain)
2020-01-31 17:39 UTC, Toralf Förster
Details
environment (environment,10.29 KB, text/plain)
2020-01-31 17:39 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,14.21 KB, application/x-bzip)
2020-01-31 17:39 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.02 KB, application/x-bzip)
2020-01-31 17:39 UTC, Toralf Förster
Details
net-mail:email-3.1.3:20200131-040254.log (net-mail:email-3.1.3:20200131-040254.log,33.07 KB, text/plain)
2020-01-31 17:39 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,7.00 KB, application/x-bzip)
2020-01-31 17:39 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-31 17:39:32 UTC
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-common -Wall -W -DUSE_GNU_STRFTIME -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3 -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/src -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/include -I../include -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/dlib/include -I../dlib/include -DEMAIL_VERSION='"3.1.3"' -DCOMPILE_DATE='"10/31/2010-01:13:35PM_EDT"' -DEMAIL_DIR='"/etc/email"' -DHAVE_CONFIG_H   -c -o sig_file.o sig_file.c
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-common -Wall -W -DUSE_GNU_STRFTIME -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3 -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/src -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/include -I../include -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/dlib/include -I../dlib/include -DEMAIL_VERSION='"3.1.3"' -DCOMPILE_DATE='"10/31/2010-01:13:35PM_EDT"' -DEMAIL_DIR='"/etc/email"' -DHAVE_CONFIG_H   -c -o smtpcommands.o smtpcommands.c
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-common -Wall -W -DUSE_GNU_STRFTIME -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3 -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/src -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/include -I../include -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/dlib/include -I../dlib/include -DEMAIL_VERSION='"3.1.3"' -DCOMPILE_DATE='"10/31/2010-01:13:35PM_EDT"' -DEMAIL_DIR='"/etc/email"' -DHAVE_CONFIG_H   -c -o utils.o utils.c
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-common -Wall -W -DUSE_GNU_STRFTIME -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3 -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/src -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/include -I../include -I/var/tmp/portage/net-mail/email-3.1.3/work/email-3.1.3/dlib/include -I../dlib/include -DEMAIL_VERSION='"3.1.3"' -DCOMPILE_DATE='"10/31/2010-01:13:35PM_EDT"' -DEMAIL_DIR='"/etc/email"' -DHAVE_CONFIG_H -o email email.o addr_parse.o addy_book.o conf.o error.o execgpg.o file_io.o message.o mimeutils.o processmail.o progress_bar.o remotesmtp.o sig_file.o smtpcommands.o utils.o  ../dlib/libdlib.a -Wl,-O1 -Wl,--as-needed -lcrypto -lssl -lm 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: addr_parse.o:(.bss+0x0): multiple definition of `Mopts'; email.o:(.bss+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: addr_parse.o:(.bss+0x48): multiple definition of `global_msg'; email.o:(.bss+0x48): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop-libressl-20200125-232521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.14.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Fri, 31 Jan 2020 01:26:20 +0000

emerge -qpvO net-mail/email
[ebuild  N    ] net-mail/email-3.1.3
Comment 1 Toralf Förster gentoo-dev 2020-01-31 17:39:34 UTC
Created attachment 609718 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-31 17:39:37 UTC
Created attachment 609720 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-31 17:39:40 UTC
Created attachment 609722 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-31 17:39:43 UTC
Created attachment 609724 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-31 17:39:45 UTC
Created attachment 609726 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-31 17:39:48 UTC
Created attachment 609728 [details]
net-mail:email-3.1.3:20200131-040254.log
Comment 7 Toralf Förster gentoo-dev 2020-01-31 17:39:51 UTC
Created attachment 609730 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-17 09:50:27 UTC
*** Bug 721174 has been marked as a duplicate of this bug. ***
Comment 9 Jeroen Roovers gentoo-dev 2020-05-17 09:50:35 UTC
*** Bug 722136 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2020-05-17 10:17:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=538995b35f322ce17289f855575cca28084782bd

commit 538995b35f322ce17289f855575cca28084782bd
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2020-05-17 10:16:52 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2020-05-17 10:17:49 +0000

    net-mail/email: Fix building with CFLAGS=-fno-common
    
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Closes: https://bugs.gentoo.org/707620
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 net-mail/email/email-3.1.3-r1.ebuild              | 21 +++++++++++++++
 net-mail/email/files/email-3.1.3-fno-common.patch | 32 +++++++++++++++++++++++
 2 files changed, 53 insertions(+)