Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 707162 - media-video/transcode-1.1.7-r3 : fails to build with -fno-common or gcc-10
Summary: media-video/transcode-1.1.7-r3 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: PATCH
: 722828 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-29 17:51 UTC by Toralf Förster
Modified: 2020-05-15 16:25 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.85 KB, text/plain)
2020-01-29 17:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,121.05 KB, text/plain)
2020-01-29 17:51 UTC, Toralf Förster
Details
environment (environment,63.56 KB, text/plain)
2020-01-29 17:51 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.88 KB, application/x-bzip)
2020-01-29 17:51 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,12.95 KB, application/x-bzip)
2020-01-29 17:51 UTC, Toralf Förster
Details
media-video:transcode-1.1.7-r3:20200129-014710.log (media-video:transcode-1.1.7-r3:20200129-014710.log,292.42 KB, text/plain)
2020-01-29 17:51 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,42.73 KB, application/x-bzip)
2020-01-29 17:51 UTC, Toralf Förster
Details
files/transcode-1.1.7-fno-common.patch (transcode-1.1.7-fno-common.patch,860 bytes, patch)
2020-04-09 08:15 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-29 17:51:03 UTC
  482 |   int tmp;
      |       ^~~
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc    -Wall -Wstrict-prototypes -Wmissing-prototypes -O2 -pipe -march=native -fno-common  -Wl,-O1 -Wl,--as-needed -o tcdemux tcdemux-aux_pes.o tcdemux-tcdemux.o tcdemux-demux_pass.o tcdemux-demuxer.o tcdemux-dvd_reader.o tcdemux-fileinfo.o tcdemux-ioaux.o tcdemux-packets.o tcdemux-scan_pack.o tcdemux-seqinfo.o ../avilib/libavi.la     ../aclib/libac.la ../libtc/libtc.la -lpthread -lm -lm -lz -ldl 
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -Wstrict-prototypes -Wmissing-prototypes -O2 -pipe -march=native -fno-common -Wl,-O1 -o tcdemux tcdemux-aux_pes.o tcdemux-tcdemux.o tcdemux-demux_pass.o tcdemux-demuxer.o tcdemux-dvd_reader.o tcdemux-fileinfo.o tcdemux-ioaux.o tcdemux-packets.o tcdemux-scan_pack.o tcdemux-seqinfo.o  -Wl,--as-needed ../avilib/.libs/libavi.a ../aclib/.libs/libac.a ../libtc/.libs/libtc.a -lpthread -lm -lz -ldl
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: tcdemux-demuxer.o:(.bss+0x0): multiple definition of `gop_cnt'; tcdemux-demux_pass.o:(.bss+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: tcdemux-demuxer.o:(.bss+0x4): multiple definition of `gop_pts'; tcdemux-demux_pass.o:(.bss+0x4): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-20200126-201521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.242_p08 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Wed, 29 Jan 2020 00:26:22 +0000

emerge -qpvO media-video/transcode
[ebuild  N    ] media-video/transcode-1.1.7-r3  USE="iconv -X -a52 -aac -alsa (-altivec) -dv -dvd -imagemagick -jpeg -lzo -mjpeg -mp3 -mpeg (-nuv) -ogg -oss (-pic) -postproc -quicktime -sdl -theora -truetype -v4l -vorbis -x264 -xml -xvid" CPU_FLAGS_X86="mmx sse sse2 -3dnow"
Comment 1 Toralf Förster gentoo-dev 2020-01-29 17:51:06 UTC
Created attachment 607602 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-29 17:51:08 UTC
Created attachment 607604 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-29 17:51:11 UTC
Created attachment 607606 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-29 17:51:14 UTC
Created attachment 607608 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-29 17:51:17 UTC
Created attachment 607610 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-29 17:51:20 UTC
Created attachment 607612 [details]
media-video:transcode-1.1.7-r3:20200129-014710.log
Comment 7 Toralf Förster gentoo-dev 2020-01-29 17:51:22 UTC
Created attachment 607614 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-04-09 08:15:30 UTC
Created attachment 631552 [details, diff]
files/transcode-1.1.7-fno-common.patch
Comment 9 Francois Chenier 2020-05-13 00:28:05 UTC
Same issue with media-video/transcode-1.1.7-r4 and -r5
Comment 10 email200202 2020-05-13 04:21:25 UTC
After update today, I got the same problem with media-video/transcode-1.1.7-r5
Comment 11 Michal Jakubowski 2020-05-13 08:19:36 UTC
Patch fix issue for media-video/transcode-1.1.7-r5
Comment 12 email200202 2020-05-13 08:41:14 UTC
The patch works for media-video/transcode-1.1.7-r5
Comment 13 Jeroen Roovers gentoo-dev 2020-05-13 10:27:34 UTC
*** Bug 722828 has been marked as a duplicate of this bug. ***
Comment 14 Larry the Git Cow gentoo-dev 2020-05-15 16:25:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6228d70137eab7594520fe6e4dbd1a9a23bfe967

commit 6228d70137eab7594520fe6e4dbd1a9a23bfe967
Author:     Ben Kohler <bkohler@gentoo.org>
AuthorDate: 2020-05-15 16:23:38 +0000
Commit:     Ben Kohler <bkohler@gentoo.org>
CommitDate: 2020-05-15 16:23:58 +0000

    media-video/transcode: add gcc-10 / -fno-common fix
    
    Closes: https://bugs.gentoo.org/707162
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Ben Kohler <bkohler@gentoo.org>

 .../files/transcode-1.1.7-gcc10-fno-common.patch   | 48 ++++++++++++++++++++++
 media-video/transcode/transcode-1.1.7-r5.ebuild    |  1 +
 2 files changed, 49 insertions(+)