Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706926 - net-misc/nx-3.5.99.22 : fails to build with -fno-common or gcc-10
Summary: net-misc/nx-3.5.99.22 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
: 720914 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-28 18:40 UTC by Toralf Förster
Modified: 2020-05-04 21:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.02 KB, text/plain)
2020-01-28 18:40 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,79.61 KB, text/plain)
2020-01-28 18:41 UTC, Toralf Förster
Details
environment (environment,63.31 KB, text/plain)
2020-01-28 18:41 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.31 KB, application/x-bzip)
2020-01-28 18:41 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,20.39 KB, application/x-bzip)
2020-01-28 18:41 UTC, Toralf Förster
Details
net-misc:nx-3.5.99.22:20200128-105132.log.bz2 (net-misc:nx-3.5.99.22:20200128-105132.log.bz2,50.80 KB, application/x-bzip)
2020-01-28 18:41 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,69.47 KB, application/x-bzip)
2020-01-28 18:41 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-28 18:40:53 UTC
  CCLD libcompext.a
make[6]: Leaving directory '/var/tmp/portage/net-misc/nx-3.5.99.22/work/nx-libs-3.5.99.22/nx-X11/programs/Xserver/hw/nxagent/compext'
make[5]: Leaving directory '/var/tmp/portage/net-misc/nx-3.5.99.22/work/nx-libs-3.5.99.22/nx-X11/programs/Xserver/hw/nxagent'
x86_64-pc-linux-gnu-gcc -o nxagent -O2 -pipe -march=native -fno-common -fno-strict-aliasing -std=c99 -Wall -Wpedantic -Wpointer-arith -Wundef     hw/nxagent/miinitext.o                   hw/nxagent/NXwindow.o                    hw/nxagent/NXevents.o                    hw/nxagent/NXproperty.o                  hw/nxagent/NXdixfonts.o                  hw/nxagent/NXglyphcurs.o                 hw/nxagent/NXdispatch.o                  hw/nxagent/NXrender.o                    hw/nxagent/NXglyph.o                     hw/nxagent/NXpicture.o                   hw/nxagent/NXextension.o                 hw/nxagent/NXglxext.o                    hw/nxagent/NXxvdisp.o                    hw/nxagent/NXresource.o                  hw/nxagent/NXdamage.o                               hw/nxagent/compext/libcompext.a dix/libdix.a os/libos.a  hw/nxagent/libnxagent.a fb/libfb.a composite/libcomposite.a damageext/libdamageext.a  xfixes/libxfixes.a miext/cw/libcw.a 		  Xext/libext.a xkb/libxkb.a os/libos.a Xi/libxinput.a                   dbe/libdbe.a record/librecord.a  GL/glx/libglx.a                GL/mesa/GLcore/libGLcore.a randr/librandr.a render/librender.a  mi/libmi.a composite/libcomposite.a damageext/libdamageext.a  xfixes/libxfixes.a miext/cw/libcw.a 		  Xext/libext.a xkb/libxkb.a os/libos.a Xi/libxinput.a                   dbe/libdbe.a record/librecord.a  GL/glx/libglx.a                GL/mesa/GLcore/libGLcore.a randr/librandr.a render/librender.a hw/nxagent/compext/libcompext.a hw/nxagent/libnxagent.a mi/libmi.a      -L../../../nxcomp/src/.libs                 -L../../../nxcompshad/src/.libs                 -L../../lib/src/.libs                 -lX11                 -lXcomp                 -lXcompshad                 -lXrender                 -lXfixes                 -lXfont2                 -lXcomposite                 -lXinerama                 -lXdmcp                 -lNX_X11                 -lXext                  -L../../exports/lib    $(pkg-config --exists 'zlib' >/dev/null 2>&1 && pkg-config --libs 'zlib' || printf '%s' '-lz') -lm  		     -lXpm `pkg-config --libs libxml-2.0` `pkg-config --libs pixman-1`  $(pkg-config --exists 'zlib' >/dev/null 2>&1 && pkg-config --libs 'zlib' || printf '%s' '-lz') `pkg-config --libs libpng` -ljpeg -Wl,-O1 -Wl,--as-needed
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: hw/nxagent/NXevents.o:/var/tmp/portage/net-misc/nx-3.5.99.22/work/nx-libs-3.5.99.22/nx-X11/programs/Xserver/hw/nxagent/Windows.h:307: multiple definition of `nxagentStaticResizedWindowList'; hw/nxagent/NXwindow.o:/var/tmp/portage/net-misc/nx-3.5.99.22/work/nx-libs-3.5.99.22/nx-X11/programs/Xserver/hw/nxagent/Windows.h:307: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: hw/nxagent/NXevents.o:/var/tmp/portage/net-misc/nx-3.5.99.22/work/nx-libs-3.5.99.22/nx-X11/programs/Xserver/hw/nxagent/Windows.h:295: multiple definition of `nxagentConfiguredWindowList'; hw/nxagent/NXwindow.o:/var/tmp/portage/net-misc/nx-3.5.99.22/work/nx-libs-3.5.99.22/nx-X11/programs/Xserver/hw/nxagent/Windows.h:295: first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-libressl_test-20200126-104546

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)

Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
Available Java Virtual Machines:
  (none found)
ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Tue, 28 Jan 2020 10:06:28 +0000

emerge -qpvO net-misc/nx
[ebuild  N    ] net-misc/nx-3.5.99.22
Comment 1 Toralf Förster gentoo-dev 2020-01-28 18:40:56 UTC
Created attachment 606618 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-28 18:41:00 UTC
Created attachment 606620 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-28 18:41:02 UTC
Created attachment 606622 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-28 18:41:05 UTC
Created attachment 606624 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-28 18:41:08 UTC
Created attachment 606626 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-28 18:41:11 UTC
Created attachment 606628 [details]
net-misc:nx-3.5.99.22:20200128-105132.log.bz2
Comment 7 Toralf Förster gentoo-dev 2020-01-28 18:41:14 UTC
Created attachment 606630 [details]
temp.tbz2
Comment 8 Bernard Cafarelli gentoo-dev 2020-05-04 21:07:33 UTC
*** Bug 720914 has been marked as a duplicate of this bug. ***
Comment 9 Bernard Cafarelli gentoo-dev 2020-05-04 21:08:32 UTC
I hoped upstream fix would be merged quickly for that, but it is not yet (and rather large). I will try to append -fcommon until this is fixed with pending version bump
Comment 10 Larry the Git Cow gentoo-dev 2020-05-04 21:23:29 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9dbc6d548f4887b50748825335c026949502e375

commit 9dbc6d548f4887b50748825335c026949502e375
Author:     Bernard Cafarelli <voyageur@gentoo.org>
AuthorDate: 2020-05-04 21:16:17 +0000
Commit:     Bernard Cafarelli <voyageur@gentoo.org>
CommitDate: 2020-05-04 21:23:24 +0000

    net-misc/nx: 3.5.99.23 bump
    
    Switch to ArcticaProject releases
    Move host.def config to src_configure
    Temporarily run with forced -fcommon until bug is fixed upstream
    
    Closes: https://bugs.gentoo.org/706926
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>

 net-misc/nx/Manifest            |   1 +
 net-misc/nx/metadata.xml        |   3 +
 net-misc/nx/nx-3.5.99.23.ebuild | 140 ++++++++++++++++++++++++++++++++++++++++
 3 files changed, 144 insertions(+)