Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706464 - dev-python/matplotlib-2*[gtk2] and dev-python/matplotlib-python2[gtk2] depend on dev-python/pygtk
Summary: dev-python/matplotlib-2*[gtk2] and dev-python/matplotlib-python2[gtk2] depend...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: PullRequest
Depends on: 714376 705646 705650
Blocks: pygtk-removal
  Show dependency tree
 
Reported: 2020-01-26 15:34 UTC by Andreas Sturmlechner
Modified: 2020-06-05 11:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-01-26 15:34:10 UTC
Two revdeps:

sci-chemistry/nmrdepaker
sci-visualization/pythonprop
Comment 1 Benda Xu gentoo-dev 2020-01-27 05:54:37 UTC
matplotlib-3.1.2 is in tree now. After its stabilization, we will get rid of all the 2.x versions.
Comment 2 Andreas Sturmlechner gentoo-dev 2020-01-28 20:49:35 UTC
(In reply to Benda Xu from comment #1)
> matplotlib-3.1.2 is in tree now. After its stabilization, we will get rid of
> all the 2.x versions.
I guess as python2-based revdeps will continue to be around for some time it is more realistic to just get rid of the matplotlib[gtk2] revdeps first.
Comment 3 Larry the Git Cow gentoo-dev 2020-05-19 16:51:46 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8803f21da4bfb23e120d83ccba4577bacaebe610

commit 8803f21da4bfb23e120d83ccba4577bacaebe610
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-05-17 21:15:09 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-05-19 16:51:15 +0000

    dev-python/matplotlib-python2: Drop IUSE="gtk2"
    
    Depends on doomed dev-python/pygtk.
    
    Bug: https://bugs.gentoo.org/706464
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../matplotlib-python2-2.2.5-r1.ebuild             | 208 +++++++++++++++++++++
 1 file changed, 208 insertions(+)
Comment 4 Larry the Git Cow gentoo-dev 2020-06-05 11:30:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0bc07f9928ab1f8ab61b482fb6847afbc574aece

commit 0bc07f9928ab1f8ab61b482fb6847afbc574aece
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-06-05 11:25:28 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-06-05 11:27:58 +0000

    dev-python/matplotlib: Drop IUSE="gtk2"
    
    Depends on doomed dev-python/pygtk.
    
    Closes: https://bugs.gentoo.org/706464
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 dev-python/matplotlib/matplotlib-2.2.2-r1.ebuild | 21 +++++++--------------
 dev-python/matplotlib/matplotlib-2.2.4.ebuild    | 21 +++++++--------------
 dev-python/matplotlib/metadata.xml               |  1 -
 3 files changed, 14 insertions(+), 29 deletions(-)