Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 706078 - media-plugins/gst-plugins-srtp-1.14.5 : gstsrtp-enumtypes.c:6:1: error: stray ‘\’ in program
Summary: media-plugins/gst-plugins-srtp-1.14.5 : gstsrtp-enumtypes.c:6:1: error: stray...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords:
: 706194 (view as bug list)
Depends on:
Blocks: make-4.3
  Show dependency tree
 
Reported: 2020-01-22 09:58 UTC by Kobboi
Modified: 2020-03-18 11:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,56.84 KB, text/plain)
2020-01-22 09:59 UTC, Kobboi
Details
gst-plugins-bad-1.16.2-make43.patch (gst-plugins-bad-1.16.2-make43.patch,3.13 KB, patch)
2020-01-23 12:04 UTC, Lars Wendler (Polynomial-C)
Details | Diff
Patch of media-plugins/gst-plugins-srtp-1.14.5 with make-4.3 (media-plugins_gst-plugins-srtp.patch,10.34 KB, patch)
2020-02-28 02:46 UTC, Phazeus
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2020-01-22 09:58:35 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/work/gst-plugins-bad-1.14.5/ext/srtp -I../.. -pthread -I/usr/include/gstreamer-1.0 -I/usr/lib64/libffi/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DGST_USE_UNSTABLE_API -fno-strict-aliasing -DG_THREADS_MANDATORY -DG_DISABLE_CAST_CHECKS -Wall -Wdeclaration-after-statement -Wvla -Wpointer-arith -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wwrite-strings -Wformat-security -Wold-style-definition -Winit-self -Wmissing-include-dirs -Waddress -Wno-multichar -Wnested-externs -g -fvisibility=hidden -pthread -I/usr/include/gstreamer-1.0 -I/usr/lib64/libffi/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -O2 -march=x86-64 -pipe -fomit-frame-pointer -g -ggdb -c gstsrtp-enumtypes.c  -fPIC -DPIC -o .libs/libgstsrtp_la-gstsrtp-enumtypes.o
gstsrtp-enumtypes.c:6:1: error: stray ‘\’ in program
    6 | \#include "gstsrtpenums.h"
      | ^
gstsrtp-enumtypes.c:6:2: error: stray ‘#’ in program
    6 | \#include "gstsrtpenums.h"
      |  ^
gstsrtp-enumtypes.c:6:11: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before string constant
    6 | \#include "gstsrtpenums.h"
      |           ^~~~~~~~~~~~~~~~
gstsrtp-enumtypes.c: In function ‘gst_srtp_auth_type_get_type’:
gstsrtp-enumtypes.c:31:9: error: ‘GST_SRTP_AUTH_NULL’ undeclared (first use in this function); did you mean ‘GST_STATE_NULL’?
   31 |       { GST_SRTP_AUTH_NULL, "GST_SRTP_AUTH_NULL", "null" },
      |         ^~~~~~~~~~~~~~~~~~
      |         GST_STATE_NULL
gstsrtp-enumtypes.c:31:9: note: each undeclared identifier is reported only once for each function it appears in
gstsrtp-enumtypes.c:32:9: error: ‘GST_SRTP_AUTH_HMAC_SHA1_32’ undeclared (first use in this function)
   32 |       { GST_SRTP_AUTH_HMAC_SHA1_32, "GST_SRTP_AUTH_HMAC_SHA1_32", "hmac-sha1-32" },
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
gstsrtp-enumtypes.c:33:9: error: ‘GST_SRTP_AUTH_HMAC_SHA1_80’ undeclared (first use in this function)
   33 |       { GST_SRTP_AUTH_HMAC_SHA1_80, "GST_SRTP_AUTH_HMAC_SHA1_80", "hmac-sha1-80" },
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
make[1]: *** [Makefile:920: libgstsrtp_la-gstsrtp-enumtypes.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/work/gst-plugins-bad-1.14.5-abi_x86_64.amd64/ext/srtp'
make: *** [Makefile:780: all] Error 2
make: Leaving directory '/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/work/gst-plugins-bad-1.14.5-abi_x86_64.amd64/ext/srtp'
 * ERROR: media-plugins/gst-plugins-srtp-1.14.5::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=media-plugins/gst-plugins-srtp-1.14.5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-plugins/gst-plugins-srtp-1.14.5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/temp/environment'.
 * Working directory: '/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/work/gst-plugins-bad-1.14.5-abi_x86_64.amd64'
 * S: '/var/tmp/portage/media-plugins/gst-plugins-srtp-1.14.5/work/gst-plugins-bad-1.14.5'


Reproducible: Always
Comment 1 Kobboi 2020-01-22 09:59:25 UTC
Created attachment 603942 [details]
build.log
Comment 2 Kobboi 2020-01-22 10:01:01 UTC
Removing the leading \ in that line "fixes" the problem, but I have not yet checked how glib-mkenums generates it
Comment 3 Kobboi 2020-01-22 10:08:08 UTC
Looking at bug #706076, I can confirm that using <make-4.3 "fixes" this issue.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2020-01-23 12:04:09 UTC
Created attachment 604052 [details, diff]
gst-plugins-bad-1.16.2-make43.patch

Possbible fix. Requires eautoreconf from autotools.eclass to be called.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2020-01-23 20:41:19 UTC
*** Bug 706194 has been marked as a duplicate of this bug. ***
Comment 6 Juan Pedro 2020-02-09 12:39:28 UTC
Hi, I've applied the patches here https://bugs.gentoo.org/705974 and I'm having trouble compiling
http://dpaste.com/1NZFMP9
Comment 7 Phazeus 2020-02-28 02:46:25 UTC
Created attachment 616406 [details, diff]
Patch of media-plugins/gst-plugins-srtp-1.14.5 with make-4.3

Another one gstreamer plugin patch.
In all such places replaced "\#" with "$(H)", where H =: \#
Comment 8 Larry the Git Cow gentoo-dev 2020-03-18 11:56:29 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=150ae16b21f309e57afad5c5de0c294a9a96bf67

commit 150ae16b21f309e57afad5c5de0c294a9a96bf67
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-03-18 11:56:07 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-03-18 11:56:07 +0000

    media-plugins/gst-plugins-srtp: Fix for >=make-4.3
    
    Closes: https://bugs.gentoo.org/706078
    Package-Manager: Portage-2.3.94, Repoman-2.3.21
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../files/gst-plugins-srtp-1.14.5-make43.patch     | 226 +++++++++++++++++++++
 .../gst-plugins-srtp-1.14.5.ebuild                 |   4 +
 2 files changed, 230 insertions(+)