Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 706076 - media-libs/gst-plugins-bad-1.14.5: fails to build with ~sys-devel/make-4.3
Summary: media-libs/gst-plugins-bad-1.14.5: fails to build with ~sys-devel/make-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: make-4.3
  Show dependency tree
 
Reported: 2020-01-22 09:21 UTC by Georgy Yakovlev
Modified: 2020-03-18 11:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log.gz,44.48 KB, application/gzip)
2020-01-22 09:22 UTC, Georgy Yakovlev
Details
gst-plugins-bad-1.16.2-make43.patch (gst-plugins-bad-1.16.2-make43.patch,3.13 KB, patch)
2020-01-23 12:03 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Georgy Yakovlev gentoo-dev 2020-01-22 09:21:26 UTC
like $subj says, fails with make-4.3,

but builds absolutely fine with =sys-devel/make-4.2.1-r4
Comment 1 Georgy Yakovlev gentoo-dev 2020-01-22 09:22:15 UTC
Created attachment 603940 [details]
build log
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2020-01-23 12:03:06 UTC
Created attachment 604050 [details, diff]
gst-plugins-bad-1.16.2-make43.patch

Possbible fix. Requires eautoreconf from autotools.eclass to be called.
Comment 3 Russell Dwiggins 2020-02-14 03:29:27 UTC
The patch from Comment 2 did not work for me. 

patching file common/glib-gen.mak
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file common/glib-gen.mak.rej
patching file common/gst-glib-gen.mak
Comment 4 Geoff Madden 2020-03-02 15:12:30 UTC
ditto to comment 3
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2020-03-06 11:14:29 UTC
*** Bug 711668 has been marked as a duplicate of this bug. ***
Comment 6 David Seifert gentoo-dev 2020-03-18 11:26:53 UTC
Should be fixed now with 58f82ad01331675e463f3dc33e1b5b2c1f69a1a0.