Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 705704 - gui-wm/sway-1.2 should not depend on <gui-libs/wlroots-0.9.0
Summary: gui-wm/sway-1.2 should not depend on <gui-libs/wlroots-0.9.0
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Aaron Bauman
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-18 00:18 UTC by kdb424
Modified: 2020-01-19 00:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kdb424 2020-01-18 00:18:56 UTC
Sway 1.2 ebuild has the inclusion of <gui-libs/wlroots-0.9.0 and I believe this to be a mistake. Sway 1.1.1 does not include this, and sway 1.2 builds with wlroots-9999 so this block does not seem needed.

Reproducible: Always

Steps to Reproduce:
1. Install Sway 1.2
2. Sway 1.2 downgrades wlroots
3.


Expected Results:  
wlroots should have not been downgraded when upgrading sway
Comment 1 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2020-01-18 08:42:03 UTC
before this I've seen problems with wlroots-0.9.1 building with sway 1.2
Comment 2 kdb424 2020-01-19 00:47:19 UTC
Should the 9999 build be blocked then as that would be at least 0.9.1 in version?
Comment 3 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2020-01-19 00:53:53 UTC
I would think so