Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 705616 - media-libs/lv2-1.16.0: please stabilize
Summary: media-libs/lv2-1.16.0: please stabilize
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 706052 706056 705618
  Show dependency tree
 
Reported: 2020-01-16 23:16 UTC by Miroslav Šulc
Modified: 2020-02-13 10:03 UTC (History)
1 user (show)

See Also:
Package list:
=media-libs/lv2-1.16.0-r1 alpha amd64 arm arm64 hppa ia64 ppc ppc64 x86
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Šulc gentoo-dev 2020-01-16 23:16:09 UTC
there are open some bugs on current stable lv2 version related to building with doc use flag. these apply also for this version but should not be considered as blockers for the stabilization.


commit cd3f25deb13cf4d6c9d721d515dbf772a988426f
Author: Michał Górny <mgorny@gentoo.org>
Date:   Sun Jan 5 10:36:11 2020 +0100

    */*: Clean PYTHON_COMPAT of obsolete impls
    
    Closes: https://github.com/gentoo/gentoo/pull/14246
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

commit b35e0d239e5838a04bed0517894ba82c051475da
Author: Miroslav Šulc <fordfrog@gentoo.org>
Date:   Sat Dec 14 20:15:12 2019 +0100

    media-libs/lv2-1.16.0: partially fixed doc building
    
    added patch to support python3
    
    Package-Manager: Portage-2.3.81, Repoman-2.3.20
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>

commit d90068a809652013e68f5d44aa555bdcbf47158c
Author: Miroslav Šulc <fordfrog@gentoo.org>
Date:   Sat Dec 14 13:58:29 2019 +0100

    media-libs/lv2-1.16.0: bump
    
    1) removed python2_7, added python3_7
    2) reorganized deps, removed obsolete blockers
    
    Closes: https://bugs.gentoo.org/696394
    Package-Manager: Portage-2.3.81, Repoman-2.3.20
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Comment 1 Agostino Sarubbo gentoo-dev 2020-01-17 09:30:54 UTC
amd64 stable
Comment 2 Agostino Sarubbo gentoo-dev 2020-01-17 09:33:51 UTC
ppc stable
Comment 3 Agostino Sarubbo gentoo-dev 2020-01-17 10:27:34 UTC
ppc64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2020-01-17 10:45:37 UTC
x86 stable
Comment 5 Agostino Sarubbo gentoo-dev 2020-01-17 12:25:35 UTC
ia64 stable
Comment 6 Sergei Trofimovich gentoo-dev 2020-01-20 22:41:55 UTC
hppa stable
Comment 7 Miroslav Šulc gentoo-dev 2020-01-22 00:53:42 UTC
removing alpha...
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-01-27 12:29:18 UTC
arm stable
Comment 9 Stabilization helper bot gentoo-dev 2020-02-13 09:04:33 UTC
An automated check of this bug failed - the following atom is unknown:

media-libs/lv2-1.16.0

Please verify the atom list.
Comment 10 Miroslav Šulc gentoo-dev 2020-02-13 09:07:32 UTC
commit 97597964ca0fea331536a5dea170fba57c2e9270
Author: Michał Górny <mgorny@gentoo.org>
Date:   Fri Feb 7 17:39:45 2020 +0100

    media-libs/lv2: Switch to PYTHON_MULTI_USEDEP API
    
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 media-libs/lv2/{lv2-1.14.0-r1.ebuild => lv2-1.14.0-r2.ebuild} | 8 +++++---
 media-libs/lv2/{lv2-1.16.0.ebuild => lv2-1.16.0-r1.ebuild}    | 8 +++++---
 2 files changed, 10 insertions(+), 6 deletions(-)
Comment 11 Stabilization helper bot gentoo-dev 2020-02-13 10:03:43 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.