Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 704700 - app-emulation/virtualbox-6.0.14 USE=opengl - In file included from /work/VirtualBox-6.0.14/src/VBox/Frontends/VirtualBox/src/VBoxGLSupportInfo.cpp:34: .../include/VBox/VBoxGL2D.h:117:19: error: conflicting declaration ‘typedef ptrdiff_t GLsizeiptr’
Summary: app-emulation/virtualbox-6.0.14 USE=opengl - In file included from /work/Virt...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 733288 (view as bug list)
Depends on:
Blocks: 726846
  Show dependency tree
 
Reported: 2020-01-03 13:27 UTC by Viktor Yu. Kovalskii
Modified: 2020-07-20 08:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (virtualbox-6.0.14:20200103-120922.log.bz2,91.28 KB, application/x-bzip)
2020-01-03 13:30 UTC, Viktor Yu. Kovalskii
Details
Patch for include/VBox/VBoxGL2D.h fixing build virtualbox with USE="opengl" (VBoxGL2D.h.patch,372 bytes, patch)
2020-01-25 16:43 UTC, Viktor Yu. Kovalskii
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor Yu. Kovalskii 2020-01-03 13:27:25 UTC
Emerging =app-emulation/virtualbox-6.0.14 with USE="opengl" fails to build with error:

VirtualBox-6.0.14/include/VBox/VBoxGL2D.h:117:19: error: conflicting declaration ‘typedef ptrdiff_t GLsizeiptr’
  117 | typedef ptrdiff_t GLsizeiptr;
      |                   ^~~~~~~~~~
In file included from /usr/include/qt5/QtGui/qopengl.h:146,
                 from /usr/include/qt5/QtOpenGL/qgl.h:45,
                 from /usr/include/qt5/QtOpenGL/QGLWidget:1,
                 from /mnt/slag/portage/app-emulation/virtualbox-6.0.14/work/VirtualBox-6.0.14/src/VBox/Frontends/VirtualBox/src/VBoxGLSupportInfo.cpp:22:
/usr/include/qt5/QtGui/qopenglext.h:477:30: note: previous declaration as ‘typedef long int GLsizeiptr’
  477 | typedef signed long int      GLsizeiptr;
      |                              ^~~~~~~~~~

Reproducible: Always




emerge --info =virtualbox-6.0.14
Portage 2.3.84 (python 3.6.10-final-0, default/linux/x86/17.0/desktop/plasma, gcc-9.2.0, glibc-2.30-r3, 4.14.158-gentoo i686)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.158-gentoo-i686-Intel-R-_Core-TM-_Duo_CPU_T2350_@_1.86GHz-with-gentoo-2.6
KiB Mem:     3092732 total,    188508 free
KiB Swap:    7347384 total,   6917968 free
Timestamp of repository gentoo: Fri, 03 Jan 2020 08:09:07 +0000
Head commit of repository gentoo: 53d1c64b4cfd6be34750bda36b45d508f5a57216

Timestamp of repository flying: Sun, 29 Dec 2019 12:50:33 +0000
Timestamp of repository oschtan: Wed, 01 Aug 2018 15:39:26 +0000
Head commit of repository deadbeef-overlay: 53e0a41db6e7193bd83ef117f8055457f0990cb7

Head commit of repository jorgicio: 9bcaf6824c9d67dd7463cb3adc4d90d6a1a08433

Head commit of repository kde: 23bc7197cc2377e86efaf8a9d7f67f4a6d703d90

Head commit of repository mozilla: 529ebb2d01743e00db6767e01b495973b4bfa7e2

Head commit of repository rion: 2573c7b3b9d30d066146cbf56eece6c6384e60cf

Head commit of repository science: 4a5df3568fcb228f465287849d51a18cea1bc76a

Head commit of repository stuff: 31ac6aacd9e4ad214de172a914e71aa5f7f065f1

sh bash 5.0_p11
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
ccache version 3.7.6 [enabled]
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r1::gentoo, 3.6.10::gentoo
dev-util/ccache:          3.7.6::gentoo
dev-util/cmake:           3.16.2-r1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            7.4.0-r2::gentoo, 9.2.0-r3::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r3::gentoo
Repositories:

gentoo
    location: /mnt/slag/gentoo-tree
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/repo/sync/gentoo.git
    priority: -1000

flying
    location: /mnt/slag/layman/flying
    masters: gentoo

oschtan
    location: /mnt/slag/layman/oschtan
    sync-type: rsync
    sync-uri: rsync://oschtan.icu/oschtan/
    masters: gentoo
    sync-rsync-extra-opts: 

deadbeef-overlay
    location: /mnt/slag/layman/deadbeef-overlay
    sync-type: git
    sync-uri: https://github.com/damex/deadbeef-overlay.git
    masters: gentoo
    priority: 50

jorgicio
    location: /mnt/slag/layman/jorgicio
    sync-type: git
    sync-uri: https://github.com/jorgicio/jorgicio-gentoo.git
    masters: gentoo
    priority: 50

kde
    location: /mnt/slag/layman/kde
    sync-type: git
    sync-uri: git://anongit.gentoo.org/proj/kde.git
    masters: gentoo
    priority: 50

mozilla
    location: /mnt/slag/layman/mozilla
    sync-type: git
    sync-uri: git://anongit.gentoo.org/proj/mozilla.git
    masters: gentoo
    priority: 50

rion
    location: /mnt/slag/layman/rion
    sync-type: git
    sync-uri: https://github.com/rion-overlay/rion-overlay.git
    masters: gentoo
    priority: 50

science
    location: /mnt/slag/layman/science
    sync-type: git
    sync-uri: git://github.com/gentoo-science/sci.git
    masters: gentoo
    priority: 50

stuff
    location: /mnt/slag/layman/stuff
    sync-type: git
    sync-uri: https://github.com/istitov/stuff.git
    masters: gentoo
    priority: 50

Installed sets: @toolchain
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="@FREE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CPPFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
CXXFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
DISTDIR="/mnt/slag/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build --with-bdeps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg ccache collision-protect distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync metadata-transfer multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles http://trumpetti.atm.tut.fi/gentoo/ http://distfiles.gentoo.org"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru ru_RU"
MAKEOPTS="-j3"
PKGDIR="/mnt/slag/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/mnt/slag"
USE="X a52 aac acl acpi alsa amr apng archive aspell bluetooth branding bzip2 cairo caps cdda cddb cdparanoia cdr cli consolekit curl cxx dbus declarative djvu dri dts dvd dvdnav dvdr emboss emf enca encode exceptions exif expat faac faad fam fbcondecor ffmpeg flac fontconfig fortran ftp fuse gif git glib gmp gnutls gpm harfbuzz http iconv icu idn imagemagick introspection jbig jemalloc jpeg jpeg2k kde kwallet lame latex lcms libass libnotify libsamplerate libtirpc lm-sensors lz4 lzma lzo mad man mime mng modemmanager mp3 mp4 mpeg mtp musepack natspec ncurses networkmanager nls nptl ogg opengl openmp orc osmesa pam pango pcre pdf phonon plasma plymouth png policykit postscript ppds pulseaudio qml qt5 rar readline rtc seccomp sndfile spell split-usr sqlite ssl startup-notification svg tcpd threads tiff truetype twolame udev udisks unicode upower usb utils vorbis wavpack webengine webp widgets wifi wmf wxwidgets x264 x86 xattr xcb xcomposite xml xmp xorg xv xvid xz zip zlib" ABI_X86="32" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python3_6" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-emulation/virtualbox-6.0.14::gentoo was built with the following:
USE="alsa opus pam pulseaudio qt5 sdk udev -debug -doc -dtrace -headless -java -libressl -lvm -opengl -pax_kernel -python -vboxwebsrv -vnc" PYTHON_SINGLE_TARGET="python3_6 -python2_7 (-python3_7)" PYTHON_TARGETS="python3_6 -python2_7 (-python3_7)"
Comment 1 Viktor Yu. Kovalskii 2020-01-03 13:30:46 UTC
Created attachment 602396 [details]
build.log.bz2
Comment 2 Andrew 2020-01-21 22:06:35 UTC
I have exactly the same problem. Virtualbox version - 6.0.16, platform - ~x86.
Comment 3 Viktor Yu. Kovalskii 2020-01-25 16:43:25 UTC
Created attachment 604338 [details, diff]
Patch for include/VBox/VBoxGL2D.h fixing build virtualbox with USE="opengl"

Commenting include typedef ptrdiff_t GLsizeiptr fixes compilation virtualbox with opengl.
Comment 4 nicotroost 2020-04-30 15:55:14 UTC
Same here for virtualbox version 5.2.40 on x86.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2020-07-20 06:52:09 UTC
*** Bug 733288 has been marked as a duplicate of this bug. ***
Comment 6 Larry the Git Cow gentoo-dev 2020-07-20 08:50:06 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=802a30f236390234d24e119aff81b36fa5adf5a0

commit 802a30f236390234d24e119aff81b36fa5adf5a0
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-07-20 08:33:50 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-07-20 08:49:58 +0000

    virtualbox packages: Bump to versions 5.2.44, 6.0.24 and 6.1.12
    
    Closes: https://bugs.gentoo.org/704700
    Package-Manager: Portage-3.0.0, Repoman-2.3.23
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 app-emulation/virtualbox-additions/Manifest        |   3 +
 .../virtualbox-additions-5.2.44.ebuild             |  33 ++
 .../virtualbox-additions-6.0.24.ebuild             |  34 ++
 .../virtualbox-additions-6.1.12.ebuild             |  34 ++
 app-emulation/virtualbox-bin/Manifest              |  10 +
 .../virtualbox-bin-5.2.44.139111.ebuild            | 287 ++++++++++++
 .../virtualbox-bin-6.0.24.139119.ebuild            | 292 ++++++++++++
 .../virtualbox-bin-6.1.12.139181.ebuild            | 292 ++++++++++++
 app-emulation/virtualbox-extpack-oracle/Manifest   |   3 +
 .../virtualbox-extpack-oracle-5.2.44.139111.ebuild |  42 ++
 .../virtualbox-extpack-oracle-6.0.24.139119.ebuild |  43 ++
 .../virtualbox-extpack-oracle-6.1.12.139181.ebuild |  43 ++
 app-emulation/virtualbox-guest-additions/Manifest  |   6 +
 .../virtualbox-guest-additions-5.2.44.ebuild       | 232 ++++++++++
 .../virtualbox-guest-additions-6.0.24.ebuild       | 219 +++++++++
 .../virtualbox-guest-additions-6.1.12a.ebuild      | 221 +++++++++
 app-emulation/virtualbox-modules/Manifest          |   3 +
 .../virtualbox-modules-5.2.44.ebuild               |  59 +++
 .../virtualbox-modules-6.0.24.ebuild               |  55 +++
 .../virtualbox-modules-6.1.12.ebuild               |  55 +++
 app-emulation/virtualbox/Manifest                  |   6 +
 app-emulation/virtualbox/virtualbox-5.2.44.ebuild  | 493 ++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.0.24.ebuild  | 507 ++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.1.12a.ebuild | 509 +++++++++++++++++++++
 24 files changed, 3481 insertions(+)