Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 704372 - app-emulation/vagrant-2.2.6 - does not work with >=virtualbox-6.1
Summary: app-emulation/vagrant-2.2.6 - does not work with >=virtualbox-6.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Georgy Yakovlev
URL:
Whiteboard:
Keywords:
: 704374 (view as bug list)
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-12-31 09:26 UTC by andy
Modified: 2020-01-01 10:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2019-12-31 09:26:14 UTC
hi 
i dont know where to report this problem so i report here

app-emulation/vagrant-2.2.6.ebuild needs to update

with something like this:

 # Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby24 ruby25 ruby26"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
RUBY_FAKEGEM_TASK_DOC=""

inherit bash-completion-r1 ruby-fakegem

DESCRIPTION="A tool for building and distributing development environments"
HOMEPAGE="https://vagrantup.com/"
SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+virtualbox"
RESTRICT="test"

RDEPEND="${RDEPEND}
	app-arch/libarchive
	net-misc/curl
	virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"

ruby_add_rdepend "
	>=dev-ruby/bcrypt_pbkdf-1.0.0
	>=dev-ruby/childprocess-0.6.0
	>=dev-ruby/ed25519-1.2.4
	>=dev-ruby/erubis-2.7.0
	>=dev-ruby/hashicorp-checkpoint-0.1.5
	>=dev-ruby/i18n-1.1.1:1
	>=dev-ruby/listen-3.1.5
	<dev-ruby/log4r-1.1.11
	<dev-ruby/mime-types-3:*
	>=dev-ruby/net-ssh-5.1.0:*
	>=dev-ruby/net-sftp-2.1
	>=dev-ruby/net-scp-1.2.0
	<dev-ruby/rest-client-2.1.0:*
	=dev-ruby/rubyzip-1.2.2:*
	>=dev-ruby/vagrant_cloud-2.0.3
    >=dev-ruby/ruby_dep-1.5.0    
"

# upstream specifies rake>=12 but it apparently doesn't need something this
# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
# is tricky, we specify a lower dependency requirement here. This way, we'll be
# able to stabilize vagrant sooner.
ruby_add_bdepend "
	>=dev-ruby/rake-10.5.0
"

all_ruby_prepare() {
	# remove bundler support
	sed -i '/[Bb]undler/d' Rakefile || die
	rm Gemfile || die

	# loosen dependencies
	sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
		-e '/ruby_dep/s/<=/>=/' \
		-i ${PN}.gemspec || die

	# remove windows-specific gems
	sed -e '/wdm\|winrm/d' \
		-i ${PN}.gemspec || die

	# remove bsd-specific gems
	sed -e '/rb-kqueue/d' \
		-i ${PN}.gemspec || die

	sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
}

all_ruby_install() {
	all_fakegem_install

	newbashcomp contrib/bash/completion.sh ${PN}

	# provide executable similar to upstream:
	# https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
	dobin "${PN}"

	# directory for plugins.json
	keepdir /var/lib/vagrant

	insinto /usr/share/vim/vimfiles/syntax/
	doins contrib/vim/vagrantfile.vim
}

to get vargant running with proton build

one more thing...

https://github.com/dustymabe/vagrant-sshfs/issues/107

regards hedmo

Reproducible: Always

Steps to Reproduce:
1.emerge -av vagrant
2.git clone https://github.com/ValveSoftware/Proton.git
3.cd proton && make install
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2019-12-31 09:37:39 UTC
*** Bug 704374 has been marked as a duplicate of this bug. ***
Comment 2 andy 2019-12-31 10:02:50 UTC
please switch bug 704372 to 704374

app-emulation/vagrant-2.2.6 cannot depend on app-emulation/virtualbox-bin.

i had to ln -s /opt/VirtualBox /opt/virtualbox to make vagrant run with virtualbox and app-emulation/vagrant-2.2.6 only support 
=<app-emulation/virtualbox-6.0.14
Comment 3 Georgy Yakovlev gentoo-dev 2020-01-01 04:41:28 UTC
Hi!
It's very hard to understand exact problems you are trying to describe, but I'll try.

vagrant-sshfs: it's not a part of vagrant so I don't see how bug is related to our vagrant ebuild.
and no, nor vagrant nor virtualbox would never create this symlink.

sftp-server did not move, it always was in $API_LIBDIR. what you experiencing is likely an issue due to migration to 17.1 profile.
before that /usr/lib was a symlink to /usr/lib64
best approach would be patching the plugin to look at correct location.

https://github.com/dustymabe/vagrant-sshfs/blob/5cb3943c6806c42551f676c468136e1555b8e654/lib/vagrant-sshfs/synced_folder.rb#L113-L117

looks like it's modifying path. probably you could run this plugin with 

export PATH=$PATH:/usr/lib64/misc


as for vagrant not working with virtualbox-6.1 and later, thanks for letting me know, I will limit the version in the ebuild.


I can't reproduce your problem with vagrant-bin, works fine for me out of the box. make sure user you are running is in vboxusers group, without that you cannot execute binaries.
Comment 4 Larry the Git Cow gentoo-dev 2020-01-01 04:49:26 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2a65bfb72e82ecf9184130a6c627e11007663293

commit 2a65bfb72e82ecf9184130a6c627e11007663293
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2020-01-01 04:47:36 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-01-01 04:49:08 +0000

    app-emulation/vagrant: add virtualbox-6.1 support to 2.2.6
    
    Closes: https://bugs.gentoo.org/704372
    Package-Manager: Portage-2.3.79, Repoman-2.3.16
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 app-emulation/vagrant/files/support-vbox-6.1.patch | 75 ++++++++++++++++++++++
 ...agrant-2.2.6.ebuild => vagrant-2.2.6-r1.ebuild} |  4 +-
 2 files changed, 78 insertions(+), 1 deletion(-)
Comment 5 Georgy Yakovlev gentoo-dev 2020-01-01 04:50:08 UTC
ok vagrant 2.2.6 now supports latest virtualbox with no problem, no need to downgrade.
Comment 6 andy 2020-01-01 10:19:19 UTC
hi Georgy Yakovlev

i named this bug :app-emulation/vagrant-2.2.6.ebuild needs to update
because of:

hedmo@mya51 ~/proton $ vagrant up
Traceback (most recent call last):
        9: from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/bin/vagrant:88:in `<main>'
        8: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:35:in `require'
        7: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:161:in `rescue in require'
        6: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems.rb:208:in `try_activate'
        5: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems.rb:215:in `rescue in try_activate'
        4: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1373:in `activate'
        3: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1391:in `activate_dependencies'
        2: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1391:in `each'
        1: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1402:in `block in activate_dependencies'
/usr/lib64/ruby/site_ruby/2.5.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'rubyzip' (~> 1.2.2) - did find: [rubyzip-2.0.0,rubyzip-1.3.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/hedmo/.gem/ruby/2.5.0:/usr/lib64/ruby/gems/2.5.0:/usr/local/lib64/ruby/gems/2.5.0', execute `gem env` for more information
hedmo@mya51 ~/proton $ cat /etc/portage/package.mask/vagrant

>=dev-ruby/rubyzip-1.2.3
hedmo@mya51 ~/proton $ sudo emerge -av dev-ruby/rubyzip

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] dev-ruby/rubyzip-1.2.2:1::gentoo [1.3.0:1::gentoo] USE="-test" RUBY_TARGETS="ruby24 ruby25 -ruby26" 0 KiB

Total: 1 package (1 downgrade), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] 
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-ruby/rubyzip-1.2.2::gentoo
>>> Installing (1 of 1) dev-ruby/rubyzip-1.2.2::gentoo
>>> Recording dev-ruby/rubyzip in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 1.41, 0.68, 1.15
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
hedmo@mya51 ~/proton $ vagrant up
Traceback (most recent call last):
        10: from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/bin/vagrant:88:in `<main>'
         9: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:35:in `require'
         8: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:161:in `rescue in require'
         7: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems.rb:208:in `try_activate'
         6: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems.rb:215:in `rescue in try_activate'
         5: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1373:in `activate'
         4: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1391:in `activate_dependencies'
         3: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1391:in `each'
         2: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1405:in `block in activate_dependencies'
         1: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1371:in `activate'
/usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:2243:in `raise_if_conflicts': Unable to activate vagrant_cloud-2.0.3, because rest-client-2.1.0 conflicts with rest-client (~> 2.0.2) (Gem::ConflictError)
hedmo@mya51 ~/proton $ cat /etc/portage/package.mask/vagrant

>=dev-ruby/rubyzip-1.2.3
>=dev-ruby/rest-client-2.1.0 
hedmo@mya51 ~/proton $ sudo emerge -av dev-ruby/rest-client

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] dev-ruby/rest-client-2.0.2:2::gentoo [2.1.0:2::gentoo] USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 -ruby26" 0 KiB

Total: 1 package (1 downgrade), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] 
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-ruby/rest-client-2.0.2::gentoo
>>> Installing (1 of 1) dev-ruby/rest-client-2.0.2::gentoo
>>> Recording dev-ruby/rest-client in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 0.65, 0.68, 1.06
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
hedmo@mya51 ~/proton $ vagrant up
Traceback (most recent call last):
        9: from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/bin/vagrant:88:in `<main>'
        8: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:35:in `require'
        7: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:161:in `rescue in require'
        6: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems.rb:208:in `try_activate'
        5: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems.rb:215:in `rescue in try_activate'
        4: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1373:in `activate'
        3: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1391:in `activate_dependencies'
        2: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1391:in `each'
        1: from /usr/lib64/ruby/site_ruby/2.5.0/rubygems/specification.rb:1402:in `block in activate_dependencies'
/usr/lib64/ruby/site_ruby/2.5.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'ruby_dep' (>= 1.3.1) among 45 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/hedmo/.gem/ruby/2.5.0:/usr/lib64/ruby/gems/2.5.0:/usr/local/lib64/ruby/gems/2.5.0', execute `gem env` for more information
hedmo@mya51 ~/proton $ sudo emerge -av dev-ruby/ruby_dep   

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-ruby/ruby_dep-1.5.0:1::gentoo  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 -ruby26" 0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] 
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-ruby/ruby_dep-1.5.0::gentoo
>>> Installing (1 of 1) dev-ruby/ruby_dep-1.5.0::gentoo
>>> Recording dev-ruby/ruby_dep in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 0.28, 0.54, 0.94
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
hedmo@mya51 ~/proton $ vagrant up
NOTE: Gem::Specification.default_specifications_dir is deprecated; use Gem.default_specifications_dir instead. It will be removed on or after 2020-02-01.
Gem::Specification.default_specifications_dir called from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/lib/vagrant/bundler.rb:428.
NOTE: Gem::Specification.default_specifications_dir is deprecated; use Gem.default_specifications_dir instead. It will be removed on or after 2020-02-01.
Gem::Specification.default_specifications_dir called from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/lib/vagrant/bundler.rb:428.
Platform: 8 CPUs, 15961 MB memory
Bringing machine 'debian10' up with 'virtualbox' provider...
==> debian10: Checking if box 'generic/debian10' version '2.0.6' is up to date...
==> debian10: Clearing any previously set forwarded ports...
==> debian10: Clearing any previously set network interfaces...
==> debian10: Preparing network interfaces based on configuration...
    debian10: Adapter 1: nat
==> debian10: Forwarding ports...
    debian10: 22 (guest) => 2222 (host) (adapter 1)
==> debian10: Running 'pre-boot' VM customizations...
==> debian10: Booting VM...
==> debian10: Waiting for machine to boot. This may take a few minutes...
    debian10: SSH address: 127.0.0.1:2222
    debian10: SSH username: vagrant
    debian10: SSH auth method: private key
==> debian10: Machine booted and ready!
==> debian10: Checking for guest additions in VM...
    debian10: The guest additions on this VM do not match the installed version of
    debian10: VirtualBox! In most cases this is fine, but in rare cases it can
    debian10: prevent things such as shared folders from working properly. If you see
    debian10: shared folder errors, please make sure the guest additions within the
    debian10: virtual machine match the version of VirtualBox you have installed on
    debian10: your host and reload your VM.
    debian10: 
    debian10: Guest Additions Version: 5.1.38
    debian10: VirtualBox Version: 6.0
==> debian10: Rsyncing folder: /home/hedmo/proton/ => /home/vagrant/proton
==> debian10:   - Exclude: [".vagrant/", "vagrant_share"]
==> debian10: Mounting SSHFS shared folder...
==> debian10: Mounting folder via SSHFS: /home/hedmo/proton/vagrant_share => /vagrant
==> debian10: Checking Mount..
==> debian10: Folder Successfully Mounted!
==> debian10: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> debian10: flag to force provisioning. Provisioners marked to run always will still run.
hedmo@mya51 ~/proton $ 

and vagrant was looking for virtualbox and not VirtualBox.

regards hedmo
Comment 7 andy 2020-01-01 10:38:17 UTC
and about >=virtualbox-6.1

hedmo@mya51 ~/proton $ vagrant up
NOTE: Gem::Specification.default_specifications_dir is deprecated; use Gem.default_specifications_dir instead. It will be removed on or after 2020-02-01.
Gem::Specification.default_specifications_dir called from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/lib/vagrant/bundler.rb:428.
NOTE: Gem::Specification.default_specifications_dir is deprecated; use Gem.default_specifications_dir instead. It will be removed on or after 2020-02-01.
Gem::Specification.default_specifications_dir called from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/lib/vagrant/bundler.rb:428.
Platform: 8 CPUs, 15961 MB memory
Bringing machine 'debian10' up with 'virtualbox' provider...
==> debian10: Checking if box 'generic/debian10' version '2.0.6' is up to date...
==> debian10: Clearing any previously set forwarded ports...
==> debian10: Fixed port collision for 22 => 2222. Now on port 2200.
==> debian10: Clearing any previously set network interfaces...
==> debian10: Preparing network interfaces based on configuration...
    debian10: Adapter 1: nat
==> debian10: Forwarding ports...
    debian10: 22 (guest) => 2200 (host) (adapter 1)
==> debian10: Running 'pre-boot' VM customizations...
==> debian10: Booting VM...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "760a8eee-272d-4d34-b6f8-afad615771ce", "--type", "headless"]

Stderr: VBoxManage: error: The virtual machine 'proton_debian10_1577867609744_8693' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

hedmo@mya51 ~/proton $ cat /etc/portage/package.mask/virtualbox
=app-emulation/virtualbox-bin-6.1.0.135406
=app-emulation/virtualbox-modules-6.1.0
hedmo@mya51 ~/proton $ sudo emerge -av virtualbox-bin   

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] app-emulation/virtualbox-modules-6.0.14::gentoo [6.1.0::gentoo] USE="-pax_kernel" 0 KiB
[ebuild     UD ] app-emulation/virtualbox-bin-6.0.14.133895::gentoo [6.1.0.135406::gentoo] USE="additions chm -headless -python -rdesktop-vrdp -sdk -vboxwebsrv" PYTHON_TARGETS="python2_7" 0 KiB

Total: 2 packages (2 downgrades), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] 
>>> Verifying ebuild manifests
>>> Emerging (1 of 2) app-emulation/virtualbox-modules-6.0.14::gentoo
>>> Installing (1 of 2) app-emulation/virtualbox-modules-6.0.14::gentoo
>>> Emerging (2 of 2) app-emulation/virtualbox-bin-6.0.14.133895::gentoo
>>> Installing (2 of 2) app-emulation/virtualbox-bin-6.0.14.133895::gentoo
>>> Jobs: 2 of 2 complete                           Load avg: 0.77, 0.46, 0.46

 * Messages for package app-emulation/virtualbox-bin-6.0.14.133895:

 * 
 * To launch VirtualBox just type: "VirtualBox"
 * 
 * You must be in the vboxusers group to use VirtualBox.
 * 
 * For advanced networking setups you should emerge:
 * net-misc/bridge-utils and sys-apps/usermode-utilities
 * 
 * Please visit http://www.virtualbox.org/wiki/Editions for
 * an overview about the different features of virtualbox-bin
 * and virtualbox-ose
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
hedmo@mya51 ~/proton $ vagrant up
NOTE: Gem::Specification.default_specifications_dir is deprecated; use Gem.default_specifications_dir instead. It will be removed on or after 2020-02-01.
Gem::Specification.default_specifications_dir called from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/lib/vagrant/bundler.rb:428.
NOTE: Gem::Specification.default_specifications_dir is deprecated; use Gem.default_specifications_dir instead. It will be removed on or after 2020-02-01.
Gem::Specification.default_specifications_dir called from /usr/lib64/ruby/gems/2.5.0/gems/vagrant-2.2.6/lib/vagrant/bundler.rb:428.
Platform: 8 CPUs, 15961 MB memory
Bringing machine 'debian10' up with 'virtualbox' provider...
==> debian10: Checking if box 'generic/debian10' version '2.0.6' is up to date...
==> debian10: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> debian10: flag to force provisioning. Provisioners marked to run always will still run.
hedmo@mya51 ~/proton $ 

regards hedmo