Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 703872 - dev-ruby/bundler-2.1.2 is blocked by dev-ruby/bundler-1.17.3-r1
Summary: dev-ruby/bundler-2.1.2 is blocked by dev-ruby/bundler-1.17.3-r1
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-26 18:45 UTC by Anton Gubarkov
Modified: 2020-09-22 01:06 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Gubarkov 2019-12-26 18:45:02 UTC
Today I faced a package block associated with the update of dev-ruby/bundler-2.1.2 package.

[ebuild  NS    ] dev-ruby/bundler-2.1.2:2::gentoo [1.17.3:0::gentoo] USE="doc -test" RUBY_TARGETS="ruby24 ruby25 ruby26 -ruby27%" 388 KiB
[blocks B      ] <dev-ruby/bundler-1.17.3-r1:0 ("<dev-ruby/bundler-1.17.3-r1:0" is hard blocking dev-ruby/bundler-2.1.2)

Conflict: 3 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-ruby/bundler-2.1.2:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/bundler-1.17.2[ruby_targets_ruby26] required by (dev-lang/ruby-2.6.5:2.6/2.6::gentoo, installed) USE="berkdb gdbm ipv6 rdoc ssl -debug -doc -examples -jemalloc -jit -libressl -rubytests -socks5 -static-libs -tk -xemacs" ABI_X86="(64)"
Comment 1 Anton Gubarkov 2019-12-26 18:45:44 UTC
PF16W6Y2 ~ # emerge --info bundler
Portage 2.3.83 (python 3.6.10-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-9.2.0, glibc-2.30-r3, 5.3.18-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.3.18-gentoo-x86_64-Intel-R-_Core-TM-_i7-8850H_CPU_@_2.60GHz-with-gentoo-2.6
KiB Mem:    32560548 total,  24249404 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Thu, 26 Dec 2019 18:05:43 +0000
Head commit of repository gentoo: 2c45582191011f47e172dedc990883ed49fd1357

sh bash 5.0_p11
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17::gentoo, 3.6.10::gentoo, 3.7.6::gentoo
dev-util/cmake:           3.16.2-r1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            8.3.0-r3::gentoo, 9.2.0-r3::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: git://github.com/gentoo-mirror/gentoo.git
    priority: -1000

dlang
    location: /var/lib/layman/dlang
    masters: gentoo
    priority: 50

gentoo-zh
    location: /var/lib/layman/gentoo-zh
    masters: gentoo
    priority: 50

go-overlay
    location: /var/lib/layman/go-overlay
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

tlp
    location: /var/lib/layman/tlp
    masters: gentoo
    priority: 50

rugubara
    location: /var/lib/layman/rugubara
    masters: gentoo
    priority: 100

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -mtune=native"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe -mtune=native"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -mtune=native"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://mirror.yandex.ru/gentoo-distfiles/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aio alsa amd64 berkdb bluetooth branding bzip2 cacert cairo cdda cdr cgroup-hybrid cli client colord crypt cups cxx dbus djvu dri dri3 dts dvd dvdr eds emboss encode evo exif fam fat ffmpeg flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm graphite gstreamer gtk iconv icu introspection ipv6 jack jpeg jpeg2k lcms ldap libglvnd libnotify libsamplerate libsecret libtirpc libzfs lm_sensors lv2 mad mng mp3 mp4 mpeg multilib native-headset nautilus ncat ncurses networkmanager nls nptl nvenc nvme ogg opengl openmp opus pam pango pcre pdf png policykit ppds pulseaudio qt5 raw readline sdl sdl2 seccomp smp sna sound spell spice split-usr ssl startup-notification svg systemd tcpd thunderbolt tiff tracker truetype udev udisks uefi unicode upower usb usbredir user-session vaapi vala vdpau virgl vorbis wayland webdav wireguard wxwidgets x264 x265 xattr xcb xml xv xvid zeroconf zfs zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput wacom" KERNEL="linux" L10N="en ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="intel iris nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-ruby/bundler-1.17.3::gentoo was built with the following:
USE="doc -test" ABI_X86="(64)" RUBY_TARGETS="ruby24 ruby25 ruby26"
FEATURES="userpriv news binpkg-dostrip strict unmerge-logs binpkg-logs unmerge-orphans binpkg-docompress protect-owned fixlafiles multilib-strict pid-sandbox ebuild-locks distlocks assume-digests parallel-fetch preserve-libs usersandbox ipc-sandbox merge-sync sandbox usersync config-protect-if-modified network-sandbox unknown-features-warn sfperms userfetch"
Comment 2 Dale Lukas Peterson 2019-12-27 00:30:16 UTC
I'm seeing the same issue.
Comment 3 Brandon Penglase 2019-12-27 01:27:29 UTC
I was getting the same thing. 
Got around it with:
emerge =dev-ruby/bundler-1.17.3-r1 -1
Comment 4 Hans de Graaff gentoo-dev 2019-12-27 06:14:43 UTC
(In reply to Brandon Penglase from comment #3)
> I was getting the same thing. 
> Got around it with:
> emerge =dev-ruby/bundler-1.17.3-r1 -1

This is the correct solution.

Both slots need to be updated to avoid the conflict (and the file collisions that is the reason the blocker is there).
Comment 5 Anton Gubarkov 2019-12-27 08:21:25 UTC
Is there a way to force rebuild of =dev-ruby/bundler-1.17.3-r1 automatically?
Comment 6 Hans de Graaff gentoo-dev 2020-01-13 18:47:34 UTC
(In reply to Anton Gubarkov from comment #5)
> Is there a way to force rebuild of =dev-ruby/bundler-1.17.3-r1 automatically?

Not that I am aware (given that I don't want to make bundler:1 a dependency of bundler:2).
Comment 7 Martin 2020-09-22 00:59:26 UTC
(In reply to Hans de Graaff from comment #6)
> (In reply to Anton Gubarkov from comment #5)
> > Is there a way to force rebuild of =dev-ruby/bundler-1.17.3-r1 automatically?
> 
> Not that I am aware (given that I don't want to make bundler:1 a dependency
> of bundler:2).

In that case:

That sounds like a "news" message is needed to avoid a gazillion bemused confused users searching through bugzilla...?
Comment 8 Martin 2020-09-22 01:06:57 UTC
(In reply to Brandon Penglase from comment #3)
> I was getting the same thing. 
> Got around it with:
> emerge =dev-ruby/bundler-1.17.3-r1 -1

Confirmed here that clears the "B" Block...


Thanks,
Martin