Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 702544 - dev-python/pythondialog-3.5.0 version bump
Summary: dev-python/pythondialog-3.5.0 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-11 15:23 UTC by Jason Chan
Modified: 2019-12-11 18:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Chan 2019-12-11 15:23:23 UTC
>As of version 2.12, the reference implementation of pythondialog (which this file belongs to) requires Python 3.0 or later in the 3.x series. pythondialog 3.5.0 has been tested with Python 3.8.

The current ebuild is limited to:

PYTHON_COMPAT=( python3_{5,6} pypy3 )

3.5.0 introduces 3.8 support and PYTHON_COMPAT can be changed to:

PYTHON_COMPAT=( python3_{5,6,7,8} pypy3 )

Resolves: using python programs that all have modules with >=3.7 support except for pythondialog.

Reproducible: Always

Steps to Reproduce:
1. Use ebuild to install protonvpn-cli
2. # protonvpn
Actual Results:  
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.7/protonvpn", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3251, in <module>
    @_call_aside
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pythondialog' distribution was not found and is required by protonvpn-cli

Expected Results:  
Usage:
    protonvpn init
    protonvpn (c | connect) [<servername>] [-p <protocol>]
    [...]

Choosing python 3.6 as my main python interpreter would have resolved this issue.