Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 702338 - net-libs/telepathy-glib-0.24.1-r1 fails to build with python 3.6
Summary: net-libs/telepathy-glib-0.24.1-r1 fails to build with python 3.6
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-09 12:58 UTC by Andrei Slavoiu
Modified: 2020-03-30 03:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (net-libs:telepathy-glib-0.24.1-r1:20191209-123051.log,21.19 KB, text/plain)
2019-12-09 13:19 UTC, Andrei Slavoiu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Slavoiu 2019-12-09 12:58:27 UTC
The upgrade to net-libs/telepathy-glib-0.24.1-r1 failed with some python errors (see the attached log). After changing PYTHON_COMPAT=( python2_7 ) in the ebuild it built fine.

Reproducible: Always




Portage 2.3.79 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-9.2.0, glibc-2.29-r2, 4.19.86-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.86-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700_CPU_@_3.40GHz-with-gentoo-2.6
KiB Mem:    49300840 total,  20800856 free
KiB Swap:   33554428 total,  33373804 free
Timestamp of repository gentoo: Mon, 09 Dec 2019 00:45:01 +0000
Head commit of repository gentoo: f172907070ac079cec6af6c061359981f5521a4e
sh bash 4.4_p23-r1
ld GNU gold (Gentoo 2.32 p2 2.32.0) 1.16
ccache version 3.7.4 [enabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/ccache:          3.7.4::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.2.0-r2::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x google-chrome OPERA-2014"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -ggdb -gz"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -ggdb -gz"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles installsources ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.xservers.ro/gentoo/ http://ftp.romnet.org/gentoo/ http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,now"
LINGUAS="ro en eo"
MAKEOPTS="-j8 -l10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="7zip X a52 aac aacplus aalib accessibility acl acpi activities ads aiglx aio akonadi alsa amd64 amr amrnb amrwb analitza apache2 asf aspell attica avahi avx bash-completion beautifier berkdb branding btrfs bzip2 cairo canberra caps cdda cdr chdir cli client clucene cmake consolekit corefonts cppcheck crash-reporter crypt css cups curl cxx dbus dcc_video declarative default-gold dell designer dga discover dlz dmi dnssec dot dpi dri dts dvd dvdr egl emboss encode evdev exif expat faac faad fam fbcondecor ffmpeg flac fontconfig fortran g3dvl gd gdbm gif git gles gles2 glew glib glibc-omitfp glitz glut gmp gnokii gnutls gold gpg gpm graphviz grub gsm gssapi haptic havekernel hex history hostonly htmlhandbook http2 iconv icu id3tag idn imagemagick imlib ipv6 irc jabber jadetex javascript jingle jpeg jpeg2k jumbo-build kde kdehiddenvisibility kdenlive kdepim kdrive kerberos kig-scripting kipi kwallet lapack lcms ldap libcaca libkms libssh2 libtirpc lm-sensors lm_sensors lto lzma lzo mad marble mdnsresponder-compat melt mjpeg mmx mng mp3 mp4 mpeg mplayer multilib ncurses netapi nettle network nls nowlistening nptl ntlm_unsupported_patch nvme ogg okteta openal opencl opencore-amr openexr opengl openmax openmp openssl openvg opus otr pam pango pch pcntl pcre pcre16 pcsc-lite pdf perforce perfprofiler pgo phonon pim plasma plotutils plymouth png policykit povray ppds prison pulseaudio qemu qemu-ifup qml qt5 qthelp qtmedia rar rdesktop rdp readline reports rtmp samba sasl schroedinger scripttools sdk sdl sdl2 seccomp semantic-desktop shared-dricore slang snmp speech speex spell spice split-usr sql sqlite sqlite3 sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification statistics svc svg symlink system-bootstrap system-libvncserver tcpd telepathy theora threads tidy tiff tracepath truetype udev udisks uefi unicode upcall upnp upower usb vaapi valgrind vdpau video visualization vnc vorbis vpx vulkan wayland webengine webkit webp webready widevine widgets winbind windeco wmf x264 xattr xcb xcomposite xml xmp xv xvid yahoo zeroconf zip zlib" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="ro en eo" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="AMDGPU" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="aarch64 x86_64" QEMU_USER_TARGETS="aarch64 x86_64" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="intel i965 r600 modesetting" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-libs/telepathy-glib-0.24.1-r1::gentoo was built with the following:
USE="introspection -debug -test -vala" ABI_X86="(64)"
FEATURES="distlocks ipc-sandbox preserve-libs protect-owned strict usersandbox unmerge-orphans splitdebug usersync ccache multilib-strict unknown-features-warn ebuild-locks sfperms unmerge-logs sandbox merge-sync news config-protect-if-modified binpkg-dostrip assume-digests pid-sandbox buildpkg xattr network-sandbox binpkg-logs userfetch binpkg-docompress fixlafiles userpriv parallel-fetch installsources"
Comment 1 Andreas Sturmlechner gentoo-dev 2019-12-09 13:00:37 UTC
Where is the attached log?
Comment 2 Andrei Slavoiu 2019-12-09 13:19:14 UTC
Created attachment 598938 [details]
build.log
Comment 3 Andreas Sturmlechner gentoo-dev 2019-12-09 14:33:58 UTC
Hm, no problem here even with python3_8 - is it a locale problem similar to bug 568070?
Comment 4 Andrei Slavoiu 2019-12-09 18:45:40 UTC
I added LC_ALL=C to make.conf and nothing changed. Is there anything else regarding locale that I could check?
Comment 5 Martin Dummer 2019-12-11 16:41:21 UTC
I can confirm this error. 
It happened to me when installing a fresh stable-only new system.

I remembered the error messages and they reminded me to Bug #688330.
In August, when I opened Bug #688330, I downgraded app-text/asciidoc - but today there is only one stable version. 
So I tried the suggestion from Comment #6:

add an UTF-8 LC_CTYPE to /etc/portage/make.conf:

/etc/portage/make.conf:

...
LC_MESSAGES=C
LC_CTYPE=en_US.UTF-8
...


and look - it works (for me....)
Comment 6 Andrei Slavoiu 2019-12-13 11:52:59 UTC
Indeed, it looks like it needs an UTF-8 locale. Setting LC_ALL="en_US.UTF-8" made it build with python 3 as well.
Comment 7 Mauro Maroni 2019-12-28 17:45:58 UTC
Same happened to me, compiled correctly after adding LC_CTYPE=en_US.UTF-8 to make.conf
Comment 8 Fitap 2020-03-22 01:46:12 UTC
Here one more with this issue, I solved setting like comment #5, but in my case I have to enable en_US.UTF-8 in /etc/locale.gen because if not I get this error setlocale: unsupported locale setting
Don't forget run . /etc/profile and last thing what don't forget is setting with eselect locale list to point to en_US.UTF-8.
Comment 9 Bob Johnson 2020-03-30 03:41:23 UTC
I ran into the same problem, and didn't want to screw up my perfectly good global locale settings because one package is broken. What worked for me was to create /etc/portage/env/utf8clocale.conf with the line LC_ALL="en_US.UTF-8" and then added:

=net-libs/telepathy-glib-0.24.1-r1      utf8clocale.conf

to /etc/portage/package.env. Using LC_CTYPE in the .conf file didn't work for me; only LC_ALL did the trick.