Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701898 - sci-electronics/geda-1.10.0 version bump
Summary: sci-electronics/geda-1.10.0 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks:
 
Reported: 2019-12-03 16:34 UTC by Stephen Cavilia
Modified: 2019-12-03 16:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for geda 1.10.0 (geda-1.10.0.ebuild,2.20 KB, text/plain)
2019-12-03 16:36 UTC, Stephen Cavilia
Details
Patch for compile errors (geda-1.10.0-maybe-uninitialized.patch,1.38 KB, patch)
2019-12-03 16:36 UTC, Stephen Cavilia
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Cavilia 2019-12-03 16:34:47 UTC
gEDA version 1.10.0 has been released.

Changes include dependency on Python 2.7 and optional libgamin. Additionally there are some compile failures with -Werror=maybe-uninitialized (at least on gcc 9.2.0, this looks a little like a compiler-version-specific issue) that I patched just to suppress the errors (they are things where the uninitialized paths are effectively ruled out by assertions).

There is some upstream support for guile 2.2 now but it seems to be incomplete. I am still using 2.0 for the time being.

Release notes say 'make check' is parallelizable now so I removed the explicit -j1. Other than that no big ebuild changes.

Reproducible: Always
Comment 1 Stephen Cavilia 2019-12-03 16:36:05 UTC
Created attachment 598328 [details]
ebuild for geda 1.10.0
Comment 2 Stephen Cavilia 2019-12-03 16:36:50 UTC
Created attachment 598330 [details, diff]
Patch for compile errors