Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701798 - dev-util/pkgconf remote repository ssl certificate expired.
Summary: dev-util/pkgconf remote repository ssl certificate expired.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Gilbert
URL: https://git.dereferenced.org/pkgconf/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-02 19:23 UTC by Jason Howe
Modified: 2019-12-02 21:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Howe 2019-12-02 19:23:06 UTC
dev-util/pkgconf-9999 building fails because of an ssl certificate error when attempting to pull the source.

...
 * Fetching https://git.dereferenced.org/pkgconf/pkgconf.git ...
git fetch https://git.dereferenced.org/pkgconf/pkgconf.git +HEAD:refs/git-r3/HEAD
fatal: unable to access 'https://git.dereferenced.org/pkgconf/pkgconf.git/': SSL certificate problem: certificate has expired
 * ERROR: dev-util/pkgconf-9999::gentoo failed (unpack phase):
 *   Unable to fetch from any of EGIT_REPO_URI
...

Reproducible: Always

Steps to Reproduce:
1.emerge dev-util/pkgconf

Actual Results:  
Build fails

Expected Results:  
Build Succeeds
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2019-12-02 19:33:15 UTC
Nothing we can do to fix it.  Complain to pkgconf owners.

In the mean time, use a non 9999 version.
Comment 2 Larry the Git Cow gentoo-dev 2019-12-02 21:17:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ff482ee0960c357158ad3aa68a4fef86ad14f05d

commit ff482ee0960c357158ad3aa68a4fef86ad14f05d
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2019-12-02 21:15:59 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2019-12-02 21:16:59 +0000

    dev-util/pkgconf: update git repo and homepage (again)
    
    Closes: https://bugs.gentoo.org/701798
    Package-Manager: Portage-2.3.79_p3, Repoman-2.3.18_p2
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 dev-util/pkgconf/pkgconf-1.6.3.ebuild | 5 ++---
 dev-util/pkgconf/pkgconf-9999.ebuild  | 5 ++---
 2 files changed, 4 insertions(+), 6 deletions(-)