Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701602 - =dev-python/fonttools-4.0.1 dependency issue with several Python2.7-dependent packages (dev-python/booleanOperations, dev-python/defcon, dev-python/nototools, dev-python/ufoLib)
Summary: =dev-python/fonttools-4.0.1 dependency issue with several Python2.7-dependent...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Fonts Team
URL: https://forums.gentoo.org/viewtopic-p...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-30 17:06 UTC by Red
Modified: 2020-03-27 10:23 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Red 2019-11-30 17:06:05 UTC
Hi,

=dev-python/fonttools-4.0.1 lacks support for Python 2.7. When it was stabilized (bug 699756) it causes a dependency conflict with several packages, including:

* dev-python/booleanOperations
* dev-python/defcon
* dev-python/nototools
* dev-python/ufoLib

These packages should be revised to depend on <=dev-python/fonttools-3.44.0

More info can be seen at this forum thread:

https://forums.gentoo.org/viewtopic-p-8393630.html

Reproducible: Always
Comment 1 Andreas Sturmlechner gentoo-dev 2019-11-30 17:28:13 UTC
This rather sounds like you have misconfigured your PYTHON_TARGETS.
Comment 2 Gregory Beauregard 2019-12-01 02:01:49 UTC
(In reply to Andreas Sturmlechner from comment #1)
> This rather sounds like you have misconfigured your PYTHON_TARGETS.

I ran into the same issue after it stabilized
Comment 3 Ionen Wolkens 2019-12-01 04:22:17 UTC
I ran into the issue long ago in unstable myself, I should probably have considered filling a report back then but my solution was just to mask the newer fonttools until packages which depends on >=dev-python/fonttools-3.36.0 despite supporting _only_ python2.7 stop trying to get the >=4 version that doesn't support it (see nototools/noto-emoji and likely others).

I guess it's more specifically be a bug with those packages rather than fonttools.
Comment 4 Andreas Sturmlechner gentoo-dev 2019-12-01 09:47:44 UTC
If what you are talking about is the paste seen in the forum thread, that is not  a bug.
Comment 5 Gregory Beauregard 2019-12-01 11:30:29 UTC
(In reply to Andreas Sturmlechner from comment #4)
> If what you are talking about is the paste seen in the forum thread, that is
> not  a bug.

Yeah, basically Gentoo ends up in a state where world updates report the listed dependency conflict if you install noto-emoji on stable. If it's not a bug then this should be able to be closed.
Comment 6 Guido Kroon 2019-12-01 13:24:08 UTC
Got the same issue. Should be easily fixed in the package ebuilds, right?
Comment 7 Ionen Wolkens 2019-12-01 14:10:20 UTC
I think the actual "bug" is that the whole dependency conflict messages is going to make people come here. Is there no more elegant way to handle this without having users either manually mask it (like I did, so I personally don't mind) or keep seeing this conflict message likely for months every time they try to update?
Comment 8 Andreas Sturmlechner gentoo-dev 2019-12-01 15:19:14 UTC
(In reply to Guido Kroon from comment #6)
> Got the same issue. Should be easily fixed in the package ebuilds, right?

No, you can't magically invent python3 support in the code.
Comment 9 Joe Breuer 2019-12-23 22:18:04 UTC
... shouldn't fonttols-4 be slotted then vs fonttools-3?
Comment 10 Michael Cook 2020-01-15 19:00:27 UTC
I'm now having several pages of conflicts due to dev-python/setuptools.


I do see there was a commit (nototools) that states "More updates to make Python 3 compatible" that isn't in the latest package, no idea if that means it's working yet or not (maybe working enough? no idea) But they haven't had a new release with that commit yet :/
Comment 11 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-03-27 10:23:20 UTC
Version removed.  If you can repro with the current, feel free to reopen.