Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701372 - app-emulation/lxc-4.0: version bump
Summary: app-emulation/lxc-4.0: version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Virtualization Team
URL:
Whiteboard:
Keywords: PullRequest
: 715972 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-28 06:28 UTC by Michael 'veremitz' Everitt
Modified: 2020-05-15 05:20 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 'veremitz' Everitt 2019-11-28 06:28:07 UTC
v3.2.1 of LXC was released on 22nd July 2019.

v3.0.3 in-tree does not build with musl-libc, but 3.2.1 as used in Void Linux does (build.log to follow).

I can PR an ebuild if it helps.
Comment 1 Jonas Stein gentoo-dev 2020-04-03 17:51:42 UTC
*** Bug 715972 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2020-05-15 05:20:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=38e26cd54c82a7635a012ab34d1206d7f01136e2

commit 38e26cd54c82a7635a012ab34d1206d7f01136e2
Author:     Joonas Niilola <juippis@gentoo.org>
AuthorDate: 2020-05-14 15:47:15 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2020-05-15 05:20:29 +0000

    app-emulation/lxc: bump to 4.0.1
    
    - basically a copypaste of old ebuild,
    - remove grsec kernel checks.
    
    Closes: https://bugs.gentoo.org/701372
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 app-emulation/lxc/Manifest         |   1 +
 app-emulation/lxc/lxc-4.0.1.ebuild | 132 +++++++++++++++++++++++++++++++++++++
 2 files changed, 133 insertions(+)