Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701192 - net-fs/nfs-utils-2.4.1-r3 stack smashing error
Summary: net-fs/nfs-utils-2.4.1-r3 stack smashing error
Status: RESOLVED DUPLICATE of bug 688644
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-26 10:01 UTC by Gerhard Hintermayer
Modified: 2019-11-26 12:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Hintermayer 2019-11-26 10:01:46 UTC
before going to nfs-utils-2.4.1-r4 I ran into the follwing problem:
rpc.mountd always crashed after a few seconds with the following error message ( I have about 20 clients) :

rpc.mountd: nfsd_fh: inbuf '10.5.16.0/22 6 \x8f424d6d527342799abc1d30bed385cd'
*** stack smashing detected ***: <unknown> terminated

If I turned off all access in /etc/exports and rexported, I could start rpc.mountd without any issues, but of course without any access to the exported directories.

Today I checked by chance for a newer version, found 2.4.1-r4, gave it a try and - voila -no more stack smashing aborts any more.

I just filed the bug to possible help others that ran into the same error using the buggy version 2.4.1-r3.
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-11-26 10:58:16 UTC
Affected version is gone. This was fixed by https://bugs.gentoo.org/688644#c25. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 688644 ***
Comment 2 Gerhard Hintermayer 2019-11-26 12:15:50 UTC
Sorry for reporting as duplicate, now at the error is at least reported with *both* client and server error message ;-) - as all my clients dropped off I did'nt even think to check there as the problem was located @ server