Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 699396 - games-engines/scummvm-2.1.0 - src_configure(): Checking for SDL... no
Summary: games-engines/scummvm-2.1.0 - src_configure(): Checking for SDL... no
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-05 19:07 UTC by Dennis Schridde
Modified: 2020-09-23 15:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,3.11 KB, text/plain)
2019-11-05 19:07 UTC, Dennis Schridde
Details
config.log (config.log,3.82 KB, text/plain)
2019-11-12 01:36 UTC, Dennis Schridde
Details
scummvm-2.0.0-fix-sdlpath.patch (scummvm-2.0.0-fix-sdlpath.patch,442 bytes, patch)
2019-11-12 02:01 UTC, Dennis Schridde
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2019-11-05 19:07:53 UTC
Created attachment 595096 [details]
build.log

>>> Configuring source in /tmp/portage/games-engines/scummvm-2.1.0/work/scummvm-2.1.0 ...         
configure --backend=sdl --host=x86_64-pc-linux-gnu --enable-verbose-build --prefix=/usr --libdir=/usr/lib64 --opengl-mode=auto --enable-a52 --enable-faad --enable-alsa --disable-debug --enable-release-mode --enable-flac --enable-jpeg --disable-lua --enable-mad --enable-mpe
g2 --disable-sdlnet --enable-png --enable-tts --enable-theoradec --enable-freetype2 --enable-vorbis --enable-zlib --disable-nasm
Running ScummVM configure...                                                                                                            
Looking for C++ compiler... x86_64-pc-linux-gnu-g++                                                                                     
Checking for compiler version... 9.2.0, ok                         
Building as C++11... no                                                                                                                 
Checking for whether C++ compiler accepts -Wglobal-constructors... no
Checking for whether C++ compiler accepts -Wno-undefined-var-template... no
Checking for whether C++ compiler accepts -Wno-pragma-pack... no
Checking endianness... little                                      
Checking 64-bitness... yes                                                                                                              
Type with 1 byte... char                                                                                                                
Type with 2 bytes... short                                          
Type with 4 bytes... int                        
Type with 8 bytes... long                                                                                                               
Alignment required... no                                     
Checking host CPU architecture... x86_64
Checking hosttype... linux-gnu                        
Cross-compiling to x86_64-pc-linux-gnu                        
WARNING: Unknown target, continuing with auto-detected values   
Looking for sdl-config... /usr/sbin/sdl2-config                    
Checking for SDL... no                                           
 * ERROR: games-engines/scummvm-2.1.0::gentoo failed (configure phase):                                                                 
 *   (no error message)                                                                                                                 
 *                                                                                                                                      
 * Call stack:                                               
 *     ebuild.sh, line 125:  Called src_configure            
 *   environment, line 1950:  Called die                          
 * The specific snippet of code:                                                                                                        
 *       SDL_CONFIG="sdl2-config" ./configure "${myconf[@]}" "${EXTRA_ECONF}" || die
Comment 1 Dennis Schridde 2019-11-05 19:09:31 UTC
Portage 2.3.78 (python 2.7.13-final-42, default/linux/amd64/17.1/desktop/plasma/systemd, gcc-9.2.0, glibc-2.29-r6, 5.3.8-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.3.8-gentoo-x86_64-AMD_Ryzen_5_2400G_with_Radeon_Vega_Graphics-with-gentoo-2.6
KiB Mem:    14135880 total,   5103264 free
KiB Swap:   16776188 total,  16757756 free
Timestamp of repository gentoo: Tue, 05 Nov 2019 17:15:01 +0000
Head commit of repository gentoo: e78b74c41d8fdb9ebb95acba7dd220a85e6b1217
Head commit of repository flatpak-overlay: dba2292fa92fbe7f51a437ff89d27cbab6105b67

Head commit of repository local: bd0d7b2f5ff4338e2ed8f4e0d3d69277862cd102

sh bash 5.0_p11
ld GNU gold (Gentoo 2.32 p2 2.32.0) 1.16
ccache version 3.7.5 [disabled]
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.5.7::gentoo, 3.6.9::gentoo, 3.7.5-r1::gentoo
dev-util/ccache:          3.7.5::gentoo
dev-util/cmake:           3.16.0_rc3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.1.0::gentoo, 9.2.0-r1::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r6::gentoo
Repositories:

gentoo
    location: /var/cache/portage/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

flatpak-overlay
    location: /var/db/repos/flatpak-overlay
    sync-type: git
    sync-uri: https://github.com/fosero/flatpak-overlay.git
    masters: gentoo

local
    location: /var/cache/portage/local
    sync-type: git
    sync-uri: https://github.com/devurandom/gentoo-overlay.git
    masters: gentoo
    priority: 1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=znver1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/grs/systems.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.6/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=znver1"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --nospinner --verbose-conflicts"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildsyspkg cgroup compressdebug config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles ipc-sandbox merge-sync mount-sandbox multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j6 -l4"
PKGDIR="/var/cache/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="7z 7zip X a52 aac aacplus aacs acl acpi activities aio alsa amd64 appindicator appstream archive audit avahi ayatana bash-completion bdplus berkdb blake2 bluetooth bluray branding brotli bs2b btrfs bzip2 cairo caps cdda cddb cdio cdr celt chromaprint cjk clang cli clipboard color-management colord conntrack crypt cups cxx d3d9 dav1d dbus declarative device-mapper dirac djvu dri drm dts dvb dvd dvdr ed25519 editorconfig egl elf emboss encode epub exif fam faudio fax fbcon ffmpeg fftw filecaps firefox firewalld fish-completion fits flac fontconfig fontforge fortran fribidi gamepad gbm gdal gdbm geoclue geolocation gif git gmp gnupg google googledrive gpg gps graphicsmagick gstreamer gtk gtk3 gzip harfbuzz hdf5 heif http2 ibus iconv icu idn imlib inotify introspection ipv6 jemalloc jpeg jpeg2k json kde kipi kms kwallet ladspa latex lcms ldap libatomic libglvnd libidn2 libinput libnotify libproxy libsecret libsoxr libtirpc libvirt lm-sensors lrz lv2 lvm lz4 lzma lzo mad mariadb markdown mbim mercurial mjpeg mng mobi modemmanager modplug mp3 mp4 mpeg mplayer mpris mtp multilib mysql ncurses netlink networkmanager nls nptl office ofx ogg openal opencl opencv openexr opengl openh264 openmax openmp opus pam pango pcap pch pcre pcre2 pdf pgo phonon pixman plasma pm-utils png policykit postscript ppds prison pulseaudio python qml qrcode qt5 raw readline redfish samba sasl scanner schroedinger screencast sctp sdl sdl2 seccomp semantic-desktop share smartcard snappy sparse speech speex spell ssl startup-notification steamruntime stemmer svg systemd systemtap tbb tcpd teamd telepathy tga theora threads tiff timezone tmux truetype tslib udev udisks unicode unwind upnp upnp-av upower usb utempter v4l v4l2 vaapi vdpau vkd3d vorbis vpx vulkan wasm wavpack wayland webchannel webengine webkit webp widgets wmf wps x264 x265 xattr xcb xcomposite xinerama xkb xml xmp xrandr xscreensaver xv xvid xwayland xz yaml zeroconf zeromq zimg zlib zstd" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" ENLIGHTENMENT_MODULES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="joystick libinput" KERNEL="linux" L10N="de de-DE en en-GB ar fa tr ja ko zh zh-CN zh-TW" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-javascript wiki-publisher" LIRC_DEVICES="devinput" LLVM_TARGETS="AMDGPU BPF RISCV WebAssembly" LUA_TARGET="lua5-2" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 pypy pypy3" QEMU_SOFTMMU_TARGETS="riscv32 riscv64 x86_64" QEMU_USER_TARGETS="riscv32 riscv64" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu virgl" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-libs/libsdl2-2.0.10::gentoo was built with the following:
USE="X alsa dbus gles haptic joystick kms opengl pulseaudio sound threads tslib udev video vulkan wayland xinerama xscreensaver (-altivec) (-aqua) (-custom-cflags) -libsamplerate -nas -oss -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx sse sse2 -3dnow" VIDEO_CARDS="(-vc4)"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildsyspkg cgroup compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"


games-engines/scummvm-2.0.0-r1::gentoo was built with the following:
USE="aac alsa flac fluidsynth jpeg mp3 mpeg2 opengl png theora truetype vorbis zlib -debug -unsupported" ABI_X86="(64)"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildsyspkg cgroup compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
Comment 2 James Le Cuirot gentoo-dev 2019-11-05 20:48:33 UTC
Bleurgh, don't you just love custom configure scripts. I can't reproduce though. I do get "WARNING: Unknown target, continuing with auto-detected values" but I think that's harmless. This part is weird:

> Looking for sdl-config... /usr/sbin/sdl2-config

I don't get that, mine says /usr/bin/sdl2-config. Do you have merged bin+sbin by any chance? The script iterates through PATH but only echos if it finds a match. Something tells me this is a broken symlink or something like that.
Comment 3 Dennis Schridde 2019-11-06 06:28:39 UTC
(In reply to James Le Cuirot from comment #2)
> Bleurgh, don't you just love custom configure scripts. I can't reproduce
> though. I do get "WARNING: Unknown target, continuing with auto-detected
> values" but I think that's harmless. This part is weird:
> 
> > Looking for sdl-config... /usr/sbin/sdl2-config
> 
> I don't get that, mine says /usr/bin/sdl2-config. Do you have merged
> bin+sbin by any chance?

Yes, I have USE=-split-usr.  /bin, /sbin, /usr/bin and /usr/sbin are all the same directory.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2019-11-06 15:46:05 UTC
Please post the content of your $PATH variable from the user you emerge scummvm with (most likely portage)
Comment 5 Dennis Schridde 2019-11-06 17:06:30 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #4)
> Please post the content of your $PATH variable from the user you emerge
> scummvm with (most likely portage)

$ echo $PATH
/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin:/usr/lib/llvm/9/bin:/usr/lib/llvm/8/bin:/usr/lib/llvm/7/bin
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2019-11-06 23:51:40 UTC
Please try with all sbin entries being stripped off your PATH variable. This might be an issue caused by the following snippet:

https://github.com/scummvm/scummvm/blob/master/configure#L438
Comment 7 Dennis Schridde 2019-11-12 01:36:02 UTC
Created attachment 595832 [details]
config.log

(In reply to Lars Wendler (Polynomial-C) from comment #6)
> Please try with all sbin entries being stripped off your PATH variable. This
> might be an issue caused by the following snippet:
> 
> https://github.com/scummvm/scummvm/blob/master/configure#L438

It behaves oddly:

# cat /etc/env.d/50baselayout 
[...]
PATH="/usr/local/bin:/usr/bin:/opt/bin"
ROOTPATH="/usr/local/sbin:/usr/local/bin:/usr/bin:/opt/bin"
[..]

# env-update

# su -s /bin/bash - portage
$ echo $PATH
/usr/lib/llvm/9/bin:/usr/lib/llvm/8/bin:/usr/lib/llvm/7/bin:/usr/local/bin:/usr/bin:/opt/bin

# emerge -1a scummvm                   
[...]
Looking for sdl-config... /usr/sbin/sdl2-config
[...]
Comment 8 Dennis Schridde 2019-11-12 02:01:21 UTC
This patch fixes the issue for me: https://github.com/devurandom/gentoo-patches/blob/master/games-engines/scummvm-2.1.0/scummvm-2.0.0-fix-sdlpath.patch

It turned out that I had already created that patch for games-engines/scummvm-2.0.0, but forgot to submit it upstream or even create a Gentoo bug report.  I did so now: https://bugs.scummvm.org/ticket/11259
Comment 9 Dennis Schridde 2019-11-12 02:01:53 UTC
Created attachment 595836 [details, diff]
scummvm-2.0.0-fix-sdlpath.patch
Comment 10 Kai Krakow 2020-02-29 07:56:33 UTC
This patch doesn't fix it for me:

> Checking host CPU architecture... x86_64
> Checking hosttype... linux-gnu
> Cross-compiling to x86_64-pc-linux-gnu
> WARNING: Unknown target, continuing with auto-detected values
> Looking for sdl-config... /bin/sdl2-config
> Checking for SDL... no
>  * ERROR: games-engines/scummvm-2.1.0::gentoo failed (configure phase):
>  *   (no error message)

I'm having the following symlinks:

/bin -> /usr/bin
/sbin -> /usr/sbin
/lib* -> /usr/lib*

sbin and bin are not merged.

/bin/sdl2-config exists and is executable.

So it's probably a different bug and this patch does nothing for me?
Comment 11 Kai Krakow 2020-02-29 08:12:41 UTC
I think the problem is somewhere in the cc_check function.

When compiling the test snippet manually, it works:

> #include "SDL.h"
> int main(int argc, char *argv[]) { SDL_Init(0); return 0; }

# make CFLAGS="$(sdl2-config --cflags)" LDFLAGS="$(sdl2-config --libs)" testsdl
cc -I/usr/include/SDL2 -D_REENTRANT  -L/usr/lib64 -lSDL2  testsdl.c   -o testsdl

But it fails in configure:

x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -O2 -march=native -pipe -fomit-frame-pointer -g -O2 -march=native -pipe -fomit-frame-pointer -g -ansi -W -Wno-unused-parameter -Wno-empty-body -pedantic -Wno-long-long ./scummvm-conf.cpp -o ./scummvm-conf -L/usr/lib64 -lSDL2 -I//include/SDL2 -D_REENTRANT
./scummvm-conf.cpp:1:10: fatal error: SDL.h: No such file or directory
    1 | #include "SDL.h"
      |          ^~~~~~~
compilation terminated.
return code: 1

The problem is: It stripped "usr" from the include path, so it is not using what `sdl2-config --cflags` actually returns.
Comment 12 Kai Krakow 2020-02-29 08:54:19 UTC
(In reply to Kai Krakow from comment #11)
> The problem is: It stripped "usr" from the include path, so it is not using
> what `sdl2-config --cflags` actually returns.

It actually uses what sdl2-config returns but it totally ignores the prefix flags passed to configure. Instead, it finds sdl2-config in /bin and assumes the prefix is "/", passing that to sdl2-config:

# sdl2-config --prefix=/ --cflags --libs
-I//include/SDL2 -D_REENTRANT
-L/usr/lib64 -lSDL2

Maybe Gentoo should patch this part of configure? It should just look in `${PREFIX}/bin` for either sdl2-config or sdl-config.
Comment 13 Dmitry Derevyanko 2020-09-23 10:05:55 UTC
Small fix that works for me:

diff --git a/games-engines/scummvm/scummvm-2.1.2.ebuild b/games-engines/scummvm/scummvm-2.1.2.ebuild
index 5f7022f10551..7c993785456c 100644
--- a/games-engines/scummvm/scummvm-2.1.2.ebuild
+++ b/games-engines/scummvm/scummvm-2.1.2.ebuild
@@ -71,6 +71,7 @@ src_configure() {
                --host=${CHOST}
                --enable-verbose-build
                --prefix="${EPREFIX}/usr"
+               --with-sdl-prefix="${EPREFIX}/usr"
                --libdir="${EPREFIX}/usr/$(get_libdir)"
                --opengl-mode=$(usex opengl auto none)
                $(use_enable a52)
Comment 14 Larry the Git Cow gentoo-dev 2020-09-23 15:09:37 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e2b80866b0cb63563a0c0c4078e9eaa3d49ee10b

commit e2b80866b0cb63563a0c0c4078e9eaa3d49ee10b
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-09-23 14:26:20 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-09-23 15:09:30 +0000

    games-engines/scummvm: Bump to version 2.2.0
    
    - Added "gtk" USE flag (enabled by default) which provides the gtk file
      chooser for scummvm
    - Enabled "net" USE flag by default
    - Added "fribidi" USE flag
    - Fixed call to strings (bug #733388)
    - Fixed sdl2 detection with /usr merge (bug #699396)
    
    Closes: https://bugs.gentoo.org/699396
    Closes: https://bugs.gentoo.org/733390
    Closes: https://bugs.gentoo.org/733388
    Package-Manager: Portage-3.0.8, Repoman-3.0.1
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 games-engines/scummvm/Manifest             |   1 +
 games-engines/scummvm/metadata.xml         |   1 +
 games-engines/scummvm/scummvm-2.2.0.ebuild | 126 +++++++++++++++++++++++++++++
 3 files changed, 128 insertions(+)