Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 699090 - gnome-extra/gnome-contacts-3.32.1 - ../gnome-contacts-3.32.1/src/contacts-window.vala:38.11-38.19: error: `HeaderBar' is an ambiguous reference between `Gtk.HeaderBar' and `Hdy.HeaderBar'
Summary: gnome-extra/gnome-contacts-3.32.1 - ../gnome-contacts-3.32.1/src/contacts-win...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-01 14:07 UTC by tsteinb
Modified: 2019-11-17 19:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,30.18 KB, text/plain)
2019-11-01 14:09 UTC, tsteinb
Details
Patch (HeaderBar.patch,517 bytes, patch)
2019-11-05 13:59 UTC, tsteinb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tsteinb 2019-11-01 14:07:30 UTC
While updating my system I found that gnome-extra/gnome-contacts-3.32.1 fails to build.

Reproducible: Always

Steps to Reproduce:
1.Merge gnome-extras/gnome-contacts-3.32.1
Actual Results:  
The build step fails

Expected Results:  
gnome-extras/gnome-contacts-3.32.1 should have successfully installed

The build.log showed that this was due to an ambiguity with HeaderBar. I made a post on the forums, and someone pointed me to a commit made by upstream which resolves this.

Here is the link to the commit which fixes it: https://gitlab.gnome.org/GNOME/gnome-contacts/commit/c5eee38cd2556403a640a0a4c11d36cbf9a5a798
Comment 1 tsteinb 2019-11-01 14:09:25 UTC
Created attachment 594732 [details]
build.log

The relevant section is at line 82.
Comment 2 Jeroen Roovers gentoo-dev 2019-11-01 14:52:35 UTC
Please post your `emerge --info gnome-extra/gnome-contacts` output in a comment.
Comment 3 tsteinb 2019-11-01 14:55:05 UTC
Sorry about that, here you go:

Portage 2.3.69 (python 3.6.5-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-8.3.0, glibc-2.29-r2, 4.19.52-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.52-gentoo-x86_64-Intel-R-_Core-TM-_i7-8550U_CPU_@_1.80GHz-with-gentoo-2.6
KiB Mem:     8013660 total,    496956 free
KiB Swap:    8388604 total,   8376096 free
Timestamp of repository gentoo: Tue, 29 Oct 2019 16:46:02 +0000
Head commit of repository gentoo: ea5298128a7f6fb348827db5ae0b56eff332044a

Timestamp of repository brave-overlay: Sat, 26 Oct 2019 02:05:13 +0000
Head commit of repository brave-overlay: bdeb432233ae2397162ee34d458ee3f38d77dead

Timestamp of repository dlang: Sun, 27 Oct 2019 20:28:12 +0000
Head commit of repository dlang: ec7d2f2c090e7aa2757027360eb30d9a994651b5

Timestamp of repository libressl: Fri, 25 Oct 2019 08:45:13 +0000
Head commit of repository libressl: 1bf88261fe5c628f475d9d7c025cbe43f91ef514

Timestamp of repository matrix: Sun, 20 Oct 2019 11:25:12 +0000
Head commit of repository matrix: f76e012dfc39db34d484f5356585199934ae51bd

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
ccache version 3.7.2 [enabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/ccache:          3.7.2::gentoo
dev-util/cmake:           3.14.6::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    priority: -1000

brave-overlay
    location: /var/db/repos/brave-overlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/brave-overlay.git
    masters: gentoo

dlang
    location: /var/db/repos/dlang
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/dlang.git
    masters: gentoo

libressl
    location: /var/db/repos/libressl
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/libressl.git
    masters: gentoo

matrix
    location: /var/db/repos/matrix
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/matrix.git
    masters: gentoo

kronos
    location: /usr/local/portage/kronos
    masters: gentoo
    priority: 9999

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 4"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="https://gentoo.osuosl.org/ https://mirrors.evowise.com/gentoo/ https://gentoo.ussg.indiana.edu/ https://lug.mtu.edu/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2 --load-average=7.2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding btrfs bzip2 cairo cdda cdr clang cli colord crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam flac fortran gdbm gif glamor gles gles2 gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv icu introspection ipv6 jpeg lcms ldap ldc2-1_16 libnotify libressl libsecret libtirpc llvm mad mng mp3 mp4 mpeg multilib nautilus ncurses networkmanager nls nptl ntfs ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl seccomp spell split-usr ssl startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wayland wxwidgets x264 xattr xcb xfs xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" CURL_SSL="libressl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="arm x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 tsteinb 2019-11-05 13:59:10 UTC
Created attachment 595054 [details, diff]
Patch

I fixed the issue by using this patch.
Comment 5 Mart Raudsepp gentoo-dev 2019-11-17 19:09:26 UTC
This error happens because you have an unstable libhandy release installed from somewhere not from main tree, which has added a Hdy.HeaderBar that doesn't exist in the stable version as found in main tree.

That said, I'll fix this in a moment anyways, so we won't have trouble in main tree once libhandy is bumped (once they release another stable release, or we are forced to due to minimum requirements of other packages), and for situations such as yours.
Comment 6 Larry the Git Cow gentoo-dev 2019-11-17 19:15:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8970439d89d47dff5b6df87fd6173907797728d3

commit 8970439d89d47dff5b6df87fd6173907797728d3
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2019-11-17 19:14:23 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2019-11-17 19:15:23 +0000

    gnome-extra/gnome-contacts: fix build against libhandy-0.0.10+
    
    Closes: https://bugs.gentoo.org/699090
    Package-Manager: Portage-2.3.69, Repoman-2.3.12
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 .../files/3.32.1-libhandy-0.0.10-compat.patch      | 30 ++++++++++++++++++++++
 .../gnome-contacts/gnome-contacts-3.32.1.ebuild    |  4 +++
 2 files changed, 34 insertions(+)