Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698774 - dev-libs/libindicator-12.10.1-r301 - .../work/libindicator-12.10.1/libindicator/indicator-desktop-shortcuts.c:83:2: error: ‘g_type_class_add_private’ is deprecated [-Werror=deprecated-declarations]
Summary: dev-libs/libindicator-12.10.1-r301 - .../work/libindicator-12.10.1/libindicat...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks: werror
  Show dependency tree
 
Reported: 2019-10-28 18:09 UTC by M8R-u38wij
Modified: 2021-03-19 10:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,33.58 KB, text/plain)
2019-10-28 18:09 UTC, M8R-u38wij
Details
libindicator-12.10.1-r301.ebuild (libindicator-12.10.1-r301.ebuild,1.17 KB, text/plain)
2019-10-28 18:11 UTC, M8R-u38wij
Details
libindicator-no-error.patch (libindicator-no-error.patch,3.79 KB, patch)
2019-10-28 18:11 UTC, M8R-u38wij
Details | Diff
libindicator-no-error.patch (libindicator-no-error.patch,1.41 KB, patch)
2019-10-28 18:16 UTC, M8R-u38wij
Details | Diff
libindicator-12.10.1-r201.ebuild (libindicator-12.10.1-r201.ebuild,1.20 KB, text/plain)
2019-10-28 18:22 UTC, M8R-u38wij
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M8R-u38wij 2019-10-28 18:09:39 UTC
Created attachment 594238 [details]
build.log

Build fails because of a bunch of deprecated functions.

/var/tmp/portage/dev-libs/libindicator-12.10.1-r301/work/libindicator-12.10.1/libindicator/indicator-object.c:129:2: error: ‘g_type_class_add_private’ is deprecated [-Werror=deprecated-declarations]
  g_type_class_add_private (klass, sizeof (IndicatorObjectPrivate));
  ^~~~~~~~~~~~~~~~~~~~~~~~
...
cc1: all warnings being treated as errors

Apparently `append-flags -Wno-error` in ebuild is not enough to override `-Werror` in the sources.
Comment 1 M8R-u38wij 2019-10-28 18:11:05 UTC
Created attachment 594240 [details]
libindicator-12.10.1-r301.ebuild
Comment 2 M8R-u38wij 2019-10-28 18:11:42 UTC
Created attachment 594242 [details, diff]
libindicator-no-error.patch
Comment 3 M8R-u38wij 2019-10-28 18:16:52 UTC
Created attachment 594244 [details, diff]
libindicator-no-error.patch

Removed redundant parts of the patch
Comment 4 M8R-u38wij 2019-10-28 18:22:04 UTC
Created attachment 594248 [details]
libindicator-12.10.1-r201.ebuild

r201 is also affected
Comment 5 Jonas Stein gentoo-dev 2019-10-28 19:39:20 UTC
Thank you for the patch.
Could you please also add the emerge info, in case the developer who looks at it cannot reproduce it? Thanks.

Why does it fail now? Does it fail since a specific gcc version?

https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
We need to have all information at hand before ticket assignment, so that the maintainer can look after it in one session with minimal number of callbacks.

I think it should be fixed upstream (too).
https://launchpad.net/libindicator

Or is it fixed upstream already?
Comment 6 M8R-u38wij 2019-10-29 11:03:44 UTC
$ emerge --info
Portage 2.3.76 (python 2.7.16-final-0, default/linux/amd64/17.1/desktop/gnome, gcc-8.3.0, glibc-2.29-r2, 4.14.65-gentoo x86_64)
=================================================================
System uname: Linux-4.14.65-gentoo-x86_64-Intel-R-_Core-TM-_i5-2410M_CPU_@_2.30GHz-with-gentoo-2.6
KiB Mem:     8023188 total,   2946140 free
KiB Swap:   16776188 total,  16776188 free
Timestamp of repository gentoo: Mon, 28 Oct 2019 12:45:01 +0000
Head commit of repository gentoo: 504b4bea7d6dc5499f21b21b8e3d7ae25fdd0245
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
ccache version 3.7.2 [enabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/ccache:          3.7.2::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://mirror.yandex.ru/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

myoverlay
    location: /home/user/Dropbox/overlay
    masters: gentoo
    priority: 0

dotnet
    location: /var/lib/layman/dotnet
    masters: gentoo
    priority: 50

rust
    location: /var/lib/layman/rust
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

tlp
    location: /var/lib/layman/tlp
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -mno-avx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -mno-avx"
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS="--ask-enter-invalid"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j5"
PKGDIR="/var/cache/packfiles"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/media/SHARE/portemp"
USE="X a52 aac acl acpi alsa amd64 bash-completion bluetooth branding bzip2 cairo caja cdda cdr cli colord crypt cups cxx dbus djvu dri dts dvd dvdr eds elogind emboss encode evo exif fam ffmpeg flac fortran fuse gdbm gif glamor gnome-keyring gnome-online-accounts gphoto2 gpm gstreamer gtk iconv icu idn introspection ipv6 jack jpeg lcms libnotify libsecret libtirpc lzma mad mate mmx mng mp3 mp4 mpeg multilib ncurses networkmanager nls nptl nsplugin ogg opengl openmp pam pango pch pcre pdf perl png policykit ppds pth python qt3support qt4 qt5 readline sdl seccomp split-usr sqlite sqlite3 sse sse2 ssl ssse3 startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vala vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="avx mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard evdev synaptics" KERNEL="linux" L10N="ru en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby24 ruby25" SANE_BACKENDS="pixma net" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 M8R-u38wij 2019-10-29 11:07:42 UTC
> Why does it fail now? Does it fail since a specific gcc version?
I guess the deprecated functions were not deprecated before.


> I think it should be fixed upstream (too).
> https://launchpad.net/libindicator
> Or is it fixed upstream already?
Well, since they have -Werror in their makefiles, it's probably a feature and not a bug.
Comment 8 Sam James archtester gentoo-dev Security 2021-03-19 10:28:02 UTC
(In reply to M8R-u38wij from comment #7)
> > Why does it fail now? Does it fail since a specific gcc version?
> I guess the deprecated functions were not deprecated before.
> 
> 
> > I think it should be fixed upstream (too).
> > https://launchpad.net/libindicator
> > Or is it fixed upstream already?
> Well, since they have -Werror in their makefiles, it's probably a feature
> and not a bug.

Well, there's a bug in that it's using deprecated features, but also -Werror should be used for development, not for users.
Comment 9 Larry the Git Cow gentoo-dev 2021-03-19 10:45:23 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=67f4ce710c7124d390bc3051e2e7ffeb7637d92a

commit 67f4ce710c7124d390bc3051e2e7ffeb7637d92a
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-03-19 10:35:08 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-03-19 10:35:08 +0000

    dev-libs/libindicator: stop using -Werror
    
    Closes: https://bugs.gentoo.org/698774
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/libindicator-12.10.1-no-werror.patch     | 196 +++++++++++++++++++++
 .../libindicator/libindicator-12.10.1-r201.ebuild  |   1 +
 .../libindicator/libindicator-12.10.1-r301.ebuild  |   1 +
 3 files changed, 198 insertions(+)