Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698240 - sys-libs/timezone-data-2019c - !!! Couldn't download 'tzdata2019c.tar.gz'. Aborting.
Summary: sys-libs/timezone-data-2019c - !!! Couldn't download 'tzdata2019c.tar.gz'. Ab...
Status: RESOLVED DUPLICATE of bug 698046
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-22 08:28 UTC by Henrik
Modified: 2019-10-22 17:38 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Log of ebuild fetch (tzlog.txt,1.39 KB, text/plain)
2019-10-22 13:41 UTC, Mark Fenner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik 2019-10-22 08:28:41 UTC
Emerge output:
>>> Downloading 'http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/distfiles/tzdata2019c.tar.gz'
/usr/portage/distfiles/tzdata2019c.tar.gz.__download__: No such file or directory
>>> Downloading 'https://www.iana.org/time-zones/repository/releases/tzdata2019c.tar.gz'
/usr/portage/distfiles/tzdata2019c.tar.gz.__download__: No such file or directory
!!! Couldn't download 'tzdata2019c.tar.gz'. Aborting.
 * Fetch failed for 'sys-libs/timezone-data-2019c', Log file:
 *  '/var/tmp/portage/sys-libs/timezone-data-2019c/temp/build.log'

>>> Failed to emerge sys-libs/timezone-data-2019c

Thank you
Comment 1 Henrik 2019-10-22 08:44:57 UTC
Guess the hostname should be data. instead of www.
https://data.iana.org/time-zones/releases/tzdata2019c.tar.gz
Comment 2 Sergei Trofimovich gentoo-dev 2019-10-22 10:52:25 UTC
Is it still reproducible for you? The files download just fine by URLs you specified in original post. Make sure it's not an internet connection problem.
Comment 3 Henrik 2019-10-22 11:40:47 UTC
Yes, I can still replicate.
I have tried without mirror as well.
emaint rsync works and other packages emerges without problems.

I can confirm that the links work in my browser.
I can see that the www.iana link is redirected to data.iana, do not know if that makes any difference for emerge?
Comment 4 Sergei Trofimovich gentoo-dev 2019-10-22 12:36:59 UTC
It should not make a difference. By default emerge uses wget which knows how to follow complicant HTTP redirect. Can you attach a full fetch log to see where fetch fails?
Comment 5 Mark Fenner 2019-10-22 13:41:48 UTC
Created attachment 593618 [details]
Log of ebuild fetch
Comment 6 Mark Fenner 2019-10-22 13:44:56 UTC
Similar issue here.  Using either of the failing URLs (for tzcode) directly with a wget and then moving the file to /usr/portage/distfiles allows the ebuild to succeed.
Comment 7 Maciej S. Szmigiero 2019-10-22 14:14:21 UTC
I have hit a similar issue on one of my machines few days ago.

I remember that portage actually wouldn't let the file to be downloaded
until I have manually deleted a temporary file in /usr/portage/distfiles/
(I guess it was 
/usr/portage/distfiles/tzdata2019c.tar.gz.__download__, but I don't
remember exactly).
After removing that file it would (re)fetch it correctly.
Comment 8 Sergei Trofimovich gentoo-dev 2019-10-22 14:44:19 UTC
dev-portage@, does it sound like a known/new cleanup problem?
Comment 9 Zac Medico gentoo-dev 2019-10-22 17:38:28 UTC
Looks like you have a dangling symlink located at /usr/portage/distfiles/tzdata2019c.tar.gz.__download__ that you need to remove. Also, check your FETCHCOMMAND. We've updated FETCHCOMMAND_RSYNC for bug 698046.

*** This bug has been marked as a duplicate of bug 698046 ***