Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 698090 - media-libs/musicbrainz-5.1.0 - ninja: error: '.../work/libmusicbrainz-5.1.0/src/*.inc', needed by 'include/musicbrainz5/mb5_c.h', missing and no known rule to make it
Summary: media-libs/musicbrainz-5.1.0 - ninja: error: '.../work/libmusicbrainz-5.1.0/s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: PullRequest
: 714744 714808 715762 727162 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-20 07:59 UTC by Jan Henke
Modified: 2020-06-04 20:07 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,4.50 KB, text/plain)
2019-10-20 08:02 UTC, Jan Henke
Details
build environment (environment,109.16 KB, text/plain)
2019-10-20 08:03 UTC, Jan Henke
Details
no_wildcards.patch (no_wildcards.patch,854 bytes, patch)
2020-03-25 02:02 UTC, cyrillic
Details | Diff
Fixes wildcard issues with cmake (libmusicbrains-5.1.0_wildcard_patch.txt,1.21 KB, patch)
2020-05-14 17:36 UTC, Jesus Rivero
Details | Diff
media-libs/musicbrainz-5.1.0-r1 (musicbrainz-5.1.0-r1.ebuild,1.10 KB, text/plain)
2020-05-26 05:34 UTC, Adios Kid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Henke 2019-10-20 07:59:57 UTC
ninja: error: '/var/tmp/portage/media-libs/musicbrainz-5.1.0/work/libmusicbrainz-5.1.0/src/*.inc', needed by 'include/musicbrainz5/mb5_c.h', missing and no known rule to make it
Comment 1 Jan Henke 2019-10-20 08:00:23 UTC
emerge --info '=media-libs/musicbrainz-5.1.0::gentoo'                                                                                                            
Portage 2.3.76 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop/gnome, gcc-8.3.0, glibc-2.29-r2, 4.19.66-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.66-gentoo-x86_64-Intel-R-_Core-TM-_i7-5500U_CPU_@_2.40GHz-with-gentoo-2.6
KiB Mem:     8128252 total,   1411164 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of repository gentoo: Sun, 20 Oct 2019 00:45:01 +0000
Head commit of repository gentoo: 72a45b5c86feaf35ba9949296c549b1454a04b13
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CC="clang"
CFLAGS="-march=native -ftree-vectorize -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.6/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXX="clang++"
CXXFLAGS="-march=native -ftree-vectorize -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms sign splitdebug strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de de_DE en en_GB vi vi_VN"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth bzip2 cairo cdda cdr clang cli client colord crypt cups cxx dbus dri dts dvd dvdr eds egl elogind emboss encode evo exif fam flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv icu introspection ipv6 jpeg lcms ldap libedit libnotify libsecret libtirpc lto mad mng mp3 mp4 mpeg multilib nautilus ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf pic pie png policykit ppds pulseaudio qt5 readline sdl seccomp spell split-usr ssl ssp startup-notification svg symlink system-llvm tcpd threads tiff tracker truetype udev udisks unicode upower usb vim-syntax vorbis vulkan wayland wxwidgets x264 xattr xcb xml xv xvid zeroconf zlib zsh-completion" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 aes avx avx2 fma3 popcnt sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="de de-DE en en-GB vi vi-VN" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="x86_64" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="i965 intel iris" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-libs/musicbrainz-5.1.0::gentoo was built with the following:
USE="-examples -test" ABI_X86="(64)"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
Comment 2 Jan Henke 2019-10-20 08:00:54 UTC
emerge -pqv '=media-libs/musicbrainz-5.1.0::gentoo'                                                                                                              
[ebuild   R   ] media-libs/musicbrainz-5.1.0  USE="-examples -test"
Comment 3 Jan Henke 2019-10-20 08:02:27 UTC
Created attachment 593374 [details]
build.log
Comment 4 Jan Henke 2019-10-20 08:03:05 UTC
Created attachment 593376 [details]
build environment
Comment 5 Jan Henke 2019-10-22 07:43:05 UTC
I have hit this bug on multiple machines now. Unfortunately I cannot set it to confirmed.
Comment 6 Jan Henke 2019-11-03 20:44:09 UTC
I have found an upstream pull request which looks like fixing this exact issue. It would also explain why I was able to build this version in the past: The issues seems to be that ninja does not handle wildcard dependencies.

Please add the small patch from https://github.com/metabrainz/libmusicbrainz/pull/16 to the ebuild, there does not seem to be a release including this change as of today.
Comment 7 cyrillic 2020-03-25 02:02:03 UTC
Created attachment 625436 [details, diff]
no_wildcards.patch

I have no idea why it took me so long to hit this bug, but that patch does fix the problem.
Comment 8 Toralf Förster gentoo-dev 2020-03-26 19:09:53 UTC
*** Bug 714808 has been marked as a duplicate of this bug. ***
Comment 9 mechtech737 2020-03-27 02:04:55 UTC
I had also built this without issue before,but your patch does fix the current issue. Thanks.
Comment 10 jospezial 2020-04-06 15:21:52 UTC
musicbrainz-5.1.0 was sleeping since 2017 on my disk without the need to rebuild or update.
Compiles with that patch.

v5.1.0
adhawkins released this on 13 Nov 2014 · 35 commits to master since this release

How about a live ebuild until a new upstream version comes?
Comment 11 Mart Raudsepp gentoo-dev 2020-04-16 06:59:57 UTC
*** Bug 715762 has been marked as a duplicate of this bug. ***
Comment 12 Leonid Kopylov 2020-04-16 07:28:22 UTC
I can confirm that this patch works for me
Comment 13 Jesus Rivero 2020-05-14 17:36:43 UTC
Created attachment 639074 [details, diff]
Fixes wildcard issues with cmake

Can confirm that having *.inc directly in the depends, doesn't work for me.
In order to avoid listing the inline files directly, I made this patch which also works for me.
Comment 14 Adios Kid 2020-05-26 05:34:12 UTC
Created attachment 641806 [details]
media-libs/musicbrainz-5.1.0-r1

ebuild with the latest commit
Comment 15 Andreas Sturmlechner gentoo-dev 2020-06-04 19:56:57 UTC
*** Bug 714744 has been marked as a duplicate of this bug. ***
Comment 16 Andreas Sturmlechner gentoo-dev 2020-06-04 19:57:20 UTC
*** Bug 727162 has been marked as a duplicate of this bug. ***
Comment 17 Larry the Git Cow gentoo-dev 2020-06-04 20:07:41 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2e3353efaacf80e2ac04c3ef59bc91db4fe62937

commit 2e3353efaacf80e2ac04c3ef59bc91db4fe62937
Author:     William Breathitt Gray <vilhelm.gray@gmail.com>
AuthorDate: 2020-05-01 18:11:10 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-06-04 20:07:22 +0000

    media-libs/musicbrainz: Fix CMake error
    
    This fixes a build error caused by improper use of wildcards in the
    project's src/CMakelists.txt file.
    
    Closes: https://bugs.gentoo.org/698090
    Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
    Closes: https://github.com/gentoo/gentoo/pull/15600
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/musicbrainz-5.1.0-no-wildcards.patch     | 27 ++++++++++++++++++++++
 media-libs/musicbrainz/musicbrainz-5.1.0.ebuild    |  2 ++
 2 files changed, 29 insertions(+)