Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 697694 - [science overlay] sci-mathematics/scilab-5.5.2-r1 depends on >=dev-java/batik-1.8-r2:1.8 which can no longer be resolved
Summary: [science overlay] sci-mathematics/scilab-5.5.2-r1 depends on >=dev-java/batik...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Overlays (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
Depends on:
Reported: 2019-10-14 08:26 UTC by Serge
Modified: 2019-10-14 08:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Serge 2019-10-14 08:26:51 UTC
When I tried to emerge scilab I got the message there are no ebuilds to satisfy batik-1.8-r2 even though batik 1.9 is the stable version on the official Gentoo repos. Presumably this is related to the fact that the ebuild wants to get that specific version of batik even though in the CDEPEND there is a >= in front of the version of batik

Reproducible: Always

Steps to Reproduce:
1.Add the overlay science
2.emerge scilab
Actual Results:  
I got the message there are no ebuilds to satisfy batik-1.8-r2 

Expected Results:  
As the CDEPEND mentions >= batik-1.8-r2 there should be no problem

I think some lines of the ebuild require the version 1.8-r2 of batik which is unavailable on the Gentoo repos and in some overlay.
The ebuild has to be rewritten to match the actual version of batik.