Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 697676 - x11-misc/adriconf - Advanced DRI Configurator, a GUI tool used to configure open source graphics drivers
Summary: x11-misc/adriconf - Advanced DRI Configurator, a GUI tool used to configure o...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL: https://github.com/jlHertel/adriconf
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2019-10-13 22:17 UTC by cazzantonio
Modified: 2021-04-18 01:11 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
WiP ebuild based on poly-c ebuild for 1.6 (adriconf-2.4.ebuild,1.48 KB, text/plain)
2020-10-01 22:05 UTC, Pascal Flöschel
Details
adriconf 2.4 ebuild (adriconf-2.4.ebuild,1.47 KB, text/plain)
2020-10-06 17:52 UTC, mercuriete
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cazzantonio 2019-10-13 22:17:51 UTC
driconf depends on python2, which will be officially deprecated in two months.
driconf is not updated from 2013, now ardiconf should be used as a replacement:
https://github.com/jlHertel/adriconf

please deprecate driconf and add adriconf to the ebuilds

Reproducible: Always
Comment 1 Pascal Flöschel 2020-10-01 22:05:22 UTC
Created attachment 663478 [details]
WiP ebuild based on poly-c ebuild for 1.6

I modified the ebuild found in poly-c overlay to latest version on it's new home at https://gitlab.freedesktop.org/mesa/adriconf. It compiles and merges. I am not familiar with writing ebuilds so please improve.
Comment 2 mercuriete 2020-10-06 17:52:08 UTC
Created attachment 664108 [details]
adriconf 2.4 ebuild

Hi I dont know how to contribute to this issue.

I created an ebuild copiying  it from an overlay and fixing it because adriconf now is in another repository.

I think I copied from poly-c 1.6 and then updated to 2.4


Please somebody from gentoo help me to contribute.
Comment 3 mercuriete 2020-10-06 17:54:16 UTC
yeah, it seems my ebuild its exactly the same as comment #3
sorry for the noise.
Comment 4 mercuriete 2020-10-06 18:04:26 UTC
actually not.
my ebuild points to the proper repo...

I will try to do a PR to gentoo.
Comment 5 mercuriete 2020-10-06 18:56:03 UTC
I did a PR here: https://github.com/gentoo/gentoo/pull/17826

I hope this helps to somebody. :)
Comment 6 Dmitri Seletski 2020-12-28 22:39:36 UTC
I suspect missing this binary prevents me from enjoying my hard earned Dying Light. Bump.
Comment 7 Guillaume Gelin 2021-03-04 08:30:53 UTC
Is there anything that blocks this PR from getting merged?