Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 697658 - media-libs/libsdl2 : add USE=jack
Summary: media-libs/libsdl2 : add USE=jack
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2019-10-13 19:57 UTC by Dominique Michel
Modified: 2020-01-27 21:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
libsdl2 ebuild with jack USE flag (libsdl2-2.0.10.ebuild,5.67 KB, text/plain)
2019-10-13 20:22 UTC, Dominique Michel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Michel 2019-10-13 19:57:27 UTC
libsdl2 have jack support. The ebuild don't have any jack USE, which imply jack support will be enabled and compiled if configure find the jack-audio-connection-kit files, and it will be skipped if it doesn't find them.

Also note than, on my system, for an sdl application to use jack audio, it have to be run with:

SDL_AUDIODRIVER="jack" my_sdl_app

So maybe the ebuild must also have an USE conditional elog message about this.

Reproducible: Always

Steps to Reproduce:
1. emerge media-sound/jack-audio-connection-kit
2. emerge media-libs/libsdl2
3.
Comment 1 Dominique Michel 2019-10-13 20:22:35 UTC
Created attachment 592662 [details]
libsdl2 ebuild with jack USE flag
Comment 2 Ionen Wolkens 2020-01-27 02:18:43 UTC
Any update on this? I've had EXTRA_ECONF="--disable-jack-shared --enable-jack" for a long time with the virtual/jack dependency missing.

Since it's my default audio output I preferred it not to be dynamically loaded too (--disable-jack-shared makes it have same behavior as libasound/libpulse and actually link against libjack.so).
Comment 3 Larry the Git Cow gentoo-dev 2020-01-27 21:07:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=681d4c0b1d09199bec912a3bcd959f6ae89cedd5

commit 681d4c0b1d09199bec912a3bcd959f6ae89cedd5
Author:     James Le Cuirot <chewi@gentoo.org>
AuthorDate: 2020-01-27 20:58:29 +0000
Commit:     James Le Cuirot <chewi@gentoo.org>
CommitDate: 2020-01-27 21:07:30 +0000

    media-libs/libsdl2: Add jack USE flag
    
    Closes: https://bugs.gentoo.org/697658
    Package-Manager: Portage-2.3.85, Repoman-2.3.20
    Signed-off-by: James Le Cuirot <chewi@gentoo.org>

 media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild | 193 ++++++++++++++++++++++++++++
 1 file changed, 193 insertions(+)