Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 69707 - suggestion to attach ndiswrapper to further liveCDs
Summary: suggestion to attach ndiswrapper to further liveCDs
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 101940 113797 125016 149338 218538 219870 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-01 05:00 UTC by Milosz Kosobucki
Modified: 2008-04-30 19:36 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milosz Kosobucki 2004-11-01 05:00:29 UTC
Is there any possibility to enclose ndiswrapper to further LiveCDs?? Ndiswrapper is a great application that gives opprtunity to use various wireless cards without proper linux drivers, you just have to fetch windows XP drivers and tell ndiswrapper to use them. Ndiswrapper translates windows drivers commands to linux kernel commands and the WiFi card can work. Ndiswrapper is also easy to configure and use.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Doug Goldstein gentoo-dev 2004-11-19 23:54:03 UTC
I like it.... but we won't be able to provide the Windows drivers on the LiveCD do to licensing. The user will have to dig out their own Windows driver CDs... which of course you can't swap a CD while booted off the LiveCD so they'd have to have it on a floppy or a USB key device.

The usefulness as a result goes way down.
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2004-11-20 06:16:13 UTC
Actually, you could boot the LiveCD with docache and swap the CD.  However, we have no intention of providing this functionality on the LiveCD.  In fact, we're not in the market for adding any new applications to the LiveCD, as we are shifting direction for the future releases.
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2005-08-09 23:02:03 UTC
*** Bug 101940 has been marked as a duplicate of this bug. ***
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-28 08:48:08 UTC
*** Bug 113797 has been marked as a duplicate of this bug. ***
Comment 5 Milosz Kosobucki 2005-11-29 14:47:03 UTC
Hmm, but I think that it is better to give SOME chance to establish wireless
connection (through floppy or whatever) than NO chance. Program binary + module
is about 210 KB large. When LiveCD said A with wireless, B should also be said
with drivers.
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-29 15:59:27 UTC
You are more than welcome to do a networkless installation.
Comment 7 Charles Christie 2005-11-29 16:25:27 UTC
Yeah, but some of the packages I want aren't on the liveCD. So how am I supposed
to download NDISWrapper to install it in the first place if my 'net isn't up?
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-29 17:02:46 UTC
The exact same way you would install the Windows driver anyway, using a USB
key/floppy/another CD.  You can think of lots of ways, I'm sure.  Any way that
you would employ to get the Windows driver into the system, you could use to get
the ndiswrapper distfiles, too.  Therefore, there is *no point* in us having
ndiswrapper on the CD.
Comment 9 Andrew Gaffney (RETIRED) gentoo-dev 2006-03-04 14:30:40 UTC
*** Bug 125016 has been marked as a duplicate of this bug. ***
Comment 10 Mike Green 2006-03-15 16:12:59 UTC
As requested in http://www.mail-archive.com/gentoo-releng%40lists.gentoo.org/msg00216.html, I would like to request ndiswrapper be placed on the gentoo minimal and livecd release media.  Most of reasons for wanting it are documented in various posts to the Gentoo Chat forum topic titled "NDISWRAPPER on the livecd" (http://forums.gentoo.org/viewtopic-t-442611.html).

I would like to be able to use the gentoo release media to install via wireless cards that are not supported by wpa_supplicant (wep -vs- wpa) and do not currently have native driver support.  More importantly I would like to be able to perform rescue/maintenance tasks using the official gentoo release media while using wireless cards that will only function using ndiswrapper.

I am not asking for official support for this installation method or for any 3rd party drivers to be included, only for the (gpl) ndiswrapper kernel module and utilities to be present and usable on the media.

From reading the responses below I see no real technical reasons why ndiswrapper could/should not be included on the media.  Wireless cards are very commonly shipped on modern hardware and it does not seem to be unreasonable to want to make gentoo installation available to those of us who have chipsets that are not supported natively.
Comment 11 Charles Christie 2006-03-18 06:21:21 UTC
not to mention that, unless you include the kernel source code on the CDs, we can't install it ourselves durring the install because the kernel is a binary, as far as I know.
Comment 12 Chris Gianelloni (RETIRED) gentoo-dev 2006-03-20 09:18:09 UTC
Alright, I am going to make this point *exactly* one more time, then I am ignoring any more responses on this bug, as you simply are not going to be able to convinve me otherwise.

I will not add ndiswrapper to the Gentoo release media.  You are more than welcome to do a networkless installation.  If that does not appeal to you, then there is the alternate installation guide that explains how to use another CD to perform a Gentoo installation.

It really boils down to one thing: support.  I refuse to waste my time, or any other Gentoo developer's time, supporting Windows drivers.  While ndiswrapper itself might be GPL, it uses components that are not and that are 100% beyond our control.  This is an absolute nightmare for support, and an endeavour that I would rather not ever commit myself to working.  I simply refuse to add anything requiring Windows components onto our CD releases due to both personal *and* technical reasons.  While I understand that this won't sit well with some users, I am prepared for that and willing to accept responsibility for telling them that this request will not be filled.  I would much rather tell a user no than to spend *any* time providing support on drivers that are 100% beyond my control.  While we could patch ndiswrapper for problems, what happens if the problem is the driver itself?  I would much rather tell a user that we do not support drivers via ndiswrapper than to spend any more time on attempting to support it.  After all, as you are already required to bring your own files to the CD with ndiswrapper, what is the difference between pulling in the driver files, and pulling in the driver files *and* the distfiles?  I'm sure some of you are going to come back with some argument about how you want to do a networked installation, but it is simply going to fall on deaf ears.

You have a perfectly valid installation method in the networkless install.  At that point, you can install ndiswrapper to your heart's content.  You don't need sources on the LiveCD, and you don't need support from Gentoo to accomplish this.  We have provided a method to work around the fact that you have hardware that does not work without Windows drivers, and it is the networkless install.
Comment 13 Andrew Gaffney (RETIRED) gentoo-dev 2006-09-27 12:17:53 UTC
*** Bug 149338 has been marked as a duplicate of this bug. ***
Comment 14 GregS 2006-10-04 12:35:15 UTC
(In reply to comment #13)
> *** Bug 149338 has been marked as a duplicate of this bug. ***
> 

There is lot of application on liveCD or MinimalCD that are not using by user - for example - if I am not partitioning my CD, I am not using fdisk - etc.
You are talking about networkless installation - isn't it gentoo about choice?. If so - why you tell me what is the way I should install my gentoo?. 
You are telling me also - that ndiswrapper is beyond your control. If you give a knife in someones hands, that person can use it for bread or for your throat. So maybe we should tell everybody that knifes are forbiden item, because they are beyond our control?.
Putting the ndiswrapper on CD is like giving a choice - IF I WANT TO USE IT - I will, if no, I don't. You are not forcing anyone to use it, you are not forcing anyone to use windows driver - you are giving a choice. Thats it.
Comment 15 Andrew Gaffney (RETIRED) gentoo-dev 2006-10-04 13:58:12 UTC
First, we don't provide a knife with the CDs, so your analogy is stupid.

Second, Chris's point was that he (and I) don't want to support ndiswrapper, and if it's on a release CD, users will expect support, regardless of how big and colorful the letters are that say "ndiswrapper isn't supported".

Third, since you're so big on choice, you can *choose* to use catalyst to build your own CD that includes ndiswrapper, or even *choose* to just use a Knoppix CD (or whatever bootable CD happens to include ndiswrapper) to do your install.
Comment 16 Andrew Gaffney (RETIRED) gentoo-dev 2008-04-20 11:57:23 UTC
*** Bug 218538 has been marked as a duplicate of this bug. ***
Comment 17 Chris Gianelloni (RETIRED) gentoo-dev 2008-04-30 19:36:02 UTC
*** Bug 219870 has been marked as a duplicate of this bug. ***